Bug 490554 - corrupt SRPM available from mirrors
corrupt SRPM available from mirrors
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: jabberd (Show other bugs)
rawhide
All Linux
low Severity urgent
: ---
: ---
Assigned To: Adrian Reber
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-16 19:17 EDT by Graham Leggett
Modified: 2009-03-17 06:47 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-17 02:46:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Graham Leggett 2009-03-16 19:17:54 EDT
The developement version of the jabberd v2.2.7.1 SRPM available on mirrors is corrupt:

[minfrin@chandler ~]$ rpmbuild --rebuild jabberd-2.2.7.1-1.fc11.src.rpm 
Installing jabberd-2.2.7.1-1.fc11.src.rpm
warning: InstallSourcePackage: Header V3 RSA/SHA256 signature: NOKEY, key ID d22e77f2
warning: user mockbuild does not exist - using root
warning: group mockbuild does not exist - using root
error: unpacking of archive failed on file /home/chandler/minfrin/rpm/SOURCES/jabberd;49bedd3d: cpio: MD5 sum mismatch
error: jabberd-2.2.7.1-1.fc11.src.rpm cannot be installed
Comment 1 Adrian Reber 2009-03-17 02:46:33 EDT
This sounds a lot like you are using a version of rpm which is too old, because the SRPM on my mirror works. Which version of RPM are you using?
Comment 2 Graham Leggett 2009-03-17 05:56:05 EDT
The version of RPM in use is the one currently shipped with the most recent and up-to-date version of Redhat Enterprise 5:

[minfrin@chandler ~]$ rpm -q -a | grep rpm
rpm-python-4.4.2.3-9.el5
rpm-libs-4.4.2.3-9.el5
rpm-4.4.2.3-9.el5
rpm-devel-4.4.2.3-9.el5

I don't see how the version of RPM would cause an MD5 sum mismatch, unless new versions of RPM are broken.
Comment 3 Adrian Reber 2009-03-17 06:07:14 EDT
Rawhide RPM changed to use stronger hashes. Old RPM version (like yours) cannot handle it anymore. See https://fedoraproject.org/wiki/Features/StrongerHashes

There are unofficial RPMs available which can help you:
http://people.redhat.com/mitr/sha256-rpm/
Comment 4 Graham Leggett 2009-03-17 06:12:33 EDT
Then this is a Redhat Enterprise bug. To support stronger hashes in Fedora but then not bother in RHEL5 is a serious case of dropping the ball.
Comment 5 Adrian Reber 2009-03-17 06:47:21 EDT
(In reply to comment #4)
> Then this is a Redhat Enterprise bug. To support stronger hashes in Fedora but
> then not bother in RHEL5 is a serious case of dropping the ball.  

But I cannot help you here. That is something which you can only solve by contacting Red Hat.

Note You need to log in before you can comment on or make changes to this bug.