Bug 490568 - kdm restart merely hangs system
Summary: kdm restart merely hangs system
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: kdebase-workspace
Version: 10
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Than Ngo
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-03-17 00:47 UTC by Tom Horsley
Modified: 2009-03-17 22:53 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-03-17 22:53:00 UTC
Type: ---


Attachments (Terms of Use)

Description Tom Horsley 2009-03-17 00:47:38 UTC
Description of problem:

Using kdm as display manager, Click on Menu, Click on Shutdown..., Click
on Restart in the resulting dialog. Screen switches to text from the
last boot, with 5 square boxes added to the last line on the screen. System
turns into a brick that cannot do anything but display that screen. Hit
reset button after giving it several times longer than it normally takes
to reboot.

Version-Release number of selected component (if applicable):
kdebase-workspace-4.2.0-8.fc10.x86_64

How reproducible:
I only tried it once since I don't really like to hang my machine.

Steps to Reproduce:
1. see above
2.
3.
  
Actual results:
Hang.

Expected results:
Reboot.

Additional info:

Comment 1 Rex Dieter 2009-03-17 00:57:54 UTC
Odd indeed, since pressing restart is essentially the same as issuing:
/sbin/reboot 
from a commandline (see /etc/kde/kdm/kdmrc for RebootCmd= option).


It is likely this is an X mode setting issue, where switching from X/gui to text/console, may be the real issue.  Can you provide details on what video hw/driver you are using?

Comment 2 Tom Horsley 2009-03-17 01:18:53 UTC
I certainly have no problem doing something like Ctrl-Alt-F2, logging in
as root, and typing reboot, or using the restart button from GDM, but
here's the info:

I've got the rpmfusion nvidia drivers installed:

kmod-nvidia-2.6.27.15-170.2.24.fc10.x86_64-180.29-1.fc10.x86_64
akmod-nvidia-180.29-1.fc10.x86_64
kmod-nvidia-2.6.27.12-170.2.5.fc10.x86_64-180.27-1.fc10.x86_64
kmod-nvidia-2.6.27.19-170.2.35.fc10.x86_64-180.29-1.fc10.1.x86_64
xorg-x11-drv-nvidia-libs-180.29-1.fc10.x86_64
xorg-x11-drv-nvidia-180.29-1.fc10.x86_64
kmod-nvidia-180.29-1.fc10.1.x86_64

The video card is:

(II) NVIDIA(0): NVIDIA GPU GeForce 6200 LE (NV44) at PCI:5:0:0 (GPU-0)
(--) NVIDIA(0): Memory: 524288 kBytes
(--) NVIDIA(0): VideoBIOS: 05.44.02.45.00
(II) NVIDIA(0): Detected PCI Express Link width: 16X

Comment 3 Rex Dieter 2009-03-17 02:19:11 UTC
Having been part of disasterous bughunting sessions where nvidia drivers were involved, I hope you don't mind if I ask to see if you can reproduce this on a system free of nvidia's kmods and libraries.

Comment 4 Tom Horsley 2009-03-17 21:41:06 UTC
I've tried to reproduce this several different ways, and it has not
hung again (even with the nvidia drivers still in use). Apparently it
is random with low frequency or was a one time event due to cosmic
rays or something :-).

Perhaps many login attempts due to bug 490566 got the video in some
state where the hang was a consequence when I tried to restart (but I even
tried the failing login a few times and restart still works).

Comment 5 Rex Dieter 2009-03-17 22:53:00 UTC
OK, reopen if it happens again.


Note You need to log in before you can comment on or make changes to this bug.