Bug 490602 - git-cvsimport got noisy
git-cvsimport got noisy
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: git (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Todd Zullinger
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-17 05:12 EDT by David Woodhouse
Modified: 2013-01-10 05:31 EST (History)
4 users (show)

See Also:
Fixed In Version: 1.6.0.6-4.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-24 15:17:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description David Woodhouse 2009-03-17 05:12:09 EDT
I have a lot of cron jobs importing things into git from legacy version control systems such as cvs, svn, hg, etc. 

Since upgrading to Fedora 10, the git-cvsimport cron jobs have got very noisy, constantly sending mail with messages like this...

* UNKNOWN LINE * Branches: IBM
* UNKNOWN LINE * Branches: 
* UNKNOWN LINE * Branches: 
* UNKNOWN LINE * Branches: 
* UNKNOWN LINE * Branches: 
* UNKNOWN LINE * Branches: 
* UNKNOWN LINE * Branches: 

or 

branch #CVSPS_NO_BRANCH not found in global branch hash
branch #CVSPS_NO_BRANCH not found in global branch hash
branch #CVSPS_NO_BRANCH not found in global branch hash
branch #CVSPS_NO_BRANCH not found in global branch hash
branch #CVSPS_NO_BRANCH not found in global branch hash
branch #CVSPS_NO_BRANCH not found in global branch hash
Comment 1 Todd Zullinger 2009-03-19 16:17:36 EDT
These appear to come from cvsps and were added in cvsps-2.2b1 (F-9 still ships 2.1).

I think you can quiet them by using the -q flag to cvsps (I think more fine grained control can be had with the cvsps --debuglvl flag, though the documentation on that is pretty sparse, so you might have trawl through the source a bit for details).

Options to cvsps can be passed with git-cvsimport using the -p flag.  Might that help restore your cron mail output to a more reasonable level?
Comment 2 David Woodhouse 2009-03-21 06:04:21 EDT
cvsps is already passed the -q option. The UNKNOWN LINE output comes from git-cvsimport, not from cvsps, and that's the majority of what I'm now seeing.

I'll file a separate bug for the '#CVSPS_NO_BRANCH' one.


[dwmw2@bombadil ~]$ cvsps --norc -q -q --cvs-direct -u -A --root :pserver:anonymous@tahini.csx.cam.ac.uk:/repo exim/exim-src > cvsps-output
[dwmw2@bombadil ~]$  git-cvsimport -A ~/exim-cvs-authors -i -o master -d :pserver:anonymous@tahini.csx.cam.ac.uk:/repo exim/exim-src -P cvsps-output 
* UNKNOWN LINE * Branches: 
* UNKNOWN LINE * Branches: 
* UNKNOWN LINE * Branches: 
* UNKNOWN LINE * Branches: 
* UNKNOWN LINE * Branches: 
* UNKNOWN LINE * Branches: 
* UNKNOWN LINE * Branches: 
* UNKNOWN LINE * Branches: 
* UNKNOWN LINE * Branches: 
* UNKNOWN LINE * Branches: 
* UNKNOWN LINE * Branches: 
* UNKNOWN LINE * Branches: 
* UNKNOWN LINE * Branches: 
* UNKNOWN LINE * Branches: 
* UNKNOWN LINE * Branches: 
* UNKNOWN LINE * Branches: 
...
Comment 3 Todd Zullinger 2009-03-23 00:27:18 EDT
Hmm, that's caused by one of the changes in cvsps-2.2b1.  Someone asked about this on the git list last May and it gathered very little response:

    http://thread.gmane.org/gmane.comp.version-control.git/81426

I'm not sure what the best plan would be.  I have little desire to do a lot of work on git-cvsimport.perl, and it seems no one upstream does either.  But cvsps seems to be in even worse shape.

Perhaps we should at least patch git-cvsimport.perl to ignore the new Branches: lines, until someone gets the urge to make cvsimport parse them or converts it to something other than cvsps.  Something like this maybe?

diff --git i/git-cvsimport.perl w/git-cvsimport.perl
index e439202..d020f1a 100755
--- i/git-cvsimport.perl
+++ w/git-cvsimport.perl
@@ -952,7 +952,7 @@ while (<CVS>) {
 	} elsif (/^-+$/) { # end of unknown-line processing
 		$state = 1;
 	} elsif ($state != 11) { # ignore stuff when skipping
-		print STDERR "* UNKNOWN LINE * $_\n";
+		print STDERR "* UNKNOWN LINE * $_\n" unless /^Branches: /;
 	}
 }
 commit() if $branch and $state != 11;
Comment 4 Fedora Update System 2009-06-19 22:22:41 EDT
git-1.6.0.6-4.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/git-1.6.0.6-4.fc10
Comment 5 Fedora Update System 2009-06-19 22:24:24 EDT
git-1.6.0.6-4.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/git-1.6.0.6-4.fc9
Comment 6 Fedora Update System 2009-06-24 15:17:15 EDT
git-1.6.0.6-4.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2009-06-24 15:28:24 EDT
git-1.6.0.6-4.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.