Bug 490628 - the quota is ineffective while mount ext4 fs with delalloc option
the quota is ineffective while mount ext4 fs with delalloc option
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Eric Sandeen
Fedora Extras Quality Assurance
http://marc.info/?l=linux-ext4&m=1233...
:
Depends On:
Blocks: F11Target
  Show dependency treegraph
 
Reported: 2009-03-17 07:39 EDT by Gui Xiaohua
Modified: 2013-01-10 00:06 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Quota on ext4 filesystems is not working correctly when the default delayed allocation mode is enabled. Mounting with -o nodelalloc should resolve this issue in the near term, and the upstream 2.6.30 will have this fixed properly for a future F11 kernel update.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-11 17:57:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Gui Xiaohua 2009-03-17 07:39:37 EDT
Description of problem:
 the quota is ineffective while mount ext4 fs with delalloc option,
 but if I mount ext4 fs with nodelalloc,the quota is effective.

 Version-Release number of selected component (if applicable):
 Fedora-11-Alpha

 How reproducible:

 Steps to Reproduce:
 1.mkfs.ext4 /dev/sda7
 2.mount -t ext4 -o usrquota /dev/sda7 /mnt
 3.quotacheck -avug
 4.quotaon -avug
 5.setquota -u quser1 5 10 0 0 /mnt
 6.chmod 777 /mnt
 7.su quser1
 8.dd if=/dev/zero of=/mnt/file count=30
 9.sync
   
 Actual results:
 # quota -u quser1
 Disk quota for user quser1(uid 501)
 Filesystem  blocks  quota  limit  grace      files  quota   limit  grace
 /dev/sda7     16       5      10    7days      1       0       0       0    


 Expected results:
 # quota -u quser1
 Disk quota for user quser1(uid 501)
 Filesystem  blocks  quota  limit    grace      files  quota   limit  grace
 /dev/sda7     10       5      10    7days      1       0       0       0 

 Additional info:
Comment 1 Phil Knirsch 2009-03-17 08:06:38 EDT
Reassigning to kernel component.

Thanks & regards, Phil
Comment 2 Chuck Ebbert 2009-04-23 22:21:02 EDT
commit 60e58e0f30e723464c2a7d34b71b8675566c572d apparently fixes this
Comment 3 Gui Xiaohua 2009-04-24 01:15:12 EDT
(In reply to comment #2)
> commit 60e58e0f30e723464c2a7d34b71b8675566c572d apparently fixes this  

I don't consider the patch fixes the problem already, i tested the patch
Comment 4 Eric Sandeen 2009-04-27 11:38:06 EDT
That commit has a lot of dependencies....

You might test the latest Rawhide kernel to see if it's working better, it should have all of the upstream quota fixes to date.

-Eric
Comment 5 Eric Sandeen 2009-05-11 17:57:08 EDT
From some brief testing, the 2.6.30 kernel should have this fixed (or at least working better?  For very small quota values I see some issues, but it generally seems to be working)

I won't be able to pull those chagnes into the initial F11 release, but when the .30 kernel hits F11 as an update it should be fixed.

Sorry for not having it working in GA, we'll add a release note about this issue.

Closing RAWHIDE for now, if you can test a rawhide kernel and still encounter quota bugs, please let me know.

Thanks,
-Eric
Comment 6 Eric Sandeen 2009-05-11 17:57:08 EDT
Release note added. If any revisions are required, please set the 
"requires_release_notes" flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

New Contents:
Quota on ext4 filesystems is not working correctly when the default delayed allocation mode is enabled.  Mounting with -o nodelalloc should resolve this issue in the near term, and the upstream 2.6.30 will have this fixed properly for a future F11 kernel update.

Note You need to log in before you can comment on or make changes to this bug.