Bug 490641 - exception instead of partition visualisation
exception instead of partition visualisation
Status: CLOSED DUPLICATE of bug 489991
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
anaconda_trace_hash:23646d855fc6f4475...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-17 09:15 EDT by Tomasz Torcz
Modified: 2009-03-26 15:30 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-26 15:30:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (62.07 KB, text/plain)
2009-03-17 09:15 EDT, Tomasz Torcz
no flags Details
Attached traceback automatically from anaconda. (101.01 KB, text/plain)
2009-03-17 13:14 EDT, Jan Bušta
no flags Details

  None (edit)
Description Tomasz Torcz 2009-03-17 09:15:30 EDT
The following was filed automatically by anaconda:
anaconda 11.5.0.29 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/iw/partition_gui.py", line 815, in populate
    " tree" % partName)
  File "/usr/lib/anaconda/iw/partition_gui.py", line 1341, in getScreen
    self.populate(initial = 1)
  File "/usr/lib/anaconda/gui.py", line 1401, in setScreen
    new_screen = self.currentWindow.getScreen(anaconda)
  File "/usr/lib/anaconda/gui.py", line 1318, in nextClicked
    self.setScreen ()
RuntimeError: can't find partition sdb1 in device tree
Comment 1 Tomasz Torcz 2009-03-17 09:15:38 EDT
Created attachment 335522 [details]
Attached traceback automatically from anaconda.
Comment 2 Tomasz Torcz 2009-03-17 09:20:50 EDT
"Disks" were:
sda - 8 GB image in VirtualBox, MSDOS partition, which previously half-installed fedora 11
sda1 - /boot, ext3
sda2 - swap
sda3 - btrfs

sdb -12 GB image, no partitions, ext4 filesystem.
Comment 3 Chris Lumens 2009-03-17 10:03:03 EDT
Is this better with anaconda-11.5.0.31?
Comment 4 Jan Bušta 2009-03-17 13:14:02 EDT
Created attachment 335564 [details]
Attached traceback automatically from anaconda.
Comment 5 Tomasz Torcz 2009-03-18 07:40:49 EDT
Sadly not better. I've tested with boot.iso from today (size 174084096).
BTW, as sda has some partition I want to reuse, I selected ,,create custom layout'' in anaconda.
Comment 6 Chris Lumens 2009-03-26 15:30:51 EDT
This appears to be a related problem of 489991 - we don't really support or handle detection of raw disks without partitions right now.

*** This bug has been marked as a duplicate of bug 489991 ***

Note You need to log in before you can comment on or make changes to this bug.