Bug 490675 - Got error msg " scsi 0:0:15:0 ABORT operation start " when running Guest on ia64
Got error msg " scsi 0:0:15:0 ABORT operation start " when running Guest on ia64
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xen (Show other bugs)
5.3
ia64 Linux
low Severity medium
: rc
: ---
Assigned To: Michal Novotny
Virtualization Bugs
:
Depends On:
Blocks: 492190
  Show dependency treegraph
 
Reported: 2009-03-17 11:55 EDT by lihuang
Modified: 2014-02-02 17:37 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-03 08:11:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description lihuang 2009-03-17 11:55:26 EDT
Description of problem:

After added a scsi device and boot the VM.
the following error is given:

scsi  0:0:15:0 ABORT operation start
scsi  0:0:15:0 ABORT operation time-out
scsi  0:0:15:0 DEVICE RESET operation started
scsi  0:0:15:0 DEVICE RESET operation time-out
scsi  0:0:15:0 BUS RESET operation started
scsi  0:0:15:0 BUS RESET operation time-out
scsi  0:0:15:0 HOST RESET operation started
sym0: SCSI BUS has been reset.
scsi  0:0:15:0 HOST RESET operation time-out



Version-Release number of selected component (if applicable):
[root@shangrila ~]# uname -a
Linux shangrila.nay.redhat.com 2.6.18-128.1.1.el5xen #1 SMP Mon Jan 26 14:17:35 EST 2009 ia64 ia64 ia64 GNU/Linux
[root@shangrila ~]# rpm -qa xen
xen-3.0.3-80.el5_3.2


How reproducible:
EveryTime

Steps to Reproduce:
1.install fully-virtualized  guest
2.Add an sisi device :
disk = [ "file:/var/lib/xen/images/Test.img,hda,w", ",hdc:cdrom,r",
"file:/var/lib/xen/images/New.img,sda,w" ]
3.boot the guest
4.run dmesg,  ls /dev/sda*, fdisk -l on the guest
  
Actual results:
Error msg is given.
the scsi disk is not present


Expected results:


Additional info:
Comment 1 Michal Novotny 2009-04-07 11:25:50 EDT
Well, I have tried to replicate it using the described scenario on 83-based version of Xen user-space tools and I have never seen this message.

Then I tried:
 1. xm create FVguest when device has been added as sda device to config file
 2. inGuest> dmesg -> no trace of error message about SCSI
 3. inGuest> ls /dev/sda* -> there is /dev/sda device (not partitioned yet)
 4. inGuest> fdisk -l -> no valid partition on /dev/sda
 5. inGuest> fdisk /dev/sda & created new partition, written using 'w' option
 6. inGuest> dmesg -> still no error message about SCSI

Could you tell me how to reproduce the problem and/or try to reproduce it using my RPMs at http://people.redhat.com/minovotn/xen ?

Thanks,
Michal
Comment 2 lihuang 2009-06-02 18:40:39 EDT
Hi.Michal
   I can not reproduce the issue in xen-3.0.3-80.el5_3.2 and your rpms now... ( the ia64 box is re-installed. and now works well.)
Comment 3 Michal Novotny 2009-06-03 04:46:46 EDT
Hi,
ok, so should I close it now if this is not the issue ? What reason?

Michal
Comment 4 Michal Novotny 2009-06-03 08:11:16 EDT
Ok, closing it. If this is still an issue please reopen it... thanks, Michal

Note You need to log in before you can comment on or make changes to this bug.