Bug 490695 - Spacewalk packages in RHN Tools channels are breaking older version of Proxy
Spacewalk packages in RHN Tools channels are breaking older version of Proxy
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
530
All Linux
urgent Severity urgent
: ---
: ---
Assigned To: Miroslav Suchý
Jan Pazdziora
:
Depends On:
Blocks: 456999
  Show dependency treegraph
 
Reported: 2009-03-17 13:00 EDT by Jeff Browning
Modified: 2009-09-10 10:37 EDT (History)
4 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 10:37:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Browning 2009-03-17 13:00:46 EDT
Description of problem:
Spacewalk packages are appearing in the RHN Tools channel for both RHEL4 and RHEL5, which is causing dependency issues when trying to install Proxy 5.2.

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. Install Satellite 5.2 and sync RHEL4 and 5 Base, Tools, and Proxy 5.2 channels from Web QA.
2. Attempt to install a proxy using this Satellite's Web UI proxy installer.
  
Actual results:
The package install fails:

This action will be executed after 2009-03-17 11:49:13 EDT.

This action's status is: Failed.
The client picked up this action on 2009-03-17 11:49:25 EDT.
The client completed this action on 2009-03-17 11:54:49 EDT.
Client execution returned "Failed: packages requested raised dependency problems" (code 18)
Packages Scheduled:

    * rhns-proxy-management-5.2.0-15.el4

Dependency errors encountered:

    * rhns-proxy-broker-5.2.0-15.el4 requires >= rhns-certs-tools-3.6.0
    * rhns-proxy-broker-5.2.0-15.el4 requires rhn-ssl-cert-check


Expected results:
The Proxy should install without error.

Additional info:
There packages appear in the RHN Tools channel and appear to be causing the problem:

spacewalk-certs-tools-0.5.2-1.el4sat.noarch   	
spacewalk-certs-tools-0.5.3-1.el4sat.noarch 	
spacewalk-koan-0.1.10-1.el4sat.noarch 	
spacewalk-koan-0.1.8-1.el4sat.noarch 	
spacewalk-proxy-installer-0.5.17-1.el4sat.noarch 
spacewalk-proxy-installer-0.5.19-1.el4sat.noarch
spacewalk-ssl-cert-check-1.5-1.el4sat.noarch
Comment 1 Miroslav Suchý 2009-03-18 10:13:00 EDT
Should be fixed by commit d9d33dd71c6e0d563c59d6b3894f702f2c90d9b5
Package: spacewalk-certs-tools-0.5.3-1
Comment 2 Miroslav Suchý 2009-03-18 10:40:31 EDT
spacewalk-ssl-cert-check fixed in commit 20ee2f4f8649dc3bfc059584bc31383e41f52f34
package: spacewalk-ssl-cert-check-1.6-1
Comment 4 Jan Pazdziora 2009-06-30 07:32:21 EDT
Installed RHEL 5, registered to Satellite 5.3.0, gave it provisioning entitlement, gave it Red Hat Network Tools for RHEL Server (v.5 32-bit x86) child channel. Started RHN Proxy 5.2 installation/activation via WebUI. Run rhn_check and all four actions

   Package Install: rhns-proxy-management-5.2.0-15.el5 - Queued
   Deploy Configuration - Queued
   Allow Proxy service to read Satellite Configuration - Queued
   Start Satellite Proxy - Queued

run OK. The http://fqdn-of-the-proxy-machine/ now shows RHN Proxy's title page.

The packages installed are

# rpm -qa | grep rhn | sort
rhncfg-5.9.5-3.el5sat
rhncfg-actions-5.9.5-3.el5sat
rhncfg-client-5.9.5-3.el5sat
rhn-check-0.4.13-1.el5
rhn-client-tools-0.4.13-1.el5
rhnlib-2.2.6-2.el5
rhns-5.2.0-15.el5
rhns-certs-tools-5.2.0-4.el5
rhnsd-4.6.1-1.el5
rhn-setup-0.4.13-1.el5
rhns-proxy-broker-5.2.0-15.el5
rhns-proxy-docs-5.2.0-15.el5
rhns-proxy-management-5.2.0-15.el5
rhns-proxy-package-manager-5.2.0-15.el5
rhns-proxy-redirect-5.2.0-15.el5
rhns-proxy-tools-5.2.0-15.el5
rhn-ssl-cert-check-1.4-10.7.el5
yum-rhn-plugin-0.4.3-1.el5

I consider this bugzilla VERIFIED.
Comment 5 Michael Mráka 2009-08-12 08:44:05 EDT
Verified in stage -> RELEASE_PENDING.

* registered RHEL4 x86_64 client to satellite 5.3.0
* installed Proxy 5.2.0 via webUI on it
Install progress

You are installing Satellite Proxy on this system. Below is the list of actions for this installation. 

Remove conflicting proxy packages - Completed
Package Installs - Completed
Deploy Configuration - Completed
Enable Monitoring Services - Completed
Allow Proxy service to read Satellite Configuration - Completed
Start Satellite Proxy - Completed

The installation is complete.

* installed proxy packages:
# rpm -qa | grep rhn | sort
rhn-base-minimal-5.2.0-16.el4.noarch
rhncfg-5.9.5-3.el4sat.noarch
rhncfg-actions-5.9.5-3.el4sat.noarch
rhncfg-client-5.9.5-3.el4sat.noarch
rhncfg-management-5.9.5-3.el4sat.noarch
rhnlib-2.1.4-7.el4.noarch
rhn-org-httpd-ssl-key-pair-sat-mim3-1.0-1.noarch
rhns-5.2.0-15.el4.noarch
rhns-proxy-broker-5.2.0-15.el4.noarch
rhns-proxy-docs-5.2.0-15.el4.noarch
rhns-proxy-management-5.2.0-15.el4.noarch
rhns-proxy-monitoring-5.2.0-2.el4.noarch
rhns-proxy-package-manager-5.2.0-15.el4.noarch
rhns-proxy-redirect-5.2.0-15.el4.noarch
rhns-proxy-tools-5.2.0-15.el4.noarch
Comment 6 Brandon Perkins 2009-09-10 10:37:56 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1433.html

Note You need to log in before you can comment on or make changes to this bug.