Bug 490761 - 500 error on "Manage Software Channels" with authenticated user session
500 error on "Manage Software Channels" with authenticated user session
Status: CLOSED CURRENTRELEASE
Product: Spacewalk
Classification: Community
Component: WebUI (Show other bugs)
0.5
All Linux
low Severity medium
: ---
: ---
Assigned To: Shannon Hughes
Red Hat Satellite QA List
:
Depends On:
Blocks: space06
  Show dependency treegraph
 
Reported: 2009-03-17 17:12 EDT by brennanrm
Modified: 2012-03-06 04:01 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-23 13:55:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description brennanrm 2009-03-17 17:12:43 EDT
Description of problem:
500 apache error occurs on "Manage Software Channels" with authenticated admin or admin level user session. 
spacewalk-0.5.4-1.fc10.noarch
 

[Tue Mar 17 16:55:22 2009] [notice] mod_python: Creating 4 session mutexes based on 256 max processes and 0 max threads.
[Tue Mar 17 16:55:22 2009] [notice] mod_python: using mutex_directory /tmp
[Tue Mar 17 16:55:23 2009] [notice] Apache/2.2.10 (Unix) DAV/2 mod_python/3.3.1 Python/2.5.2 mod_ssl/2.2.10 OpenSSL/0.9.8g mod_apreq2-20051231/2.6.1 mod_perl/2.0.4 Perl/v5.10.0 configured -- resuming normal operations
[Tue Mar 17 16:58:52 2009] [error] Execution of /var/www/html/network/software/channels/manage/index.pxt failed at Tue Mar 17 16:58:52 2009: user_role_acl_test called with no $pxt->user authenticated at /usr/lib/perl5/vendor_perl/5.10.0/RHN/Access.pm line 60.
[Tue Mar 17 16:58:53 2009] [error] Traceback sent to brennanrm@mail.gov at /usr/lib/perl5/vendor_perl/5.10.0/PXT/ApacheHandler.pm line 729.
[Tue Mar 17 16:58:54 2009] [error] Execution of /var/www/html/errors/500.pxt failed at Tue Mar 17 16:58:54 2009: RHN::Exception: RHN::DB connect('xe','spacewalk',...) failed: ORA-12519: TNS:no appropriate service handler found (DBD ERROR: OCIServerAttach)\n  RHN::DB /usr/lib/perl5/vendor_perl/5.10.0/RHN/DB.pm 233 RHN::Exception::DB::throw\n  DBI /usr/lib/perl5/vendor_perl/5.10.0/i386-linux-thread-multi/DBI.pm 650 RHN::DB::handle_error\n  DBI /usr/lib/perl5/vendor_perl/5.10.0/i386-linux-thread-multi/DBI.pm 706 DBI::__ANON__\n  RHN::DB /usr/lib/perl5/vendor_perl/5.10.0/RHN/DB.pm 224 DBI::connect\n  RHN::DB /usr/lib/perl5/vendor_perl/5.10.0/RHN/DB.pm 191 RHN::DB::direct_connect\n  RHN::DB::User /usr/lib/perl5/vendor_perl/5.10.0/RHN/DB/User.pm 2562 RHN::DB::connect\n  RHN::Access /usr/lib/perl5/vendor_perl/5.10.0/RHN/Access.pm 73 RHN::DB::User::satellite_has_users\n  PXT::ACL /usr/lib/perl5/vendor_perl/5.10.0/PXT/ACL.pm 94 RHN::Access::need_first_user\n  Sniglets::Navi::Node /usr/lib/perl5/vendor_perl/5.10.0/Sniglets/Navi/Node.pm 185 PXT::ACL::eval_acl\n  Sniglets::Navi /usr/lib/perl5/vendor_perl/5.10.0/Sniglets/Navi.pm 202 Sniglets::Navi::Node::visible\n  Sniglets::Navi /usr/lib/perl5/vendor_perl/5.10.0/Sniglets/Navi.pm 168 Sniglets::Navi::render_nav\n  Sniglets::Navi /usr/lib/perl5/vendor_perl/5.10.0/Sniglets/Navi.pm 128 Sniglets::Navi::format_nav\n  PXT::Parser /usr/lib/perl5/vendor_perl/5.10.0/PXT/Parser.pm 152 Sniglets::Navi::navi_nav\n  PXT::Parser /usr/lib/perl5/vendor_perl/5.10.0/PXT/Parser.pm 83 PXT::Parser::expand_tag\n  PXT::ApacheHandler /usr/lib/perl5/vendor_perl/5.10.0/PXT/ApacheHandler.pm 632 PXT::Parser::expand_tags\n  PXT::Request /usr/lib/perl5/vendor_perl/5.10.0/PXT/Request.pm 747 PXT::ApacheHandler::pxt_parse_data\n  Grail::Frame /usr/lib/perl5/vendor_perl/5.10.0/Grail/Frame.pm 111 PXT::Request::include\n  PXT::Parser /usr/lib/perl5/vendor_perl/5.10.0/PXT/Parser.pm 171 Grail::Frame::canvas_template_handler\n  PXT::Parser /usr/lib/perl5/vendor_perl/5.10.0/PXT/Parser.pm 83 PXT::Parser::expand_tag\n  PXT::ApacheHandler /usr/lib/perl5/vendor_perl/5.10.0/PXT/ApacheHandler.pm 632 PXT::Parser::expand_tags\n  PXT::ApacheHandler /usr/lib/perl5/vendor_perl/5.10.0/PXT/ApacheHandler.pm 124 PXT::ApacheHandler::pxt_parse_data\n  PXT::ApacheHandler /usr/lib/perl5/vendor_perl/5.10.0/PXT/ApacheHandler.pm 124 (eval)\n  main -e 0 PXT::ApacheHandler::handler\n  main -e 0 (eval)
[Tue Mar 17 16:58:54 2009] [error] Traceback sent to brennanrm@mail.gov at /usr/lib/perl5/vendor_perl/5.10.0/PXT/ApacheHandler.pm line 729.



[Tue Mar 17 17:01:16 2009] [error] Execution of /var/www/html/network/software/channels/manage/index.pxt failed at Tue Mar 17 17:01:16 2009: user_role_acl_test called with no $pxt->user authenticated at /usr/lib/perl5/vendor_perl/5.10.0/RHN/Access.pm line 60.
[Tue Mar 17 17:01:16 2009] [error] Traceback sent to brennanrm@mail.gov at /usr/lib/perl5/vendor_perl/5.10.0/PXT/ApacheHandler.pm line 729.
[Tue Mar 17 17:01:16 2009] [error] Execution of /var/www/html/errors/500.pxt failed at Tue Mar 17 17:01:16 2009: RHN::Exception: RHN::DB connect('xe','spacewalk',...) failed: ORA-12519: TNS:no appropriate service handler found (DBD ERROR: OCIServerAttach)\n  RHN::DB /usr/lib/perl5/vendor_perl/5.10.0/RHN/DB.pm 233 RHN::Exception::DB::throw\n  DBI /usr/lib/perl5/vendor_perl/5.10.0/i386-linux-thread-multi/DBI.pm 650 RHN::DB::handle_error\n  DBI /usr/lib/perl5/vendor_perl/5.10.0/i386-linux-thread-multi/DBI.pm 706 DBI::__ANON__\n  RHN::DB /usr/lib/perl5/vendor_perl/5.10.0/RHN/DB.pm 224 DBI::connect\n  RHN::DB /usr/lib/perl5/vendor_perl/5.10.0/RHN/DB.pm 191 RHN::DB::direct_connect\n  RHN::DB::User /usr/lib/perl5/vendor_perl/5.10.0/RHN/DB/User.pm 2562 RHN::DB::connect\n  RHN::Access /usr/lib/perl5/vendor_perl/5.10.0/RHN/Access.pm 73 RHN::DB::User::satellite_has_users\n  PXT::ACL /usr/lib/perl5/vendor_perl/5.10.0/PXT/ACL.pm 94 RHN::Access::need_first_user\n  Sniglets::Navi::Node /usr/lib/perl5/vendor_perl/5.10.0/Sniglets/Navi/Node.pm 185 PXT::ACL::eval_acl\n  Sniglets::Navi /usr/lib/perl5/vendor_perl/5.10.0/Sniglets/Navi.pm 202 Sniglets::Navi::Node::visible\n  Sniglets::Navi /usr/lib/perl5/vendor_perl/5.10.0/Sniglets/Navi.pm 168 Sniglets::Navi::render_nav\n  Sniglets::Navi /usr/lib/perl5/vendor_perl/5.10.0/Sniglets/Navi.pm 128 Sniglets::Navi::format_nav\n  PXT::Parser /usr/lib/perl5/vendor_perl/5.10.0/PXT/Parser.pm 152 Sniglets::Navi::navi_nav\n  PXT::Parser /usr/lib/perl5/vendor_perl/5.10.0/PXT/Parser.pm 83 PXT::Parser::expand_tag\n  PXT::ApacheHandler /usr/lib/perl5/vendor_perl/5.10.0/PXT/ApacheHandler.pm 632 PXT::Parser::expand_tags\n  PXT::Request /usr/lib/perl5/vendor_perl/5.10.0/PXT/Request.pm 747 PXT::ApacheHandler::pxt_parse_data\n  Grail::Frame /usr/lib/perl5/vendor_perl/5.10.0/Grail/Frame.pm 111 PXT::Request::include\n  PXT::Parser /usr/lib/perl5/vendor_perl/5.10.0/PXT/Parser.pm 171 Grail::Frame::canvas_template_handler\n  PXT::Parser /usr/lib/perl5/vendor_perl/5.10.0/PXT/Parser.pm 83 PXT::Parser::expand_tag\n  PXT::ApacheHandler /usr/lib/perl5/vendor_perl/5.10.0/PXT/ApacheHandler.pm 632 PXT::Parser::expand_tags\n  PXT::ApacheHandler /usr/lib/perl5/vendor_perl/5.10.0/PXT/ApacheHandler.pm 124 PXT::ApacheHandler::pxt_parse_data\n  PXT::ApacheHandler /usr/lib/perl5/vendor_perl/5.10.0/PXT/ApacheHandler.pm 124 (eval)\n  main -e 0 PXT::ApacheHandler::handler\n  main -e 0 (eval)
[Tue Mar 17 17:01:16 2009] [error] Traceback sent to brennanrm@mail.nih.gov at /usr/lib/perl5/vendor_perl/5.10.0/PXT/ApacheHandler.pm line 729.


Version-Release number of selected component (if applicable):

spacewalk-0.5.4-1.fc10.noarch

How reproducible:
Occurs on all attempts to click on Manage Software Channels

Steps to Reproduce:
1. Login as admin or admin level user
2. click channels/ manage software channels
3. 500 error occurs
  
Actual results:
500 error see apache log.

Expected results:
Software Channel Management page

Additional info:
[root@NCI-BrennanR-V ~]# more /usr/lib/oracle/xe/app/oracle/product/10.2.0/server/network/admin/tnsnames.ora
# tnsnames.ora Network Configuration File:

XE =
  (DESCRIPTION =
    (ADDRESS = (PROTOCOL = TCP)(HOST = BrennanR-V)(PORT = 1521))
    (CONNECT_DATA =
      (SERVER = DEDICATED)
      (SERVICE_NAME = XE)
    )
  )

EXTPROC_CONNECTION_DATA =
  (DESCRIPTION =
    (ADDRESS_LIST =
      (ADDRESS = (PROTOCOL = IPC)(KEY = EXTPROC_FOR_XE))
    )
    (CONNECT_DATA =
      (SID = PLSExtProc)
      (PRESENTATION = RO)
    )
  )

[root@NCI-BrennanR-V ~]# more /usr/lib/oracle/xe/app/oracle/product/10.2.0/server/network/admin/listener.ora
# listener.ora Network Configuration File:

SID_LIST_LISTENER =
  (SID_LIST =
    (SID_DESC =
      (SID_NAME = PLSExtProc)
      (ORACLE_HOME = /usr/lib/oracle/xe/app/oracle/product/10.2.0/server)
      (PROGRAM = extproc)
    )
  )

LISTENER =
  (DESCRIPTION_LIST =
    (DESCRIPTION =
      (ADDRESS = (PROTOCOL = IPC)(KEY = EXTPROC_FOR_XE))
      (ADDRESS = (PROTOCOL = TCP)(HOST = BrennanR-V)(PORT = 1521))
    )
    (DESCRIPTION=(ADDRESS=(PROTOCOL=tcp)(HOST=BrennanR-V)(PORT=9000))(Presentation=HTTP)(Session=RAW))
  )

DEFAULT_SERVICE_LISTENER = (XE)
Comment 1 Klemen Andreuzi 2009-04-24 05:51:04 EDT
The solution, that worked for me was adding the:
-------------------------------
LD_LIBRARY_PATH=/usr/lib/oracle/xe/app/oracle/product/10.2.0/server/lib:
PATH=/usr/lib/oracle/xe/app/oracle/product/10.2.0/server/bin:/usr/kerberos/sbin:/usr/kerberos/bin:/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:/root/bin   
                                                                                                           
ORACLE_HOME=/usr/lib/oracle/xe/app/oracle/product/10.2.0/server                                                                            
export LD_LIBRARY_PATH                                                                                                                     
export PATH                                                                                                                                
export ORACLE_HOME
------------------------------
to the beginning of the /etc/init.d/httpd

The error accured because, when apache started, the oracle_env was not set jet.
So the perl module in apache didn't get the right info for accessing the database

hope this helps,

Klemen Andreuzi
Comment 2 Clifford Perry 2009-06-23 13:55:07 EDT
To our knowledge, recent updates to the installation guide for XE and Spacewalk covers this issue. Please reopen if you are still seeing this.

Note You need to log in before you can comment on or make changes to this bug.