Bug 490790 - while clicking the review button shown in the "update system" window it throws an error.
while clicking the review button shown in the "update system" window it throw...
Status: CLOSED DUPLICATE of bug 495087
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
rawhide
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Panu Matilainen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-17 23:07 EDT by mail.for.bugs
Modified: 2009-04-21 08:52 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-21 08:52:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description mail.for.bugs 2009-03-17 23:07:45 EDT
Description of problem:
While clicking the "Review" Button shown in the "Update System" window, it throws an error saying.. "An Internal System Error has occurred".

This window is called :Update Viewer in the manual.

Version-Release number of selected component (if applicable):
Fedora 10  (i386).

How reproducible:


Steps to Reproduce:
1.select System->Administration->System Update
2.once the number of updates were displayed, press Review
3.This had thrown the Error.
  
Actual results:It had shown the complete list of updates, which is as expected, but had thrown the error in an error window.

It was throwing the error and stopped there when i tried "Apply Updates"
It was throwing the same error even while i was trying to select different updates available in the list.

Expected results:
It should not throw the error and the ApplyUpdates should update the system.

Additional info:
Error Type: <type 'exceptions.TypeError'>
Error Value: rpmdb open failed
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 2314, in <module>
    main()
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 2310, in main
    backend = PackageKitYumBackend('', lock=True)
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 182, in __init__
    self.yumbase = PackageKitYumBase(self)
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 2253, in __init__
    self.repos.confirm_func = self._repo_gpg_confirm
  File : /usr/lib/python2.5/site-packages/yum/__init__.py, line 589, in <lambda>
    repos = property(fget=lambda self: self._getRepos(),
  File : /usr/lib/python2.5/site-packages/yum/__init__.py, line 395, in _getRepos
    self._getConfig() # touch the config class first
  File : /usr/lib/python2.5/site-packages/yum/__init__.py, line 192, in _getConfig
    self._conf = config.readMainConfig(startupconf)
  File : /usr/lib/python2.5/site-packages/yum/config.py, line 774, in readMainConfig
    yumvars['releasever'] = _getsysver(startupconf.installroot, startupconf.distroverpkg)
  File : /usr/lib/python2.5/site-packages/yum/config.py, line 844, in _getsysver
    idx = ts.dbMatch('provides', distroverpkg)
Comment 1 Panu Matilainen 2009-04-21 08:52:19 EDT

*** This bug has been marked as a duplicate of bug 495087 ***

Note You need to log in before you can comment on or make changes to this bug.