Bug 490794 - RFE: Kickstart to configure/setup ipv6 addresses on network devices.
RFE: Kickstart to configure/setup ipv6 addresses on network devices.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.0
All Linux
medium Severity medium
: rc
: ---
Assigned To: Radek Vykydal
Release Test Team
: FutureFeature
Depends On:
Blocks: 609570
  Show dependency treegraph
 
Reported: 2009-03-17 23:33 EDT by Wade Mealing
Modified: 2011-01-24 18:47 EST (History)
8 users (show)

See Also:
Fixed In Version: anaconda-13.21.60-1
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
: 609570 609576 (view as bug list)
Environment:
Last Closed: 2010-11-10 14:36:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
IPv4 / IPv6 selection in loader (3.99 KB, image/png)
2010-05-18 09:34 EDT, Alexander Todorov
no flags Details
manual IPv4/IPv6 configuration screen in loader (5.46 KB, image/png)
2010-05-18 09:34 EDT, Alexander Todorov
no flags Details
Networking settings in stage2 - IPv6 tab (86.19 KB, image/png)
2010-05-18 09:35 EDT, Alexander Todorov
no flags Details

  None (edit)
Description Wade Mealing 2009-03-17 23:33:53 EDT
Description of problem:

At the moment kickstarting does not seem to support the configuration of IPV6 on network devices. One can turn it off, but not set it up on the network line.  

The installers post installation anaconda-ks.cfg does not contain ipv6 information as configured during installation.

The kickstart script does not allow for configuration for ipv6 during the kick start.

Version-Release number of selected component (if applicable):

anaconda-11.1.2.168
Comment 5 RHEL Product and Program Management 2009-06-04 12:15:24 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 6 Issue Tracker 2009-10-12 10:47:23 EDT
Event posted on 06-08-2009 07:56am EDT by Glen Johnson

------- Comment From gongjie@cn.ibm.com 2009-06-07 23:15 EDT-------
Dear Red Hat Engineer,

As I mentioned previously, with the anaconda update image,
updates-2.img.gz, anaconda supports IPv6 but kickstart not.  This is
inconsistent.  I think we should fix them at the same time.

And Joe Kachuck said that fix this problem for RHEL5 could cause issue to
the stage 2 loader.  Does it mean fix this problem for RHEL5 will cause
unwanted side effect and we cannot fix it at all?

Installing Linux on a system with multiple network interfaces and manually
specified IPv6 addresses is a rarely used function.  And we have work
around method.  I think this is not an urgent problem.  We may defer this
bug to RHEL6 until we can fix it completely.

To work around this problem, set NETWORKING_IPV6 to "yes" in
/etc/sysconfig/network.  Then, restart network connection with command
"service network restart".

Thanks
Jie Gong


This event sent from IssueTracker by jkachuck 
 issue 140830
Comment 7 Issue Tracker 2009-10-12 10:47:26 EDT
Event posted on 10-12-2009 03:53am EDT by Glen Johnson

------- Comment From gongjie@cn.ibm.com 2009-10-12 03:47 EDT-------
There is no place to configure IPv6 in the anaconda of RHEL6
pre-Alpha2-1006.  Neither in the text installation user interface nor the
graphical user interface.  I cannot even configure the network interfaces
other than the one I used to doing the network installation.

Is it a ``feature''?  Or the network configuration interface has missed
from the installation procedure.

~~~snip~~~
Welcome to Red Hat Enterprise Linux 6 for ppc64

?????????????????? Installation Method ??????????????????
???                               ???
??? What type of media contains   ???
??? the installation image?       ???
???                               ???
???         Local CD/DVD          ???
???         Hard drive            ???
???         NFS directory         ???
???         URL                   ???
???                               ???
???    ??????????????????        ????????????????????????     ???
???    ??? OK ???        ??? Back ???     ???
???    ??????????????????        ????????????????????????     ???
???                               ???
???                               ???
???????????????????????????????????????????????????????????????????????????????????????????????????

<Tab>/<Alt-Tab> between elements  | <Space> selects | <F12> next screen

Welcome to Red Hat Enterprise Linux 6 for ppc64

?????????????????????????????????????????????????????? Networking Device
??????????????????????????????????????????????????????
???                                                     ???
??? You have multiple network devices on this system.   ???
??? Which would you like to install through?            ???
???                                                     ???
???   eth0 - Ethernet device eth0 - 00:1a:64:3b:18:ae   ???
???   eth1 - Ethernet device eth1 - 00:1a:64:28:20:23   ???
???   eth2 - Ethernet device eth2 - 00:1a:64:28:20:33   ???
???   eth3 - Ethernet device eth3 - 00:14:5e:b8:08:37   ???
???                                                     ???
???    ??????????????????         ????????????????????????????????????    
    ????????????????????????     ???
???    ??? OK ???         ??? Identify ???         ??? Back ???     ???
???    ??????????????????         ????????????????????????????????????    
    ????????????????????????     ???
???                                                     ???
???                                                     ???
?????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????

<Tab>/<Alt-Tab> between elements  | <Space> selects | <F12> next screen

Welcome to Red Hat Enterprise Linux 6 for ppc64

?????????????????????????????????????????? Configure TCP/IP
??????????????????????????????????????????
???                                            ???
??? [*] Enable IPv4 support                    ???
???        ( ) Dynamic IP configuration (DHCP) ???
???        (*) Manual configuration            ???
???                                            ???
???        ??????????????????              ????????????????????????       
???
???        ??? OK ???              ??? Back ???        ???
???        ??????????????????              ????????????????????????       
???
???                                            ???
???                                            ???
??????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????

<Tab>/<Alt-Tab> between elements  | <Space> selects | <F12> next screen

Welcome to Red Hat Enterprise Linux 6 for ppc64

???????????????????????????????????????????????? Manual TCP/IP
Configuration ???????????????????????????????????????????????????
???                                                            ???
??? Enter the IPv4 and/or the IPv6 address and prefix          ???
??? (address / prefix).  For IPv4, the dotted-quad netmask     ???
??? or the CIDR-style prefix are acceptable. The gateway and   ???
??? name server fields must be valid IPv4 or IPv6 addresses.   ???
???                                                            ???
??? IPv4 address: 9.3.111.192_____ / 255.255.255.0___          ???
??? Gateway:      9.3.111.1________________________________    ???
??? Name Server:  9.3.121.18_______________________________    ???
???                                                            ???
???            ??????????????????                     
????????????????????????            ???
???            ??? OK ???                      ??? Back ???            ???
???            ??????????????????                     
????????????????????????            ???
???                                                            ???
???                                                            ???
??????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????

<Tab>/<Alt-Tab> between elements  | <Space> selects | <F12> next screen

Welcome to Red Hat Enterprise Linux 6 for ppc64

?????????????????????????????????????????????????????????????????????????????????
NFS Setup
????????????????????????????????????????????????????????????????????????????????????
???                                                                ???
??? Please enter the server name and path to your Red Hat          ???
??? Enterprise Linux 6 installation image.                         ???
???                                                                ???
??? NFS server name:                      9.3.117.7_______________ ???
??? Red Hat Enterprise Linux 6 directory: /distros/rhel6__________ ???
???                                                                ???
???            ??????????????????                        
????????????????????????             ???
???            ??? OK ???                         ??? Back ???            
???
???            ??????????????????                        
????????????????????????             ???
???                                                                ???
???                                                                ???
??????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????

<Tab>/<Alt-Tab> between elements  | <Space> selects | <F12> next screen

~~~snip~~~


This event sent from IssueTracker by jkachuck 
 issue 140830
Comment 8 Chris Lumens 2009-10-12 11:51:04 EDT
(In reply to comment #7)
> ------- Comment From gongjie@cn.ibm.com 2009-10-12 03:47 EDT-------
> There is no place to configure IPv6 in the anaconda of RHEL6
> pre-Alpha2-1006.  Neither in the text installation user interface nor the
> graphical user interface.  I cannot even configure the network interfaces
> other than the one I used to doing the network installation.

Correct.  As previously mentioned, what is still lacking here is complete support for IPv6 in NetworkManager.  anaconda has switched to using NM to do all network configuration in RHEL6 as that's the same thing the rest of the system uses.  However since it does not yet fully support IPv6, neither does anaconda.  When it grows that support, we can re-enable the dialogs in anaconda.
Comment 10 Chris Lumens 2010-01-13 09:21:55 EST
This should be fixed in the next build of anaconda for RHEL6, which I am referencing in the Fixed In Version: field above.  I am currently working on getting this build done, and it should be completed by the end of this week.
Comment 13 Issue Tracker 2010-01-15 10:21:24 EST
Event posted on 01-15-2010 10:00am EST by Glen Johnson

?????? Installation Method ??????
?                               ?
? What type of media contains   ?
? the installation image?       ?
?                               ?
?         Local CD/DVD          ?
?         Hard drive            ?
?         NFS directory         ?
?         URL                   ?
?                               ?
?    ??????        ????????     ?
?    ? OK ?        ? Back ?     ?
?    ??????        ????????     ?
?                               ?
?                               ?
?????????????????????????????????



?????????????????? Networking Device ??????????????????
?                                                     ?
? You have multiple network devices on this system.   ?
? Which would you like to install through?            ?
?                                                     ?
?   eth0 - Ethernet device eth0 - 00:1a:64:3b:18:ae   ?
?   eth1 - Ethernet device eth1 - 00:1a:64:28:20:23   ?
?   eth2 - Ethernet device eth2 - 00:1a:64:28:20:33   ?
?   eth3 - Ethernet device eth3 - 00:14:5e:b8:08:37   ?
?                                                     ?
?    ??????         ????????????         ????????     ?
?    ? OK ?         ? Identify ?         ? Back ?     ?
?    ??????         ????????????         ????????     ?
?                                                     ?
?                                                     ?
???????????????????????????????????????????????????????



?????????????? Configure TCP/IP ??????????????
?                                            ?
? [*] Enable IPv4 support                    ?
?        ( ) Dynamic IP configuration (DHCP) ?
?        (*) Manual configuration            ?
?                                            ?
?        ??????              ????????        ?
?        ? OK ?              ? Back ?        ?
?        ??????              ????????        ?
?                                            ?
?                                            ?
??????????????????????????????????????????????



???????????????? Manual TCP/IP Configuration ?????????????????
?                                                            ?
? Enter the IPv4 and/or the IPv6 address and prefix          ?
? (address / prefix).  For IPv4, the dotted-quad netmask     ?
? or the CIDR-style prefix are acceptable. The gateway and   ?
? name server fields must be valid IPv4 or IPv6 addresses.   ?
?                                                            ?
? IPv4 address: 9.3.111.192_____ / 255.255.255.0___          ?
? Gateway:      9.3.111.1________________________________    ?
? Name Server:  9.3.121.18_______________________________    ?
?                                                            ?
?            ??????                      ????????            ?
?            ? OK ?                      ? Back ?            ?
?            ??????                      ????????            ?
?                                                            ?
?                                                            ?
??????????????????????????????????????????????????????????????



??????????????????????????? NFS Setup ????????????????????????????
?                                                                ?
? Please enter the server name and path to your Red Hat          ?
? Enterprise Linux 6 installation image.                         ?
?                                                                ?
? NFS server name:                      9.3.117.7_______________ ?
? Red Hat Enterprise Linux 6 directory: /distros/rhel6__________ ?
?                                                                ?
?            ??????                         ????????             ?
?            ? OK ?                         ? Back ?             ?
?            ??????                         ????????             ?
?                                                                ?
?                                                                ?
??????????????????????????????????????????????????????????????????


This event sent from IssueTracker by jkachuck 
 issue 140830
Comment 14 Chris Lumens 2010-01-15 10:24:58 EST
Can you please verify the version of anaconda you have in your tree?  A test I just did with anaconda-13.21.0-1 shows that the Configure TCP/IP screen has options for both IPv4 and IPv6.
Comment 15 Alexander Todorov 2010-05-18 09:34:08 EDT
Created attachment 414851 [details]
IPv4 / IPv6 selection in loader
Comment 16 Alexander Todorov 2010-05-18 09:34:56 EDT
Created attachment 414854 [details]
manual IPv4/IPv6 configuration screen in loader
Comment 17 Alexander Todorov 2010-05-18 09:35:45 EDT
Created attachment 414855 [details]
Networking settings in stage2 - IPv6 tab
Comment 18 Alexander Todorov 2010-05-18 09:43:31 EDT
Hi Chris,
I've tested with anaconda-13.21.39-1.el6. IPv6 configuration options have been enabled in the UI, see attached screenshots.

Can you please clarify my questions below. 

This bug talks about kickstart but is assigned to anaconda. Is there a pykickstart bug for the --ipv6 option or we'll track this one here?

In loader when I'm at the IPv4/IPv6 manual settings screen and I press back the previous screen defaults to DHCP/Automatic, it doesn't remember my previous selection manual/manual. Should this be considered bug and reported separately?

In loader when I select IPv4/DHCP and IPv6/Manual and press Next loader gets an IPv4 address and continues to stage2. It doesn't ask me for manual configuration. In stage2 the default setting for IPv6 is Automatic not manual. 
What is the desired behavior and which is the faulty component here, anaconda or NM?
Comment 19 Chris Lumens 2010-06-30 10:32:06 EDT
> This bug talks about kickstart but is assigned to anaconda. Is there a
> pykickstart bug for the --ipv6 option or we'll track this one here?

--ipv6= was added in F8, so it should be in RHEL6.  Is anaconda not paying attention to it, or are you seeing a parse error?

> In loader when I'm at the IPv4/IPv6 manual settings screen and I press back the
> previous screen defaults to DHCP/Automatic, it doesn't remember my previous
> selection manual/manual. Should this be considered bug and reported separately?
> 
> In loader when I select IPv4/DHCP and IPv6/Manual and press Next loader gets an
> IPv4 address and continues to stage2. It doesn't ask me for manual
> configuration. In stage2 the default setting for IPv6 is Automatic not manual. 
> What is the desired behavior and which is the faulty component here, anaconda
> or NM?    

These both sound like separate bugs.  They also both sound like they should be investigated on the anaconda side first.
Comment 20 Alexander Todorov 2010-07-09 06:01:38 EDT
(In reply to comment #19)
> > This bug talks about kickstart but is assigned to anaconda. Is there a
> > pykickstart bug for the --ipv6 option or we'll track this one here?
> 
> --ipv6= was added in F8, so it should be in RHEL6.  Is anaconda not paying
> attention to it, or are you seeing a parse error?
> 

With a ks.cfg that has the line
network --device eth0 --bootproto dhcp --ipv6=auto


ksvalidator reports no errors while anaconda (stage1) says:
Bad argument to kickstart network command: Unknown option --ipv6=auto.

This is with anaconda-13.21.56-1.el6. Moving back to ASSIGNED.
Comment 21 Chris Lumens 2010-07-09 10:49:16 EDT
The curse of the kickstart networking command is that it requires changes to pykicsktart, anaconda, AND loader.
Comment 23 Radek Vykydal 2010-07-20 09:11:13 EDT
This should be fixed in anaconda-13.21.60-1.

Kickstart command network --ipv6 should work, and network --gateway can be given ipv6 address now.
Comment 25 Alexander Todorov 2010-07-23 07:04:29 EDT
anaconda-13.21.60 didn't report unknown option as in comment #20. eth0 was assigned IPv6 address. Moving to VERIFIED.
Comment 27 releng-rhel@redhat.com 2010-11-10 14:36:36 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.