This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 490829 - mingetty started on tty1 causing xorg to use 100% cpu
mingetty started on tty1 causing xorg to use 100% cpu
Status: CLOSED DUPLICATE of bug 475890
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Fedora Extras Quality Assurance
:
Depends On: 475890
Blocks: 516998
  Show dependency treegraph
 
Reported: 2009-03-18 04:19 EDT by Dr. Tilmann Bubeck
Modified: 2014-03-16 23:17 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-19 13:30:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dr. Tilmann Bubeck 2009-03-18 04:19:54 EDT
Description of problem:
Since FC10 the Xorg is started on tty1. But /etc/event.d/tty1 also starts a mingetty on tty1. So we have two processes concurrently accessing tty1. This results in mingetty respawing rapidly and is also cauing Xorg to have 100% cpu usage all the time (even when idle). There is a separat bugzilla entry #475890 describing the problem of xorg which leads to this bug report.

Version-Release number of selected component (if applicable):
initscripts-8.86-1

How reproducible:
always (at least on two Thinkpad T43 laptops)

Steps to Reproduce:
1. Boot system
2. log into KDE or GNOME
3. use "top" or other tool to watch constant load of "1".
  
Actual results:
Load of "1" on idle system.

Expected results:
Load of ~"0" on idle system.

Additional info:

SOLUTION:
   removing /etc/event.d/tty1 solves the problem.
Comment 1 Bill Nottingham 2009-03-18 12:46:49 EDT
This shouldn't happen. Can you attach your /etc/event.d/tty1?
Comment 2 iarly selbir 2009-03-19 17:07:20 EDT
Triaged.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 3 Jason Tibbitts 2009-07-24 18:03:38 EDT
Looks like Till has gone idle.  I'm seeing the problem on a fully updated F-11; here's my /etc/event.d/tty1 (short enough that attaching it seems pointless):

# tty1 - getty
#
# This service maintains a getty on tty1 from the point the system is
# started until it is shut down again.

start on stopped rc2
start on stopped rc3
start on stopped rc4

stop on runlevel 0
stop on runlevel 1
stop on runlevel 6

respawn
exec /sbin/mingetty tty1

I can verify that a mingetty was started on tty1 at the time that a user last logged out of X on this (virtual) machine, and at that time X started chewing 100% CPU.
Comment 4 Richard Allen 2009-11-12 05:31:38 EST
I often see this problem on my fc11 laptop.   What happens is that sometimes when I boot my machine, kdm (or X) wont start.  This I can fix by switching to VC2, logging in as root and running init 3 ; init 5.
Then mingetty is running on vc1 (tty1) and thus I get X using 100% cpu on one of my cpu's.

I just tried to log in on vc2 and killing kdm instead of switching runlevels and this got X up and running without starting mingetty on vc1.

There are no errors in Xorg.0.log
Comment 5 Rex Dieter 2009-12-12 23:05:51 EST
This is almost certainly a consequence of bug #475890 alright, the pending kde-4.3.4 update should take care of that (and this).
Comment 6 Karel Volný 2010-01-11 08:33:13 EST
can anyone confirm this bug with anything else than kdm?
(as the original report mentions GNOME as well)

if not, I'm going to close this as duplicate of bug #475890
Comment 8 Bill Nottingham 2010-01-19 13:30:07 EST

*** This bug has been marked as a duplicate of bug 475890 ***

Note You need to log in before you can comment on or make changes to this bug.