Bug 490841 - accented characters are replaced by a separate stress and a character in KDE apps running under GNOME in F10.
accented characters are replaced by a separate stress and a character in KDE ...
Status: CLOSED DUPLICATE of bug 468590
Product: Fedora
Classification: Fedora
Component: qt (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-18 05:50 EDT by George Dimitropoulos
Modified: 2009-09-08 03:04 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-18 05:56:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description George Dimitropoulos 2009-03-18 05:50:10 EDT
Description of problem:
when not root, accented characters are replaced by a separate stress and a character. 

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. use non-privileged account to run any KDE app under Gnome, e.g. LyX
2. switch to Greek layout (other similar reports mention French, or any other EU language using stresses - did not check personally)
3. press ; and a
  
Actual results:
´α

Expected results:
ά

Additional info:
Many other ppl reported this under many names, dead keys, accent character et.c. All closed, but bug still here. Well, I figured out that does it in latest fresh fedora 10 when using it as a non-privileged user. As root works ΟΚ. For keyboard switching I use 'keyboard Indicator 2.24.3.1 for Gnome'.
Comment 1 Kevin Kofler 2009-03-18 05:56:10 EDT

*** This bug has been marked as a duplicate of bug 468590 ***
Comment 2 George Dimitropoulos 2009-03-23 06:09:52 EDT
The bug you refer to is "closed upstream" while the bug is not resolved. Therefore, either open the bug again or leave this bug as a separate report. 

May I remind you that with the exception of English, all other European languages (or non-european written with the latin alphabet, e.g. turkish) use some form of accents and not being able to produce such characters is a MAJOR issue.
Comment 3 Rex Dieter 2009-03-23 07:49:32 EDT
fyi, closed->upstream simply means that the issue is being tracked upstream, and doesn't reflect whether it is fully resolved or not.
Comment 4 Kevin Kofler 2009-03-23 08:28:23 EDT
Right, CLOSED UPSTREAM just means the bug was reported upstream and we have to wait for upstream to fix it. As long as the upstream report is still open, the issue is not resolved.

There's also a workaround provided: remove all the scim* packages.
Comment 5 George Dimitropoulos 2009-03-23 10:36:08 EDT
rpm -qa|grep scim returned nothing in my system, yet the problem persists.

Genuinely I wonder why when launched as root it runs fine. 

CLOSED DUPLICATE = closed being duplicate
CLOSED UPSTREAM = closed being upstream
UPSTREAM = near the original developer of program at fault

Which is the project that's at fault? QT? 
Running fine as root, could it mean that QT is not at fault, but something's fishy with the user configuration files instead, ergo it should come back downstream?
Comment 6 Nicola Romanò 2009-09-08 03:04:21 EDT
I have the same exact issue under Fedora 10.
Running as root I can write accented letters, as normal user I cannot.
It seems to be happening only in Qt apps run under GNOME.

As pointed out by George this is a quite important bug for many non-English languages (in Italian writing "è" vs "e" changes from "is" to "and"... that's not quite a minor thing IMHO...).
Uninstalling scim didn't do any good unfortunately.

Any other workaround would be highly appreciated (my current one is: switch to gedit, type the accented letter and copy/paste it in the QT app. Not a very nice one).

Note You need to log in before you can comment on or make changes to this bug.