Bug 490880 - Could not find enough free space with "Use Entire Drive" selected
Could not find enough free space with "Use Entire Drive" selected
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F11Blocker/F11FinalBlocker
  Show dependency treegraph
 
Reported: 2009-03-18 08:26 EDT by James Laska
Modified: 2013-09-02 02:32 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-03 14:13:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Screenshot or error (89.28 KB, image/png)
2009-03-18 08:26 EDT, James Laska
no flags Details
anaconda-logs.tgz (5.61 KB, application/octet-stream)
2009-03-18 08:26 EDT, James Laska
no flags Details
anaconda-logs.tgz (F10) (3.33 KB, application/octet-stream)
2009-03-18 10:50 EDT, James Laska
no flags Details

  None (edit)
Description James Laska 2009-03-18 08:26:05 EDT
Created attachment 335693 [details]
Screenshot or error

Description of problem:


Version-Release number of selected component (if applicable):
anaconda 11.5.0.31

How reproducible:


Steps to Reproduce:
1. Boot rawhide installer using a kickstart file with *just* a "url --url ..."
2. At the parttype %step, select "Use Entire Drive"
3. Be sure to select [X] Review and modify partitioning layout
4. Select Next
  
Actual results:

Dialog stating...
"Could not find enough free space for automatic partitioning, please use another partitioning method."

Expected results:
Autopart should work

Additional info:

This works fine when *not* using a basic kickstart file, the problem is likely introduced by using a kickstart file that contains *no* part or clearpart commands.
Comment 1 James Laska 2009-03-18 08:26:41 EDT
Created attachment 335694 [details]
anaconda-logs.tgz

# tar -ztvf /tmp/anaconda-logs.tgz 
-rw------- root/root       444 2009-03-18 08:19 tmp/ks-script-zk6Gg4.log
-rw-r--r-- root/root      1408 2009-03-18 08:19 tmp/ks.cfg
-rw-r--r-- root/root     10668 2009-03-18 12:21 tmp/anaconda.log
-rw------- root/root       444 2009-03-18 08:19 tmp/ks-script-zk6Gg4.log
-rw-r--r-- root/root      1178 2009-03-18 12:20 tmp/program.log
-rw-r--r-- root/root     10117 2009-03-18 12:21 tmp/storage.log
-rwxr-xr-x root/root       912 2009-03-18 08:19 tmp/vncserver.log
Comment 2 Chris Lumens 2009-03-18 10:14:07 EDT
Does this same kickstart file work with previous releases?  According to the kickstart documentation, by default clearpart does not remove any partitions and is an optional command.  So, this seems to be working as I would expect.
Comment 3 James Laska 2009-03-18 10:50:55 EDT
Created attachment 335703 [details]
anaconda-logs.tgz (F10)

Yeah, works fine in previous release.  In F-10, anaconda seems to just get the repo URL from my kickstart ... and the remaining %steps are all manual.  

My understanding is that if a kickstart command is not found in the ks.cfg, it should prompt the user?
Comment 4 Chris Lumens 2009-04-03 14:13:02 EDT
This should be fixed in the next build of anaconda.

Note You need to log in before you can comment on or make changes to this bug.