Bug 490891 - software raid setup fails if partitions used already contain a file system
software raid setup fails if partitions used already contain a file system
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
All Linux
low Severity medium
: ---
: ---
Assigned To: Radek Vykydal
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2009-03-18 09:56 EDT by Jarod Wilson
Modified: 2009-06-08 14:37 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-06-08 14:37:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Jarod Wilson 2009-03-18 09:56:20 EDT
If a software raid array is created using a partition that previously contained a file system, setup of the raid array hangs indefinitely. Running the same command that sits there in ps output forever on vt2 results in a prompt saying (paraphrased) "/dev/sda1 appears to contain an ext2fs file system .... Continue creating array? _", waiting for your input. I presume the call made by anaconda is waiting for the same input, only w/o any way to get it, thus the hang. Simply adding "-R" or "--run" to the mdadm --create line skips the prompt and happily creates the array.

This was with anaconda, and sda1 was formerly a /boot fs of another install, being converted into a software raid partition for a raid1 /boot across two disks.
Comment 1 Radek Vykydal 2009-03-18 11:54:08 EDT
This should be fixed in

Note You need to log in before you can comment on or make changes to this bug.