Bug 490894 - "Caught exception:" when calling rhn-applet-tui for the first time
"Caught exception:" when calling rhn-applet-tui for the first time
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: rhn-applet (Show other bugs)
4.8
All Linux
low Severity low
: rc
: ---
Assigned To: John Matthews
Preethi Thomas
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-18 09:57 EDT by Jan Hutař
Modified: 2009-05-18 16:15 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-18 16:15:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Hutař 2009-03-18 09:57:55 EDT
Description of problem:
When I upgrade rhn-applet package and call rhn-applet-tui, I'm getting error message "Caught exception:" which was not there before.


Version-Release number of selected component (if applicable):
rhn-applet-2.1.28-4.el4.i386


How reproducible:
always


Steps to Reproduce:
1. Update rhn-applet from older release
2. # rhn-applet-tui


Actual results:
# rhn-applet-tui
Caught exception: 
unable to remove: 
Ignoring 
No package updates are needed.


Expected results:
# rhn-applet-tui
Ignoring 
No package updates are needed.


Additional info:
# rhn-applet-tui --verbose
rhnAppletModel.__init__(url=https://xmlrpc.rhn.redhat.com/APPLET)
rpm db mtimes: 0, 1237384320, 1237384353.38
Beginning RPM iter (match, (0,))
Finished RPM query (match, (0,))
******
******
********
**********

gpg-pubkey-30c9ecf8-3f9da3f7- is newer than gpg-pubkey-db42a60e-37ea5438-
gpg-pubkey-897da07a-3c979a7f- is newer than gpg-pubkey-30c9ecf8-3f9da3f7-
gpg-pubkey-99049b4c-4864bc51- is newer than gpg-pubkey-897da07a-3c979a7f-
Ended RPM query for installed packages
Beginning RPM iter (findbyprovides, ('redhat-release',))
Finished RPM query (findbyprovides, ('redhat-release',))
Beginning RPM iter (findbyfile, ('/boot/vmlinuz-2.6.9-82.ELxenU',))
Finished RPM query (findbyfile, ('/boot/vmlinuz-2.6.9-82.ELxenU',))
rhnAppletRPC.__init__(url=https://xmlrpc.rhn.redhat.com/APPLET, release = 4AS, arch = i686
rhn_applet_rpc::__get_data_store() called
attempting to open file, /root/.rhn-applet.cache
Caught exception: 
can't open for reading /root/.rhn-applet.cache: [Errno 2] No such file or directory: '/root/.rhn-applet.cache', trying to remove it...
unable to remove: 
rhnAppletRPC::_do_refresh() invoked
rhnAppletRPC::create_server(), options applied to rpclib.Server are: 
rhnAppletRPC._do_refresh() calling server.applet.poll_packages()
rhnAppletRPC._do_refresh() calling server.applet.poll_packages() response: 
packages received from server, mtime 20090316101628
Wrote applet cache to /root/.rhn-applet.cache, self.__server_url = https://xmlrpc.rhn.redhat.com/APPLET,self.__latest_packages_mtime__ = 20090316101628
inside of refresh, changedSources() = 0
rhnAppletModel.refresh() calling source.latest_packages()
rhnAppletModel.refresh() source.latest_packages() returned 1736 packages
Ignoring 
No package updates are needed.
Comment 1 RHEL Product and Program Management 2009-03-18 10:01:58 EDT
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being proposed as a blocker for this release.  

Please resolve ASAP.
Comment 2 John Matthews 2009-03-18 13:17:30 EDT
This message shows up when the applet cache file doesn't exist.  The error message is harmless.  It's been fixed in this commit #182619

To test this:
1) rm ~/.rhn-applet.cache
2) rhn-applet-tui

The old RPM shows the "Exception" message
New RPM adds a check if the cache exists.


Committed revision 182619.

Index: rhn_applet_rpc.py
===================================================================
--- rhn_applet_rpc.py	(revision 182617)
+++ rhn_applet_rpc.py	(working copy)
@@ -273,6 +273,10 @@
         file = file + "/.rhn-applet.cache"
         rhn_utils.log_debug("rhn_applet_rpc::__get_data_store() called")
         try:
+            if not os.path.isfile(file):
+                rhn_utils.log_debug("%s does not exist" % (file))
+                return
+
             rhn_utils.log_debug("attempting to open file, %s" % (file))
             fd = open(file, "r")
             rhn_utils.log_debug("opened cache at %s" % (file))
Index: rhn-applet.spec
===================================================================
--- rhn-applet.spec	(revision 182617)
+++ rhn-applet.spec	(working copy)
@@ -90,8 +90,8 @@
 %doc doc/*
 
 %changelog
-* Tue Mar 17 2009 John Matthews <jmatthew@redhat.com> - 2.1.28-5
-- Resolves:  #487660
+* Wed Mar 18 2009 John Matthews <jmatthew@redhat.com> - 2.1.29-1
+- Resolves:  #487660, #490894
 
 * Wed Feb 25 2009 Pradeep Kilambi <pkilambi@redhat.com> - 2.1.28-4
 - Resolves:  #452976
Comment 13 errata-xmlrpc 2009-05-18 16:15:10 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0975.html

Note You need to log in before you can comment on or make changes to this bug.