Bug 49094 - Samba start run level files (S35smb) are not created
Samba start run level files (S35smb) are not created
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: tksysv (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Powers
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-13 11:41 EDT by David Sampson
Modified: 2007-04-18 12:34 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-16 12:04:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Sampson 2001-07-13 11:41:45 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)

Description of problem:
When editing Samba and trying to start/stop it in run level 2, SysV Init 
will create the K35smb files in the various rcx.d directories, however it 
will not create the S35smb files.  You also can't edit the smb item to 
reassign numbers because smb will not appear in the process list.  Also, 
because the S35smb files aren't there, samba doesn't start at boot.  I'm 
using RH7.1 with samba-2.0.10-2

How reproducible:
Always

Steps to Reproduce:
1. Install samba server pkg from CD 2, upgrade to samba-2.0.10-2
2. Start control-panel in console window
3. Click on SysV init icon
4. Click on smb task in left hand pane and choose Add
5. Add it to run level 2
6. It will offer to let you set the number, but smb will not appear in list
7. Select smb and click on Edit.  Try to set the number, smb is not in list
8. Go to /etc/rc.d/rc2.d and look at files.  You'll see K35smb but not 
S35smb.  Same for other run level directories.
	

Actual Results:  S35smb files are not created in the various run level 
directories so samba doesn't start at boot.

Expected Results:  Both K35smb and S35smb file should be created in 
various run level directories.

Additional info:

This is very reproducable.  I've tried it on 2 VMWare virtual machines and 
one physical desktop machine.
Comment 1 Tim Powers 2001-07-16 12:24:24 EDT
It won't be in the list because it hasn't been added when it lets you set the
number. Also, you forgot a step. If you want to add it to start (the default is
to stop) then you have to select that option after you select "add" and have
selected smb.

A better way to add/remove services is to use chkconfig. Here's how you would do
it if you are wanting smb to start in runlevel 2 (to have it come on):

/sbin/chkconfig --level 2 smb on

To have it turn off instead of start:

/sbin/chkconfig --level 2 smb off

I am closing this as not a bug.

TIm


Note You need to log in before you can comment on or make changes to this bug.