Bug 49095 - Can't assign mountpoints to preexisting linux partitions on fresh install.
Can't assign mountpoints to preexisting linux partitions on fresh install.
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-13 12:03 EDT by Jp Robinson
Modified: 2007-04-18 12:34 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-16 12:05:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jp Robinson 2001-07-13 12:03:43 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0b; Windows 98; Win 9x 4.90)

Description of problem:
Trying to install qa0711 as I was told this is what will probably be 
considered beta2. The hardware is a Dell Inspiron 3500 laptop which on 
installed windows ME on. To prevent winME from taking over the whole drive 
I partitioned with linux Fdisk to create 3 linux partitions and one win95 
fat32 partition as follows:

/dev/hda1 59M intended as /boot
/dev/hda2 2001M Windows C: 
/dev/hda3 133M Linux swap
/dev/hda4 2451M intended /
I then rebooted into the windows installer and windows installed fine on 
hda2. I have now gone back into the Beta Installation and was attempting 
to configure my partitions with fdisk and/or disk druid.

It now shows:
/dev/hda1 59M vfat (Yet, the partition is apparently unformatted.. it 
neither shows in windows or in linux as being visible/mountable) 
/dev/hda2 2001M vfat (correct)
/dev/hda3 133 none
/dev/hda4 2451 none
When I edit hda1, I am able to change the "type" to ext3 and assign a 
mount point. However, attempting this with hda3 or hda4 I can change the 
type (on hda3, it will change to swap ok) but I am unable to assign a 
mount point even after selecting "ext3" or "ext2" as the type. (or swap, 
but that does not worry me). 
When editing the hda4 partition I see:

Mount point is "<not applicable>" and can not be changed. Original 
filesystem shows as "foreign" size shows "2451" and my options are "leve 
unchanged" or "format partition as:" 
If I choose format as I still can't change mount point and when I attempt 
to say "ok" it gives me an invalid mount point error. 

I just found out if I change the partition to format as software raid (of 
all things) I can say ok and go back in and make it ext3 and change the 
mount point. 


How reproducible:
Always

Steps to Reproduce:
1.Create partitions, exit installer
2.re enter installer and try and use disk druid or fdisk
3. Can't assign mount points. 
	

Expected Results:  Should have simply let me reassign the fstype and give 
it a mount point so I could go on. 

Additional info:

Dell Inspiron 3500 using the pcmcia bootdisk to install from porkchop and 
the qa0711.4 dir
Comment 1 Glen Foster 2001-07-13 18:07:11 EDT
This defect considered MUST-FIX for Fairfax gold-release.
Comment 2 Michael Fulbright 2001-07-16 11:31:40 EDT
The problem with hda1 looking like FAT is probably because there was a FAT
partition at the front of the disk sometime ago and the 'magic' is still there
which parted sees to determine the partition type. I think it needs to check the
size of the FAT filesystem against the size of the partition to see this is not
the case.

Ideas Matt?

The rest of the issues you saw would best be handled by showing us in person.
We're over near where Matthew sits. Are you in the Meridian office?
Comment 3 Michael Fulbright 2001-07-16 12:05:55 EDT
I'll fix the rest of these issues, which are:

1) If you have a Foreign filesystem, if you edit it and try to format it as
   something else (say ext3), the mount point entry is still insensitive.

2) If in the same case you set it to format as RAID, then ext3, you get 
   gunk left in the mount point entry that shouldn't be there.
Comment 4 Michael Fulbright 2001-07-18 18:12:42 EDT
Fixed, will appear in beta 3.

Note You need to log in before you can comment on or make changes to this bug.