Bug 490968 - spacewalk-setup fails on Fedora x86_64
spacewalk-setup fails on Fedora x86_64
Status: CLOSED CURRENTRELEASE
Product: Spacewalk
Classification: Community
Component: Installation (Show other bugs)
0.5
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Pradeep Kilambi
Dennis Gilmore
:
Depends On:
Blocks: space06
  Show dependency treegraph
 
Reported: 2009-03-18 13:39 EDT by Dennis Gilmore
Modified: 2009-09-10 08:05 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 08:05:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dennis Gilmore 2009-03-18 13:39:19 EDT
Description of problem:
spacewalk-setup fails to complete on fedora 10 x86_64,  i386 is ok 

Version-Release number of selected component (if applicable):
spacewalk-setup-0.5.22-1.fc10.noarch

How reproducible:
always

Steps to Reproduce:
1. run spacewalk-setup --disconnected
2.
3.
  
Actual results:
Unsubstituted Tags:

ERROR: RHN Entitlement Certificate failed to validate: 
Exception reported from spacewalk-f10-x64.ausil.us
Time: Wed Mar 18 17:35:34 2009
Exception type <class 'server.rhnSQL.sql_base.SQLStatementPrepareError'>

Exception Handler Information
Traceback (most recent call last):
  File "/usr/share/rhn/satellite_tools/rhn_satellite_activate.py", line 203, in activateSatellite_local
    satCerts.storeRhnCert(cert, check_generation=1, check_version=not(options.ignore_version_mismatch))
  File "/usr/share/rhn/satellite_tools/satCerts.py", line 231, in storeRhnCert
    create_first_org(owner=sc.owner)
  File "/usr/share/rhn/satellite_tools/satCerts.py", line 104, in create_first_org
    create_first_private_chan_family()
  File "/usr/share/rhn/satellite_tools/satCerts.py", line 553, in create_first_private_chan_family
    h.execute()
  File "/usr/share/rhn/server/rhnSQL/sql_base.py", line 161, in execute
    return apply(self._execute_wrapper, (self._execute, ) + p, kw)
  File "/usr/share/rhn/server/rhnSQL/driver_cx_Oracle.py", line 107, in _execute_wrapper
    raise apply(sql_base.SQLStatementPrepareError, args)
SQLStatementPrepareError: ('ORA-00984: column not allowed here\n', 984, 'INSERT INTO  rhnChannelFamily (id, name, label, org_id, product_url) VALUES (rhn_channel_family_id_seq.nextval, "Private Channel Family 1", "private-channel-family-1", 1, "First Org Created")')


Expected results:

install to succeed

Additional info:
Comment 1 Dennis Gilmore 2009-03-18 13:49:08 EDT
that traceback is a false one.  i attempted to work around the issue.

the correct one is

Unsubstituted Tags:

ERROR: RHN Entitlement Certificate failed to validate: 
Exception reported from spacewalk-f10-x64.ausil.us
Time: Wed Mar 18 17:47:20 2009
Exception type <class 'server.rhnSQL.sql_base.SQLError'>

Exception Handler Information
Traceback (most recent call last):
  File "/usr/share/rhn/satellite_tools/rhn_satellite_activate.py", line 203, in activateSatellite_local
    satCerts.storeRhnCert(cert, check_generation=1, check_version=not(options.ignore_version_mismatch))
  File "/usr/share/rhn/satellite_tools/satCerts.py", line 231, in storeRhnCert
    create_first_org(owner=sc.owner)
  File "/usr/share/rhn/satellite_tools/satCerts.py", line 104, in create_first_org
    create_first_private_chan_family()
  File "/usr/share/rhn/satellite_tools/satCerts.py", line 555, in create_first_private_chan_family
    org=1, url="First Org Created")
  File "/usr/share/rhn/server/rhnSQL/sql_base.py", line 161, in execute
    return apply(self._execute_wrapper, (self._execute, ) + p, kw)
  File "/usr/share/rhn/server/rhnSQL/driver_cx_Oracle.py", line 118, in _execute_wrapper
    raise apply(sql_base.SQLError, ret)
SQLError: (1008, 'ORA-01008: not all variables bound\n', 'INSERT INTO  rhnChannelFamily (id, name, label, org_id, product_url) VALUES (rhn_channel_family_id_seq.nextval, :name, :label, :org, :url)')
Comment 2 Jan Pazdziora 2009-03-19 11:20:39 EDT
Reassigning to Pradeep as the code in backend/satellite_tools/satCerts.py line 104 seems to have been added by him for bug 446289 in commit 93c4a98b629d43f9eb0c9d0158eae4d089c45d2d, so he has the most fresh memory about what's going on there.
Comment 3 Pradeep Kilambi 2009-03-19 12:14:10 EDT
hrm I works jus fine with my cert:

SQL> select * from rhnChannelFamily;

 ID     ORG_ID
---------- ----------
NAME
--------------------------------------------------------------------------------
LABEL
--------------------------------------------------------------------------------
PRODUCT_URL
--------------------------------------------------------------------------------
CREATED   MODIFIED
--------- ---------
      1000     1
Private Channel Family 1
private-channel-family-1

 ID     ORG_ID
---------- ----------
NAME
--------------------------------------------------------------------------------
LABEL
--------------------------------------------------------------------------------
PRODUCT_URL
--------------------------------------------------------------------------------
CREATED   MODIFIED
--------- ---------
First Org Created
19-MAR-09 19-MAR-09


The error says, "ERROR: RHN Entitlement Certificate failed to validate:" are
you sure your cert is valid?
Comment 4 Dennis Gilmore 2009-03-20 17:27:42 EDT
What info is needed?
Comment 5 Pradeep Kilambi 2009-03-20 17:33:57 EDT
As I said in comment#3, you're using an invalid cert looks like. The error says, "ERROR: RHN Entitlement Certificate failed to validate:" 

I cannot reproduce this with latest install. Make sure you're using a valid certificate and report back if you still see issues.
Comment 6 Jesus M. Rodriguez 2009-04-14 10:13:35 EDT
Spacewalk 0.5 released.
Comment 7 Dennis Gilmore 2009-04-14 18:31:49 EDT
Pradeep.  I never saw your comment as you marked it private  so all i got was needinfo.  you really should not mark spacewalk comments private.  its really bad form.  the cert is what was created during setup.
Comment 8 Michael Kearey 2009-04-21 23:18:03 EDT
I have the same problem here - I suspect the issue is something to do with x86_64 compared to i686.

I am using x86_64.

I am using latest released packages for Spacewalk, and a fully updated F10 system. Oracle XE appears to be installed correctly. The error possibly misleading, the certifcate does not fail to validate at all. The certificate validation process needs to insert a row into rhnChannelFamily successfully, as part of the activation: 

ERROR: RHN Entitlement Certificate failed to validate: 
Exception reported from realfood.usersys.redhat.com
Time: Wed Apr 22 12:40:49 2009
Exception type <class 'server.rhnSQL.sql_base.SQLError'>

Exception Handler Information
Traceback (most recent call last):
  File "/usr/share/rhn/satellite_tools/rhn_satellite_activate.py", line 203, in activateSatellite_local
    satCerts.storeRhnCert(cert, check_generation=1, check_version=not(options.ignore_version_mismatch))
  File "/usr/share/rhn/satellite_tools/satCerts.py", line 232, in storeRhnCert
    create_first_org(owner=sc.owner)
  File "/usr/share/rhn/satellite_tools/satCerts.py", line 105, in create_first_org
    create_first_private_chan_family()
  File "/usr/share/rhn/satellite_tools/satCerts.py", line 572, in create_first_private_chan_family
    raise e
SQLError: (1008, 'ORA-01008: not all variables bound\n', 'INSERT INTO  rhnChannelFamily (id, name, label, org_id, product_ur
l) VALUES (rhn_channel_family_id_seq.nextval, :name, :label, :org, :url)')


I have run the equivalent SQL commands like so ( added a little debug to /usr/share/rhn/satellite_tools/satCerts.py so find out where is gets, and execute create_first_org('Spacewalk Public Cert',397227464551); is happening ) :

[root@realfood ~]# rlwrap sqlplus spacewalk/spacewalk@xe

SQL*Plus: Release 10.2.0.4.0 - Production on Thu Apr 16 11:07:57 2009

Copyright (c) 1982, 2007, Oracle.  All Rights Reserved.


Connected to:
Oracle Database 10g Express Edition Release 10.2.0.1.0 - Production

SQL> execute create_first_org('Spacewalk Public Cert',397227464551);

PL/SQL procedure successfully completed.

SQL> INSERT INTO  rhnChannelFamily (id, name, label, org_id, product_url) VALUES (rhn_channel_family_id_seq.nextval,'Private Channel Family 1','private-channel-family-1',1,'First Org Created');

1 row created.

SQL>



It appears everything is right except for the 'INSERT INTO  rhnChannelFamily (id, name, label, org_id, product_ur
l) VALUES (rhn_channel_family_id_seq.nextval, :name, :label, :org, :url)' statement in /usr/share/rhn/satellite_tools/satCerts.py which fails with ORA-01008: not all variables bound.

I am almost certain it is a x86_64 problem but where exactly?
Comment 9 Erik Logtenberg 2009-04-30 16:33:45 EDT
I have the exact same problem: I installed Spacewalk 0.5.4-1-fc10 on a fully updated Fedora 10 system, on x86_64 architecture (running in a xen-U domain), and spacewalk-setup gives me the exact same error message as quoted above.

I followed the howto on https://fedorahosted.org/spacewalk/wiki/HowToInstall to the letter, and also (successfully) followed the howto on https://fedorahosted.org/spacewalk/wiki/OracleXeSetup to setup Oracle XE first. The version of Oracle exactly matches the versions in the howto also.

Also note that I didn't do anything explicitly concerning certificates and/or SQL queries, those are all created/done automatically by spacewalk-setup.

I don't know what information could be useful for tracking down this bug, but ofcourse I'm willing to provide any information necessary, please suggest what I should post and I will.
Comment 10 Erik Logtenberg 2009-04-30 16:41:22 EDT
I'm not sure if this is the right place to ask, but when I browse to the bug report that Jan Pazdziora refers to in comment #2 (bug 446289), bugzilla denies me access to that bug. Is that some special top secret bug, or if not, could someone please grant me access to it? I would like to figure out as much as I can about this issue, in order to possibly find a workaround for the time being.
Comment 11 Erik Logtenberg 2009-05-18 13:19:59 EDT
I see Pradeep Kilambi just bumped this bug from space05 to space06. According to the roadmap [1] however, support for Fedora 10 was scheduled for milestone 0.5. This bug blocks that goal: Spacewalk 0.5 is still not installable on Fedora 10 64-bits (doublechecked recently with the spacewalk-0.5.4-1 package - it still gives the same error).

[1] https://fedorahosted.org/spacewalk/milestone/Release%20-%200.5

Don't mean to pressure you in any way, I just think this bug really ought to block space05.
Comment 12 Pradeep Kilambi 2009-05-18 14:28:57 EDT
Well 0.6 is the next closest release and thats why its blocking 0.6r. The update will be released as soon as the issue is resolved. Just wanted to confirm that jus because its aligned to 0.6 doesn't mean it will not be looked at until then. 

So dont be alarmed that its aligned for 0.6.
Comment 13 Pradeep Kilambi 2009-05-20 09:35:04 EDT
As per zeus' email to spacewalk-list this should be resolved with an updated cx_oracle package. 

Please do the following as per the email,

<snip>

In order to fix this you need the latest version of cx_Oracle from the
nightly repos. This will fix your issue. I was able to rerun spacewalk-setup --disconnected tonight and got a successful Spacewalk 0.5 on Fedora 10 x86_64.

rpm -Uvh http://miroslav.suchy.cz/spacewalk/nightly-candidate-f10/x86_64/os/Packages/cx_Oracle-4.4.1-1.fc10.x86_64.rpm

</snip>


Thanks,
~ Prad
Comment 14 Erik Logtenberg 2009-05-20 11:00:03 EDT
Thanks Pradeep, I installed the new cx_Oracle per your instructions, and then spacewalk-setup worked like a charm.
Spacewalk 0.5 works on Fedora 10 x86_64 for me now.
Comment 15 Miroslav Suchý 2009-09-10 08:05:39 EDT
Spacewalk 0.6 released

Note You need to log in before you can comment on or make changes to this bug.