Bug 490977 - running installer arch doesn't match .discinfo
running installer arch doesn't match .discinfo
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
:
: 491378 (view as bug list)
Depends On:
Blocks: F11Beta/F11BetaBlocker
  Show dependency treegraph
 
Reported: 2009-03-18 14:30 EDT by Jesse Keating
Modified: 2013-01-09 22:27 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-25 19:26:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Log file from install attempt. (36.01 KB, text/plain)
2009-03-18 14:30 EDT, Jesse Keating
no flags Details
Attempt with repo=nfsiso (31.72 KB, text/plain)
2009-03-18 20:59 EDT, Jesse Keating
no flags Details

  None (edit)
Description Jesse Keating 2009-03-18 14:30:09 EDT
Created attachment 335750 [details]
Log file from install attempt.

I did a kickstart where the repo was nfs:reducio:/srv/pungi/raw18.0/development/i386/iso  Stage2 came from an images/install.img within that path.  The DVD plus split CD isos were in that path as well.  Anaconda complained that it couldn't find the repodata to proceed with the install.
Comment 1 Jesse Keating 2009-03-18 20:59:40 EDT
Created attachment 335788 [details]
Attempt with repo=nfsiso

Here is an attempt with boot.iso and repo=nfsiso.  It fails in a slightly different manner, a dialog box regarding attempts to mount image #1 but cannot find it on the hard drive.  TTY1 has some interesting info:

udevadm settle - timeout of 2 seconds reached, the event queue contains:
/sys/devices/virtual/block/loop7 (1345)
(this repeats all the way to loop0)
/sys/devices/platform/floppy.0/block/fd0 (1337)
/sys/devices/pci0000:00/0000:00:07.0/host3/target3:0:0/3:0:0:0/block/sdb/sdb1 (1336)
(repeated for sdb, sda/sda2, sda/sda1, sda, and sr0)

Perhaps we're not settling correctly to get the loop devices up?
Comment 2 Chris Lumens 2009-03-23 17:46:33 EDT
*** Bug 491378 has been marked as a duplicate of this bug. ***
Comment 3 Chris Lumens 2009-03-23 17:47:34 EDT
This is because the arch of the running system is "i386", but the .discinfo file says the images are being build for "i586".
Comment 4 Jesse Keating 2009-03-24 00:48:52 EDT
This also prevents media installs on i386 from seeing the local media as a source for installation, and falls back to network installs.
Comment 5 Chris Lumens 2009-03-24 11:25:22 EDT
This should be fixed in the next build of anaconda.
Comment 6 Jesse Keating 2009-03-25 19:26:49 EDT
Confirmed fixed with the anaconda tagged for beta.
Comment 7 chandoo 2009-06-09 18:34:10 EDT
Guyz

I had downloaded F11 just now, still struggling to install from hard drive

after i choose Hard Drive, installer still doesn't find ISO image instead it is looking for images/install.img file, so i had extracted f11-dvd.iso into fc11 directory and pointed to images/install.img, X is always failing irrespective of method of installation. it picks up and does some thing and it is failing to find iso image. after trail and error i succeeded moving dvd image into fc11 directory and wired things happen next, it doesn't give me any options except it formats disk and install 180+ packages into it in 30secs and installer says installation is done, after i reboot into fedora11, i had bare minimum installation without network and GUI.

Please suggest what i have to do for a sucessfull installation from image.


i am attempting to do a internet install now. let's see how it goes by.
Comment 8 Chris Lumens 2009-06-10 09:43:00 EDT
bugzilla is not a support mechanism.  Please direct your question to the appropriate mailing list or help forum.

Note You need to log in before you can comment on or make changes to this bug.