Bug 490980 - cannot compose new newsgroup message
cannot compose new newsgroup message
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-18 14:48 EDT by David Woodhouse
Modified: 2009-05-20 11:59 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-20 11:59:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 274117 None None None Never

  None (edit)
Description David Woodhouse 2009-03-18 14:48:28 EDT
I don't know how to start a news thread. I can _reply_ to a post, and I get a composer window with a Post-To: header filled in appropriately.

But if I try to create a new message, even if I select my 'news' account as the source, I can't enable the Post-To: header in the composer. It remains greyed-out.
Comment 1 Matthew Barnes 2009-03-27 22:07:43 EDT
Right, the composer needs to be smarter about managing its header fields.  They currently get enabled/disabled permanently when the composer window is created instead of reacting to which type of account you've chosen.  So unless you're replying to a newsgroup post (or using Post New Message to Folder), it assumes you want the mail message set, which excludes Post-To.

Preferences for visible headers is screwy too, because we only remember one set of header preferences (as opposed to a set for mail messages and another set for newsgroup posts).  Hope to get this straightened out for the next release.
Comment 2 Matthew Barnes 2009-05-20 11:59:08 EDT
I have a patch to finally fix this for Fedora 12.  Moving this to an equivalent upstream bug.  See [1] for further updates.

[1] http://bugzilla.gnome.org/show_bug.cgi?id=274117

Note You need to log in before you can comment on or make changes to this bug.