Bug 490987 - packages added to the errata after it has been published do not get in the channel.
packages added to the errata after it has been published do not get in the ch...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Other (Show other bugs)
530
All Linux
medium Severity medium
: ---
: ---
Assigned To: Justin Sherrill
Preethi Thomas
: Regression
Depends On:
Blocks: 456985
  Show dependency treegraph
 
Reported: 2009-03-18 15:34 EDT by Preethi Thomas
Modified: 2009-09-10 16:34 EDT (History)
3 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 16:34:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Preethi Thomas 2009-03-18 15:34:21 EDT
Description of problem:

packages added to the errata after it has been published do not get in the channel.
Version-Release number of selected component (if applicable):

ISO: Satellite-5.3.0-RHEL5-re20090306.2-i386-embedded-oracle.iso

How reproducible:


Steps to Reproduce:
1.create a custom channel1
2.create a custom errata1
3.publish the errata1 to channel1
4. rhnpush a package to the satellite ( not to the channel)
5. Navigate to the Errata->Manage Errata
6. click on the errata1 and add the package to the errata.
7. Now go to channel
8. click on the channel name -channel1 and navigate to the errata tab
9. click on the errata name-errata1 and go to the package tab.

  
Actual results:
 package that was added after publishing is not available through the channel

Expected results:

 
Additional info:
Comment 1 Clifford Perry 2009-03-19 11:46:04 EDT
Justin - is this a regression to 520/510 code/behavior?
- if regression, we should fix for sure. 
- if not regression - how hard is this to fix? Do we need to go mucking in schema and errata tmp tables for publish/unpublished states to get fixed, or just some simple app code logic changes to do right thing?

Thanks,
Cliff.
Comment 2 Justin Sherrill 2009-03-24 11:56:12 EDT
Cliff,  I'm not able to reproduce this myself.    Preethi can you reproduce on the latest ISO ?
Comment 3 Preethi Thomas 2009-03-26 07:58:18 EDT
yes, I reproduced it with 
ISO: Satellite-5.3.0-RHEL5-re20090323.0-i386-embedded-oracle.iso
Comment 4 Clifford Perry 2009-03-26 12:27:00 EDT
Justin - please get with preethi and understand how she replicated it, if your still not able to see this. Then hopefully can figure out the answers to the Q's I had within comment #1. 

Cliff
Comment 5 Preethi Thomas 2009-03-26 13:43:55 EDT
looks like this is a regression. I tried it in 5.2 and could not reproduce it.
Comment 6 Justin Sherrill 2009-03-26 15:29:55 EDT
So yes this is a regression.  THe package is getting pushed to the channel, it's just not showing up in the 'errata packages' list.
Comment 7 Justin Sherrill 2009-03-31 14:39:25 EDT
004a652398b123b548218a28d28cc158f69afcbb

Change the errata->packages page to not work off errata files.  This was a highly error prone approach and so I now just have it pull from the  errata->package, errata->channel, channel->package associations.
Comment 8 Preethi Thomas 2009-04-14 13:55:49 EDT
verified
Satellite-5.3.0-RHEL5-re20090413.0-i386-embedded-oracle.iso
Comment 9 John Sefler 2009-08-05 18:02:24 EDT
Re-verified stage iso 7/24

Add the following steps to the problem description to clarify the user actions:

6.1  after adding the package to the errata, I am presented a success message:
     1 package added to errata errata490987-1

     The channel channel490987 has different versions of these packages, or 
     does not have the packages at all. Select the packages you want push into
     this channel below, and click 'Continue'.
    
6.2  I selected my pushed package (weatherbug) and pressed Continue.  Then I
     was presented with a success message:
     1 package(s) were pushed to channel channel490987.

Now following the rest of the problem description steps, I can see the package on the Packages tab of the errata:

Packages
channel490987
5944d9898bf036296961faca2b5642fc weatherbug-1.0-1-i586 

moving to RELEASE_PENDING
Comment 10 Brandon Perkins 2009-09-10 16:34:26 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.