Bug 49099 - aic7xxx unable to get me via aic7892 to SCSI drives
aic7xxx unable to get me via aic7892 to SCSI drives
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Doug Ledford
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-13 14:00 EDT by Lukas Knizewski
Modified: 2007-04-18 12:34 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-06 10:41:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lukas Knizewski 2001-07-13 14:00:30 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.75 [en] (X11; U; Linux 2.2.16-22smp i686)

Description of problem:
a) after installing patch for kernel 2.4.3-12smp aic7xxx aint working
b) after either patching kernel 2.4.3 or 2.4.6 with adaptec aic7xxx driver,
it's aint working
None of solutions presented in above solved my problem.

Hardware config:
motherboard: SuperMicro 370DER with aic-7892
2x PIII 1GHz
2x IBM 36.7GB U160
Ide cd-rom 


How reproducible:
Always

Steps to Reproduce:
1.install rh 7.1 on some ide drive attached to computer.
2.try to access scsid drives-not work (known bug 29555)
3a.install kernel patch from redhat: kernel-2.4.3-12.i686.rpm -> still no
access
3b. download and complie kernel 2.4.6 from www.linuxhq.com -> still no
access
3c. download aic7xxx patches from adaptec site for both 2.4.3 and 2.4.6
kernels
   http://people.freebsd.org/~gibbs/linux/ -> still no access

	

Actual Results:  for 3a -> module loads but show errors -> no acess
for 3b -> errors -> no acess (2.4.6 has the same version of aic7xxx as
rh7.1 update) 
for 3c(2.4.6) -> module loads but dumps errors about parity, and still no
access)
for 3c(2.4.3) -> error in patch

Expected Results:  load module, get access to SCSI disks, install rh 7.1 on
scsi disk and deattach ide hd disk (this is supposed to be server with no
ide hard drives attached)

Additional info:

It's pretty urgent for me, this server should be working since beginning of
the July.
Comment 1 Arjan van de Ven 2001-07-18 04:31:43 EDT
Are you sure all your devices have unique SCSI ID's ?
Comment 2 Lukas Knizewski 2001-07-18 10:30:16 EDT
SCSi ID are: 0 , 1
 So that're definitely difrent.

Luaks
Comment 3 Doug Ledford 2001-08-02 13:51:56 EDT
First, this is not the same as bug 29555 (not even close, please read the bug
report more carefully next time, where it mentions "If you don't have an Intel
440GX motherboard, then this isn't the same bug you have" is pretty clear that
you don't have the same bug).

Second, the problem you describe sounds like a hardware/cabling issue.  In other
words, if I had to guess (and I do because you tell me there are errors, but not
what the errors are), I would say you have either bad/wrongly configured
termination or you are using the wrong SCSI cable or a SCSI cable that doesn't
have a terminator on the end of it.

Before I can help you at all, I have to know *exactly* what the errors are.
Comment 4 Alan Cox 2003-06-06 10:41:26 EDT
No reply in over a year: closing

Note You need to log in before you can comment on or make changes to this bug.