Bug 491043 - ibus "Use automatic engine selection" checkbox?
ibus "Use automatic engine selection" checkbox?
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Peng Huang
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 481098
  Show dependency treegraph
 
Reported: 2009-03-18 23:57 EDT by Warren Togami
Modified: 2009-06-11 23:23 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-11 23:23:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Warren Togami 2009-03-18 23:57:52 EDT
If you login to a desktop with a particular language like Japanese, it should automatically enable that ibus engine.  The user shouldn't be required to manually go into the ibus Preferences and enable the engine.

Perhaps ibus engines should register with ibus a mapping table of language codes to preferred engine.  This means:

* If the user runs ibus as LANG=ja_JP, then activate ibus-anthy.
* If the user runs ibus as LANG=ko_KR, then activate ibus-hangul.
* (Many other languages, you pretty much expect the user will want a particular engine or table.  Enable it automatically.)
* (Some languages are less certain because there are multiple engines or tables for that language.  In that case it should pick the most common one.  This isn't too bad for users who need something else, because they would have done to manually configure it anyway.)
Comment 1 Peng Huang 2009-03-19 21:42:40 EDT
Ibus supports it.
Please install latest ibus in rawhide, and try to create a new user and login with ja or ko locale. If it does not work, please tell me.
Comment 2 Warren Togami 2009-03-19 22:56:17 EDT
That is true only of the first login.  I am talking about logins after the first.

Core to this issue, if a user logs in to a Japanese desktop, they would expect Japanese IM to work.  If they login to Korean, they would expect Korean IM to work.  All other reasons not to do this are unimportant.

There are complications sure, like what if there are multiple engines for that language?  In that case enable only one that is the most preferred for that language.

Sure "most preferred" for Chinese this is less clear.  But for nearly every other language the expectation is clear.
Comment 3 Jens Petersen 2009-03-23 05:13:46 EDT
During some discussion one idea that came up was to have a "Use default input method" checkbox above the IME selector in ibus-setup.
Comment 4 Jens Petersen 2009-03-24 04:19:05 EDT
I am removing this from the Blocker list since I think we agreed it is not so important: might still be good to do something to improve this.
Comment 5 Warren Togami 2009-03-24 13:07:48 EDT
Proposed Behavior
* "Use automatic engine selection" checkbox enabled by default.  This makes ibus always run the preferred engine for the desktop language.
* If unchecked, then it always uses whatever is defined by the user in the Preferences, no matter what the desktop language is.
Comment 6 Jens Petersen 2009-06-04 00:18:44 EDT
Warren do you think we really still need this?

I am pretty happy now with the current UI.
Comment 7 Bug Zapper 2009-06-09 08:23:50 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Peng Huang 2009-06-11 23:23:36 EDT
I think this option will confuse normal users. Most users just use one locale. Even if some users will use two or three locales, most of them also wish the enabled engines be constant. So I would like close this bug as wontfix.

Note You need to log in before you can comment on or make changes to this bug.