Bug 49105 - innxmit does not post articles
Summary: innxmit does not post articles
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: inn   
(Show other bugs)
Version: 7.1
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Florian La Roche
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-07-13 18:51 UTC by stano
Modified: 2007-04-18 16:34 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-25 19:42:38 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description stano 2001-07-13 18:51:39 UTC
Description of Problem:
innxmit does not post anything

How Reproducible:
always

Steps to Reproduce:
1. configure an inn system
2. create a directory containing some Usenet news articles (I use suckmt to
suck news from a server, but any messages will do
3. create a batch file with one absolute article file path per line
4. run the innxmit as "innxmit -d localhost /abs/path/to/the batch"

Actual Results:
innxmit negotiates streaming mode with the server, then quits without
sending any articles and removes the batch file. There is no mention of any
problems in the logs, just the usual message that the innxmit was run and
sent zero articles.

Expected Results:
the articles are posted

Additional Information:
When using strace/ltrace there is an evidence that the batch file is read
and parsed, but the only communication with the server is streaming mode
negotiation (it makes no difference when I disable it) and then quit
command. Downgrading to inn 2.2.3 from RH 7.0 fixes the problem.

This system was updated from RH 7.0 to 7.1 - it is no fresh install (in the
case it matters).

If you need more info, I can install the 7.1 version of inn again and send
complete inn config.

Comment 1 stano 2001-08-25 18:23:44 UTC
I tested version 2.3.2-5 from Roswell. This time it is different - the innxmit
tries to send the article, but it seems like it forgets to sned a single dot on
a line to signal end of the article - this can be verified by doing strace. The
net effect is that innxmit will hang, never sending anything.

Reproduce: as in original bug report. If a dot on a line is added to the article
file, the innxmit does send the article.

Comment 2 stano 2001-08-25 19:42:33 UTC
Disregard previous mail, my news server offered me news articles with crlf
instead of lf (I am fetching news via suckmt and posting them to the local news
server). This was probably the reason the new innxmit was quite confused.

Please, set this bug to resolved in Roswell and later. The original bug was
fixed between 2.3.1 and 2.3.2, see http://www.isc.org/products/INN/inn-current.html:

   Changes from 2.3.1 are:

   * innxmit can again handle regular filenames as input as well
     as storage API tokens (allowing it to be used to import
     an old traditional spool).

Thanks


Note You need to log in before you can comment on or make changes to this bug.