Bug 491067 - snd_emu10k1 BUG
snd_emu10k1 BUG
Status: CLOSED DUPLICATE of bug 496320
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i686 Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-19 06:06 EDT by Adam Kirchhoff
Modified: 2009-05-15 23:09 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-15 23:09:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Kirchhoff 2009-03-19 06:06:30 EDT
Description of problem:

Sound doesn't work with an SB Live!.  Dmesg shows the following error:

ALSA sound/core/pcm_lib.c:155: BUG: stream = 0, pos = 0x2000, buffer size = 0x2000, period size = 0x2000
ALSA sound/core/pcm_lib.c:155: BUG: stream = 0, pos = 0x2000, buffer size = 0x2000, period size = 0x2000
ALSA sound/core/pcm_lib.c:155: BUG: stream = 0, pos = 0x2000, buffer size = 0x2000, period size = 0x2000
ALSA sound/core/pcm_lib.c:155: BUG: stream = 0, pos = 0x2000, buffer size = 0x2000, period size = 0x2000
ALSA sound/core/pcm_lib.c:155: BUG: stream = 0, pos = 0x2001, buffer size = 0x2000, period size = 0x2000
ALSA sound/core/pcm_lib.c:155: BUG: stream = 0, pos = 0x2001, buffer size = 0x2000, period size = 0x2000

This keeps happening as long as an application tries to access the device.

Version-Release number of selected component (if applicable):

2.6.29-0.258.rc8.git2.fc11.i586

How reproducible:

Very.  Happens every time I boot up.

Steps to Reproduce:
1. Install Fedora 11 Alpha on a machine with an SB Live!
2. Update to rawhide
  
Actual results:

No sound

Expected results:

Sound :-)

Additional info:

0c:02.0 0401: 1102:0002 (rev 05)
        Subsystem: 1102:8040
        Flags: bus master, medium devsel, latency 64, IRQ 18
        I/O ports at bce0 [size=32]
        Capabilities: [dc] Power Management version 1
        Kernel driver in use: EMU10K1_Audigy
        Kernel modules: snd-emu10k1

0c:02.1 0980: 1102:7002 (rev 05)
        Subsystem: 1102:0020
        Flags: bus master, medium devsel, latency 64
        I/O ports at bcd8 [size=8]
        Capabilities: [dc] Power Management version 1
        Kernel driver in use: Emu10k1_gameport
        Kernel modules: emu10k1-gp
Comment 1 Adam Kirchhoff 2009-03-28 10:52:10 EDT
Still an issue on 2.6.29-0.258.2.3.rc8.git2.fc11.i586

Adam
Comment 2 Edouard Bourguignon 2009-04-10 02:36:54 EDT
No sound at all on Fedora 11 beta with an audio card Creative Labs SB0400 Audigy2 Value. But not sure it's the same bug I don't have anything in dmesg about this sound card. Was working great on F10.

kernel 2.6.29.1-54.fc11.x86_64

01:07.0 Multimedia audio controller: Creative Labs SB0400 Audigy2 Value
	Subsystem: Creative Labs Device 1021
	Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
	Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 32 (500ns min, 5000ns max)
	Interrupt: pin A routed to IRQ 17
	Region 0: I/O ports at ac00 [size=64]
	Capabilities: [dc] Power Management version 2
		Flags: PMEClk- DSI+ D1+ D2+ AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
		Status: D0 PME-Enable- DSel=0 DScale=0 PME-
	Kernel driver in use: EMU10K1_Audigy
	Kernel modules: snd-emu10k1
Comment 3 Ben Skeggs 2009-04-11 02:20:22 EDT
Same issue here on 2.6.29.1-54.fc11.x86_64

01:07.0 Multimedia audio controller: Creative Labs SB Live! EMU10k1 (rev 07)
	Subsystem: Creative Labs SBLive! 5.1 Model SB0100
	Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
	Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 32 (500ns min, 5000ns max)
	Interrupt: pin A routed to IRQ 17
	Region 0: I/O ports at 9c00 [size=32]
	Capabilities: <access denied>
	Kernel driver in use: EMU10K1_Audigy
	Kernel modules: snd-emu10k1
Comment 4 Tim Wegener 2009-05-03 01:04:17 EDT
Problem still present with kernel-2.6.29.1-111.fc11.i586

00:0b.0 Multimedia audio controller: Creative Labs SB Live! EMU10k1 (rev 04)
	Subsystem: Creative Labs CT4850 SBLive! Value
	Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
	Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 32 (500ns min, 5000ns max)
	Interrupt: pin A routed to IRQ 10
	Region 0: I/O ports at d800 [size=32]
	Capabilities: <access denied>
	Kernel driver in use: EMU10K1_Audigy
	Kernel modules: snd-emu10k1
Comment 5 rookcifer 2009-05-15 09:41:09 EDT
Same problem here on a Soundblaster Live! 5.1.  I get repeated kerneloopses as long as Pulseaudio is installed.  If I remove Pulseaudio, the kerneloopses stop, but I have no control over the volume of my sound device (no option in Kmix will adjust the volume no matter what switch I try).

I know that, at least for me, this bug is a deal breaker for me using Fedora 11.  Until this is fixed, I simply can't use it.  It's sad that there are such regressions in such an old driver (emu10k1) that has worked for me for years.

Also, there is another bug about this.  Bug #496320.  Perhaps they should be marked as duplicates.
Comment 6 Adam Williamson 2009-05-15 23:09:18 EDT
This is a dupe of 496320 (this one's older, but that one's more popular :>)

*** This bug has been marked as a duplicate of bug 496320 ***

Note You need to log in before you can comment on or make changes to this bug.