Bug 49107 - RHN doesn't work with Konqueror
Summary: RHN doesn't work with Konqueror
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Web Site   
(Show other bugs)
Version: RHN Stable
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Greg DeKoenigsberg
QA Contact: Jay Turner
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-07-13 19:26 UTC by Michael E Brown
Modified: 2015-01-07 23:47 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-01 12:48:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michael E Brown 2001-07-13 19:26:59 UTC
Description of Problem:
I cannot log into the RHN site with konqueror on Red Hat 7.1. I get a 
dialog "The process for the https://www.redhat.com protocol died 
unexpectedly"

How Reproducible:
go here: http://www.redhat.com/network/main/login.html
enter your login name and click login

This is with konqueror v2.1.1 distributed with RedHat 7.1

Comment 1 Greg DeKoenigsberg 2001-09-17 19:32:55 UTC
Shold be solved with newest version of RHN, please triple-check, Jay.

Comment 2 Michael E Brown 2001-09-17 19:50:37 UTC
Is it supposed to be fixed with the Red Hat 7.1 konqueror, or do I need to
upgrade to RH 7.2?

I just tried it again with Konqueror from RH7.1 (version 2.1.1), and I get the
same message (protocol died unexpectedly)

Comment 3 Cristian Gafton 2001-10-01 23:45:39 UTC
Jay and Chip: - was this a problem with the cookie expiration or is it something
else?


Comment 4 Jay Turner 2001-10-02 13:25:02 UTC
OK, this was not the cookie problem.  It just told the user they they needed to
enable cookies in order to use RHN.  I just tried doing this with 2.1.1 on
KDE-2.1.2 and it worked . . . to a point.  Following the link that you gave
above doesn't present the user with a login dialog anymore (since the site
change.)  Instead, it just takes you to a info page about RHN.  But going to
www.redhat.com and clicking the RHN link (which takes you to
https://rhn.redhat.com) and logging in does work.

Only thing that I imagine is happening is that Konquerer on KDE-2.1.1 has
issues.  I'll check with gdk to see what the "fix" was for this.

Comment 5 Jay Turner 2001-10-02 13:28:04 UTC
OK, just checked with gdk and he said that he saw the old url (from the old
site) and knew that we didn't have that link anymore, so he closed the bug.  So,
Michael, let me know what you are seeing from your side.  Any chance that we
have some odd proxy issues going on here?

Comment 6 Thais Smith 2001-11-01 12:48:00 UTC
Konqueror in KDE 2.1 had some problems with cookies and SSL, causing a whole 
bunch of sites not to work right including (for example) Lloyds TSB Bank in the 
UK and RHN. This problem appears to be fixed in KDE 2.2.1.

I am successfully using RHN with Konqueror from KDE 2.2.1, BTW


Comment 7 Jay Turner 2001-11-16 01:01:08 UTC
Closing this out as it appears to have been a Konquerer bug.


Note You need to log in before you can comment on or make changes to this bug.