Bug 491080 - Memory corruption with Xvideo.
Memory corruption with Xvideo.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F11Blocker/F11FinalBlocker
  Show dependency treegraph
 
Reported: 2009-03-19 07:04 EDT by Thomas Woerner
Modified: 2009-04-06 05:46 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-06 05:46:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Serial console log file. (64.13 KB, text/plain)
2009-03-19 07:04 EDT, Thomas Woerner
no flags Details
Xorg.0.log (107.40 KB, text/plain)
2009-03-19 07:05 EDT, Thomas Woerner
no flags Details
dmesg file. (41.56 KB, text/plain)
2009-03-19 07:06 EDT, Thomas Woerner
no flags Details
lspci -vv output. (24.16 KB, text/plain)
2009-03-19 07:07 EDT, Thomas Woerner
no flags Details

  None (edit)
Description Thomas Woerner 2009-03-19 07:04:08 EDT
Created attachment 335837 [details]
Serial console log file.

Description of problem:
The driver was working for some hours without problems. Even restarting the X server was no problem. But after a day I tried to use Xvideo, which resulted in a kernel oops because of memory corruption. The video player started and the system was dead.

Version-Release number of selected component (if applicable):
xorg-x11-drv-ati-6.12.0-2.fc11.i586
kernel-PAE-2.6.29-0.258.rc8.git2.fc11.i686
Comment 1 Thomas Woerner 2009-03-19 07:05:22 EDT
Created attachment 335838 [details]
Xorg.0.log
Comment 2 Thomas Woerner 2009-03-19 07:06:02 EDT
Created attachment 335839 [details]
dmesg file.
Comment 3 Thomas Woerner 2009-03-19 07:07:17 EDT
Created attachment 335840 [details]
lspci -vv output.
Comment 4 Thomas Woerner 2009-03-23 09:43:24 EDT
Here is a simple reproducer:

1) Remove /var/lib/mlocate/mlocate.db and call updatedb
2) Start to play some video file
Comment 5 Thomas Woerner 2009-03-23 09:48:34 EDT
Using xf86-video-ati (from GIT) solves the problem for me completely.
Comment 6 Thomas Woerner 2009-04-02 11:04:24 EDT
It is still a problem with the latest rawhide packages:

xorg-x11-drv-ati-6.12.1-2.fc11
kernel-2.6.29.1-37.rc1.fc11
Comment 7 Thomas Woerner 2009-04-06 05:46:05 EDT
There has been no corruption since using the fix in xorg-x11-drv-ati-6.12.1-4.fc11.

Closing as RAWHIDE.

Note You need to log in before you can comment on or make changes to this bug.