This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 491083 - Missing mouse pointer with openchrome 0.2.903-5
Missing mouse pointer with openchrome 0.2.903-5
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-openchrome (Show other bugs)
10
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Xavier Bachelot
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-19 08:06 EDT by Elena Grandi
Modified: 2009-09-24 01:25 EDT (History)
4 users (show)

See Also:
Fixed In Version: 0.2.903-8.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-24 01:20:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg log for the working 0.2.903-1 xorg-x11-drv-openchrome version (51.13 KB, text/x-log)
2009-03-23 05:52 EDT, Elena Grandi
no flags Details
Xorg log for the non-working 0.2.903-5 xorg-x11-drv-openchrome version (53.08 KB, text/x-log)
2009-03-23 06:00 EDT, Elena Grandi
no flags Details
xorg.conf with SWCursor (873 bytes, text/plain)
2009-03-23 06:22 EDT, Elena Grandi
no flags Details
Xorg Log from Fedora 10 openchrome-0.2.903-6 driver (53.94 KB, text/plain)
2009-05-26 09:45 EDT, Graham White
no flags Details
Xorg Log from Fedora 9 openchrome-0.2.903-1 driver (compiled for Fedora 10) (51.98 KB, text/plain)
2009-05-26 09:47 EDT, Graham White
no flags Details

  None (edit)
Description Elena Grandi 2009-03-19 08:06:40 EDT
No mouse pointer is shown under X with xorg-x11-drv-openchrome-0.2.903-5 drivers and a VIA CX700 Card.

giving the command

xsetroot -def

partially solves the problem in that the standard pointer can now be seen (but not custom pointers from applications).

xorg-x11-drv-openchrome-0.2.903-1 on the same hardware used to work.
Comment 1 Xavier Bachelot 2009-03-19 09:55:49 EDT
Could you please attach the xorg log both with the working driver and the driver that exhibit the problem, together with the corresponding xorg confs ?

Also, can you please try to activate the software cursor (Option "SWCursor") on the non-working driver and see if it helps or not ?
Comment 2 Elena Grandi 2009-03-23 05:52:19 EDT
Created attachment 336259 [details]
Xorg log for the working 0.2.903-1 xorg-x11-drv-openchrome version
Comment 3 Elena Grandi 2009-03-23 06:00:47 EDT
Created attachment 336260 [details]
Xorg log for the non-working 0.2.903-5 xorg-x11-drv-openchrome version  

Here are the two Xorg logs; it's using autodetection (on a live image) so there is no xorg.conf.
Comment 4 Elena Grandi 2009-03-23 06:22:25 EDT
Created attachment 336261 [details]
xorg.conf with SWCursor

Using the xorg.conf found in the latest Xorg.log and adding the SWCursor option as in the attached file did in fact work; cursors (even custom ones) were again available.
Comment 5 Xavier Bachelot 2009-03-25 10:40:16 EDT
which applications are showing the bug ? I'd like to try to reproduce.
Comment 6 Elena Grandi 2009-03-25 17:43:04 EDT
I'm having problems with sugar and every activity under it. I'm using the Sugar on a Stick image from http://wiki.sugarlabs.org/go/Sugar_on_a_Stick and I've been asked to report the problem upstream.
Comment 7 Caroline Meeks 2009-04-08 17:35:37 EDT
I am seeing this on a computer with SoaS2 (F11) but not with SoaS1 (F10).
Comment 8 Elena Grandi 2009-04-09 03:56:08 EDT
Recent versions of SoaS1 use an earlier version of xorg-x11-drv-openchrome (0.2.903-1 IIRC) instead of the one in F10 as a workaround for this bug.
Comment 9 Graham White 2009-05-26 06:08:27 EDT
I've just upgraded my Fedora 9 home server this weekend to Fedora 10 and had a couple of problems with openchrome when I booted:

1) No mouse cursor (the SWCursor option fixes this)
2) Only 640x480 was available (as in bug #488193)

I was unable to find a solution to the second problem so I tried compiling the latest SRPM from Fedora 9 updates (xorg-x11-drv-openchrome-0.2.903-1.fc9.src.rpm) for Fedora 10 (giving me a xorg-x11-drv-openchrome-0.2.903-1.fc10.i386.rpm RPM).  After installing this I'm enjoying the same working system I had under Fedora 9.

I'm guessing this could possibly be a packaging issue (I've not looked to see if the sources or patches are different between the F9 and F10 versions yet) but could also be an upstream bug.  All the same, would be nice for the Fedora 10 production version to be reliable.  For now I've yum excluded openchrome updates.

Here's my lspci:

01:00.0 VGA compatible controller: VIA Technologies, Inc. CX700/VX700 [S3 UniChrome Pro] (rev 03) (prog-if 00 [VGA controller])
	Subsystem: Device 0908:1975
	Flags: bus master, 66MHz, medium devsel, latency 64, IRQ 16
	Memory at c0000000 (32-bit, prefetchable) [size=512M]
	Memory at fd000000 (32-bit, non-prefetchable) [size=16M]
	Expansion ROM at feaf0000 [disabled] [size=64K]
	Capabilities: [60] Power Management version 2
	Capabilities: [70] AGP version 3.0
Comment 10 Xavier Bachelot 2009-05-26 07:53:08 EDT
(In reply to comment #9)
> I've just upgraded my Fedora 9 home server this weekend to Fedora 10 and had a
> couple of problems with openchrome when I booted:
> 
> 1) No mouse cursor (the SWCursor option fixes this)
> 2) Only 640x480 was available (as in bug #488193)
> 
Please make sure you are using the openchrome package from F10 updates (0.2.903-6.fc10).
Comment 11 Graham White 2009-05-26 08:29:54 EDT
Sorry, yes I should have mentioned that.  I did a full Fedora 10 upgrade and update so I was using the latest 0.2.903-6 package from Fedora 10 updates and it exhibited both the problems listed above.
Comment 12 Xavier Bachelot 2009-05-26 09:03:08 EDT
(In reply to comment #11)
> Sorry, yes I should have mentioned that.  I did a full Fedora 10 upgrade and
> update so I was using the latest 0.2.903-6 package from Fedora 10 updates and
> it exhibited both the problems listed above.  
Please provide the xorg conf and xorg log with 0.2.903-6.fc10.
Comment 13 Graham White 2009-05-26 09:45:37 EDT
Created attachment 345466 [details]
Xorg Log from Fedora 10 openchrome-0.2.903-6 driver

Log when using the latest openchrome driver in Fedora 10 on my system (see comments for lspci output) with no xorg.conf in place.  When using this driver my system displays without a cursor and also only shows 640x480 resolution.
Comment 14 Graham White 2009-05-26 09:47:57 EDT
Created attachment 345467 [details]
Xorg Log from Fedora 9 openchrome-0.2.903-1 driver (compiled for Fedora 10)

Log when using the latest openchrome driver in Fedora 9 on my system (see comments for lspci output) with no xorg.conf in place.  When using this driver my system displays perfectly i.e. 1680x1050 resolution and showing the mouse cursor.  Note, this is using the Fedora 9 RPM which I recompiled from SRPM on Fedora 10 before installing (it's not the initial Fedora 10 openchrome-0.2.903-1 release).
Comment 15 Xavier Bachelot 2009-05-26 15:56:35 EDT
(In reply to comment #14)
> Created an attachment (id=345467) [details]
> Xorg Log from Fedora 9 openchrome-0.2.903-1 driver (compiled for Fedora 10)
> 
> Log when using the latest openchrome driver in Fedora 9 on my system (see
> comments for lspci output) with no xorg.conf in place.  When using this driver
> my system displays perfectly i.e. 1680x1050 resolution and showing the mouse
> cursor.  Note, this is using the Fedora 9 RPM which I recompiled from SRPM on
> Fedora 10 before installing (it's not the initial Fedora 10
> openchrome-0.2.903-1 release).  

I'm sorry, but this log is useless to me. I need the log from the genuine 0.2.903-6.fc10 to be able to diagnose the problem.
Comment 16 Graham White 2009-05-26 16:23:08 EDT
> I'm sorry, but this log is useless to me. I need the log from the genuine
> 0.2.903-6.fc10 to be able to diagnose the problem.  

Please see comment #13 with associated attachment.  Comment #14 and its attachment are for reference and comparison.
Comment 17 Xavier Bachelot 2009-05-26 16:55:32 EDT
oops, sorry. I know what's wrong. The driver thinks there is an LVDS panel attached while there's not.

You can force the driver to use only the CRT with the following line in the device section of the xorg conf :
Option "ActiveDevice" "CRT"

I'll revert the bad commit upstream, and I'll push a new package later.

I think I'll also force the driver to software cursor at the same time, at least until there's a real fix upstream.
Comment 18 Graham White 2009-05-27 01:39:52 EDT
Forcing ActiveDevice to CRT appears to correct both problems, I get a sensible resolution and I can see the mouse cursor without explicitly setting SWCursor.

I've removed openchrome from my yum excludes so I'll test the 0.2.903-7 package when it's pushed, let me know if you'd like me to test the new release before you push it to updates and I'll be happy to grab it from elsewhere first.

Just FYI, performance appears to be pretty much the same between the F9 0.2.903-1 package and the F10 0.2.903-6 one - as measured by gtkperf.  Although performance is much better on F10 than it was in F9, presumably because of the xorg updates.  I've still got all the test results if that's something you're interested in.

One other thing I tried was setting the AccelMethod to EXA and MigrationHeuristic to greedy in xorg.conf.  This caused X to go into a continuous loop of starting up then bombing out and I noticed the following 3 lines get repeated in dmesg:
  agpgart-via 0000:00:00.0: AGP 3.5 bridge
  agpgart-via 0000:00:00.0: putting AGP V3 device into 8x mode
  pci 0000:01:00.0: putting AGP V3 device into 8x mode

Any other info about my system or testing you need let me know, I'm usually very happy to help out.
Comment 19 Fedora Update System 2009-06-19 07:01:24 EDT
xorg-x11-drv-openchrome-0.2.903-11.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/xorg-x11-drv-openchrome-0.2.903-11.fc11
Comment 20 Fedora Update System 2009-06-19 07:01:39 EDT
xorg-x11-drv-openchrome-0.2.903-7.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/xorg-x11-drv-openchrome-0.2.903-7.fc10
Comment 21 Fedora Update System 2009-06-24 15:34:38 EDT
xorg-x11-drv-openchrome-0.2.903-7.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update xorg-x11-drv-openchrome'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-6806
Comment 22 Fedora Update System 2009-06-24 15:37:32 EDT
xorg-x11-drv-openchrome-0.2.903-11.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update xorg-x11-drv-openchrome'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-6855
Comment 23 Fedora Update System 2009-07-19 11:40:19 EDT
xorg-x11-drv-openchrome-0.2.903-12.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/xorg-x11-drv-openchrome-0.2.903-12.fc11
Comment 24 Fedora Update System 2009-07-19 11:41:39 EDT
xorg-x11-drv-openchrome-0.2.903-8.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/xorg-x11-drv-openchrome-0.2.903-8.fc10
Comment 25 Fedora Update System 2009-07-22 17:50:22 EDT
xorg-x11-drv-openchrome-0.2.903-12.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update xorg-x11-drv-openchrome'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-7851
Comment 26 Fedora Update System 2009-07-22 17:53:49 EDT
xorg-x11-drv-openchrome-0.2.903-8.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update xorg-x11-drv-openchrome'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-7859
Comment 27 Fedora Update System 2009-09-24 01:20:29 EDT
xorg-x11-drv-openchrome-0.2.903-12.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 28 Fedora Update System 2009-09-24 01:24:44 EDT
xorg-x11-drv-openchrome-0.2.903-8.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.