Bug 491096 - Evolution fails to cross-post NNTP properly, violates RFC3977
Evolution fails to cross-post NNTP properly, violates RFC3977
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-19 09:28 EDT by David Woodhouse
Modified: 2009-06-28 21:40 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-28 21:40:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 587257 None None None Never

  None (edit)
Description David Woodhouse 2009-03-19 09:28:57 EDT
When cross-posting to multiple news groups, Evolution seems to be submitting _multiple_ messages with the same Message-Id: header, each to only one group. These seem to get eaten by the news server, not entirely surprisingly. RFC3977 says that Message-ID MUST be unique.

Compare Evolution's attempt at cross-posting: http://david.woodhou.se/postdump.cap
With Pine: http://david.woodhou.se/post-dump-3.cap

The important part being that Evolution does this...

post

340 340 <49c24468$0$513$5a6aecb4@news.aaisp.net.uk> (desired)

Newsgroups: uk.net.providers.aaisp

Subject: News cross-posts silently discarded?
 ...

post

340 340 <49c24468$1$513$5a6aecb4@news.aaisp.net.uk> (desired)

Newsgroups: uk.test

Subject: News cross-posts silently discarded?


While Pine does it in one go:

POST

340 340 <49c246b4$0$511$5a6aecb4@news.aaisp.net.uk> (desired)

Path: macbook.infradead.org!dwmw2

Newsgroups: uk.test,uk.net.providers.aaisp

Date: Thu, 19 Mar 2009 13:20:47 +0000

From: David Woodhouse <dwmw2@macbook.infradead.org>

Subject: Cross-posting, again.
Comment 1 Matthew Barnes 2009-06-28 21:40:19 EDT
Moving this upstream for better visibility.
Please see [1] for further updates.

[1] http://bugzilla.gnome.org/show_bug.cgi?id=587257

Note You need to log in before you can comment on or make changes to this bug.