Bug 491120 - AttributeError: 'BTRFS' object has no attribute 'fslabel'
AttributeError: 'BTRFS' object has no attribute 'fslabel'
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
urgent Severity urgent
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
anaconda_trace_hash:f521d4b556e90ad18...
:
Depends On:
Blocks: F11Beta/F11BetaBlocker
  Show dependency treegraph
 
Reported: 2009-03-19 10:38 EDT by M8R-nxns8i
Modified: 2009-04-23 18:43 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-23 18:43:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (192.30 KB, text/plain)
2009-03-19 10:38 EDT, M8R-nxns8i
no flags Details
Attached traceback automatically from anaconda. (153.20 KB, text/plain)
2009-03-20 14:04 EDT, Josef Bacik
no flags Details

  None (edit)
Description M8R-nxns8i 2009-03-19 10:38:26 EDT
The following was filed automatically by anaconda:
anaconda 11.5.0.33 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/storage/formats/fs.py", line 831, in _getFormatOptions
    if self.fslabel:
  File "/usr/lib/anaconda/storage/formats/fs.py", line 266, in doFormat
    argv = self._getFormatOptions(options=options)
  File "/usr/lib/anaconda/storage/formats/fs.py", line 676, in create
    return self.doFormat(*args, **kwargs)
  File "/usr/lib/anaconda/storage/deviceaction.py", line 280, in execute
    options=self.device.formatArgs)
  File "/usr/lib/anaconda/storage/devicetree.py", line 634, in processActions
    action.execute(intf=self.intf)
  File "/usr/lib/anaconda/storage/__init__.py", line 184, in doIt
    self.devicetree.processActions()
  File "/usr/lib/anaconda/packages.py", line 115, in turnOnFilesystems
    anaconda.id.storage.doIt()
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 128, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1317, in nextClicked
    self.anaconda.dispatch.gotoNext()
AttributeError: 'BTRFS' object has no attribute 'fslabel'
Comment 1 M8R-nxns8i 2009-03-19 10:38:43 EDT
Created attachment 335861 [details]
Attached traceback automatically from anaconda.
Comment 2 Josef Bacik 2009-03-20 14:04:55 EDT
Created attachment 336094 [details]
Attached traceback automatically from anaconda.
Comment 3 Josef Bacik 2009-03-20 14:20:46 EDT
Tried this with icantbeleiveitsnotbtr, once using the default lvm layout and just changing lv_root to btrfs, and then another time taking out lvm altogether and just doing btrfs.  Then I tried it without icantbelieveitsnotbtr and it still died.
Comment 4 David Lehman 2009-03-20 14:28:42 EDT
This should be fixed in the next build of anaconda (11.5.0.35-1). Thanks for the bug report.
Comment 5 Adam Williamson 2009-04-22 12:57:12 EDT
can reporters confirm or deny the claimed fix? this is on f11 preview blocker list.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 6 Will Woods 2009-04-23 18:43:23 EDT
There's no description of the actions that lead to this traceback, so I assume the bug here concerns the obvious case: "install onto btrfs".

I've just completed an install onto btrfs / (on LVM) on x86_64 - no trouble from anaconda-11.5.0.47 during the initial installation.

Just to be sure, I also started a new installation (without the magic commandline parameter) and it isn't exploding when it sees the existing btrfs partition. 

Therefore I'm going to consider the fix confirmed and close the bug. Feel free to reopen if you can still trigger this bug with current rawhide / F11Preview.

Note You need to log in before you can comment on or make changes to this bug.