Bug 49115 - some cron.weekly jobs not run
some cron.weekly jobs not run
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: crontabs (Show other bugs)
5.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-13 18:35 EDT by Need Real Name
Modified: 2007-04-18 12:34 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-06 19:10:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-07-13 18:35:53 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)

Description of problem:
Our cron jobs look like this:
01    *    *    *    *    root    run-parts    /etc/cron.hourly
02    1    *    *    *    root    run-parts    /etc/cron.daily
22    4    *    *    *    root    run-parts    /etc/cron.weekly
42    4    1    *    *    root    run-parts    /etc/cron.monthly
 
in /etc/cron.weekly is this file:
 
SALESSAT

which has the following lines in it:
 
BLASTDIR=/usr/blast
SETUPDIR=/usr/blast
PATH=/usr/blast:.
export BLASTDIR SETUPDIR PATH
rm  /usr/blast/wake.1
rm  /usr/blast/wake.2
rm  /usr/spool/uucp/LCK*
blast -b autopoll -sautopoll.scr 2 wake
 
This file is to delete files from the system and then start a BLAST 
communication autopoll function to retreive data files from several 
locations.  None of the /var/log files say this is even being run.  I do 
not see any entries in /usr/tmp/ttymgr.log with a Sunday date.  And the 
program is apparently not being run as we don't get data from the 
different locations.  


How reproducible:
Always

Steps to Reproduce:
1.setup your cron files as we have indicated
1a.  you will have to use a dial out program in place of BLAST.
2.set your system clock to sunday midnight
3.see if it runs
	

Actual Results:  it didn't run.

Expected Results:  we should have ended up with data from 14 remote 
locations on the system.

Additional info:

we ran each line of the SALESSAT file at the command prompt and it 
performed flawlessly.
Comment 1 Preston Brown 2001-07-19 16:21:18 EDT
is /etc/cron.weekly/SALESSTAT an executable file (i.e. executable bit set)?
Comment 2 Need Real Name 2001-07-23 20:10:31 EDT
relayed info to our programmer and she is checking...however, it may be some 
time before I hear from her she is on an Installation....if I can get her 
attention I will query and relay back to you.  JKing on hold.
Comment 3 Need Real Name 2001-07-28 13:41:11 EDT
Programmer went on vacation/training session and wasn't able to query her.  
However, the User said that the programming was still not working.  So we are 
still at square one.

JKing
Comment 4 Need Real Name 2002-08-06 19:10:05 EDT
apologize for not getting back to this sooner....it wasn't a crontab 
problem....it was an incorrect setting in the blast program...once that was 
corrected the problem was resolved........i didn't get word of this until today.

Note You need to log in before you can comment on or make changes to this bug.