Bug 491159 - openoffice/KDE quickstart session management issues
openoffice/KDE quickstart session management issues
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-19 12:43 EDT by Orion Poplawski
Modified: 2009-05-01 06:46 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-01 06:46:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 580411 None None None Never
KDE Software Compilation 190522 None None None Never
KDE Software Compilation 190811 None None None Never
OpenOffice.org 101379 None None None Never

  None (edit)
Description Orion Poplawski 2009-03-19 12:43:25 EDT
Description of problem:

Need a .desktop file to lauch "openoffice.org" to get the generic startup screen.

Also, current desktop files have "1.9" in the name which is kind of confusing:

/usr/share/applications/openoffice.org-1.9-writer.desktop

Version-Release number of selected component (if applicable):
openoffice.org-core-3.0.1-15.2.fc10.i386
Comment 1 Caolan McNamara 2009-03-19 13:04:54 EDT
Well, in F11 they have unversioned names so that goes away in F-11.

There is a "start center" .desktop available in the 3.1 source, though we haven't installed it as of yet, which could be used in e.g. F11, but there wasn't one in 3.0.1 (as in F-10).

Is there a particular reason you want a .desktop for the "empty frame"/"start center", i.e. do you simply want to see it in the menus, or do you want to rely on its presence for something (i.e. one with hidden set so it doesn't show up in the menus is acceptable)
Comment 2 Orion Poplawski 2009-03-19 13:12:54 EDT
One of my users asked for it, so I passed on the request.  Not really sure why they want it :-).  Perhaps they don't know you can open/create any document from any of the applications.  Mainly want just a single icon to put on their start panel I think.
Comment 3 Caolan McNamara 2009-03-24 05:37:24 EDT
Can't do it for F-10 anyway, because it doesn't exist in 3.0.1 and translations and UI changes in a released product is problematic.

I'm unconvinced that we want it for F-11 either, but it is possible. I wonder though if the quick starter fits the requirement better. Launch any OOo component from it, and keeps OOo in memory for the constant-OOo user for speedy launch times.
Comment 4 Caolan McNamara 2009-03-29 06:14:07 EDT
I don't really like the idea of packing the generic .desktop. The quick launcher is probably the more useful entity for the power-OOo user
Comment 5 Orion Poplawski 2009-04-16 12:51:04 EDT
Okay, the quick launcher looks promising, but it has some issues.  What I want to achieve is a way to have it started by default when you log in without bringing up a empty document window.  The problem seems to be that the quick launcher being in the system tray is tied to a running OOo application.
Comment 6 Caolan McNamara 2009-04-16 15:33:18 EDT
If you launch openoffice.org and use tools->options->memory-> and enable systray quickstarter then the next time you log in to your session the quickstarter should be running in the panel and there shouldn't be any "empty" window. That's what happens here anyway, and is what I would expect.

(not unless there was an empty window there on log-out and some explicit global session saving stuff active)
Comment 7 Orion Poplawski 2009-04-17 11:06:37 EDT
Doesn't work with KDE.  Start OOo Writer, enable systray, see it, close document window, logout, login.  What gets launched is "/bin/sh /usr/lib64/openoffice.org3/program/soffice -writer -session=..... -nologo"  which is what is running on logout.
Comment 8 Caolan McNamara 2009-04-17 18:19:18 EDT
Sounds like a session management thing. I hate session management issues, they're most horrible
Comment 9 Caolan McNamara 2009-04-23 09:38:01 EDT
Assuming its a glitch with OOO session management, here's something to try...

shutdown OOo, exit quickstarter
run...
ooffice -quickstart -nologo -nodefault
save session, log out, log in

that might "do the right thing"
Comment 10 Orion Poplawski 2009-04-23 17:22:27 EDT
Nope, with this no OOo item is saved in the session, so the quickstarter (or any other oo app) is not started on login.
Comment 11 Caolan McNamara 2009-04-24 06:39:02 EDT
Hmm

stage 1)...

cd ~/.config/autostart
cp -f /usr/lib/openoffice.org3/share/xdg/qstart.desktop .
edit qstart.desktop and remove the "NoDisplay" line
log out, log in

it gets started

edit qstart.desktop and add a "NoDisplay=true" line

log out, log in

it doesn't get started.

Can you confirm this behaviour, i.e. NoDisplay=true disables it from getting run from the autostart


Seems like that "NoDisplay" is being treated like "Hidden", but they're different things. "Hidden" is to ignore an autostart .desktop while "NoDisplay" it to not show a .desktop in application menus

http://standards.freedesktop.org/desktop-entry-spec/desktop-entry-spec-latest.html
http://standards.freedesktop.org/autostart-spec/autostart-spec-0.5.html
Comment 12 Orion Poplawski 2009-04-24 10:46:24 EDT
Confirmed.  Filed KDE bug: https://bugs.kde.org/show_bug.cgi?id=190522

But perhaps we can remove NoDisplay=true for now?  Does this cause problems?
Comment 13 Caolan McNamara 2009-04-25 11:41:53 EDT
Yeah we can do that, but only fixes comment #9

stage 2 is to figure out a way when *only* the quickstarter is running at exit, even if it was launched from inside e.g. writer during that session, that *only* the quickstarter gets launched, and not a blank top-level writer along with it, i.e. comment #7. I think we might be able to handle this with SmRestartStyleHint of SmRestartNever vs SmRestartIfRunning depending on the count of toplevel open visible frames
Comment 14 Caolan McNamara 2009-04-27 06:11:16 EDT
Bah, the gnome one doesn't pay any attention to SmRestartNever, and the KDE is using the wrong type for a SmRestartStyleHint. I knew I hated session management
Comment 15 Caolan McNamara 2009-04-27 06:16:29 EDT
Filed a patch at http://bugzilla.gnome.org/show_bug.cgi?id=580411 for gnome-session
Comment 16 Caolan McNamara 2009-04-27 07:33:41 EDT
Filed a patch at https://bugs.kde.org/show_bug.cgi?id=190811 for KWin, etc. for different problem of wrong sized type for SmRestartStyleHint
Comment 17 Caolan McNamara 2009-04-27 10:09:45 EDT
Fixed a patch at http://www.openoffice.org/issues/show_bug.cgi?id=101379 for OOo, which IMO would do the right thing, if everything else was working the way I'd like it to.

OOo side checked in for F-10/F-11/F-12. Will be in >= 3.0.1-15.4 if there is another release for F-10. Won't get full benefit of course if the kde/gnome-session changes don't get made. But will at least get a better working quickstarter under kde, even if get an extra blank window under some ordering circumstances.
Comment 18 Caolan McNamara 2009-05-01 06:46:27 EDT
All OOo-side done in 3.1.0-11.2.f11, caveats explained above.

Note You need to log in before you can comment on or make changes to this bug.