Bug 49119 - kernel is not patchable
kernel is not patchable
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-13 20:06 EDT by Joe Acosta
Modified: 2007-04-18 12:34 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-13 22:26:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joe Acosta 2001-07-13 20:06:09 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (Win98; U)

Description of problem:
Try to patch a redhat kernel with a new patch (2.4.2 to 2.4.3) and it fails.

How reproducible:
Always

Steps to Reproduce:
1. cd /usr/src/linux
2) zcat patch-2.4.3.gz | patch -p1


Additional info:
Comment 1 Bill Nottingham 2001-07-13 22:26:41 EDT
The Red Hat kernel is a rather heavily patched 2.4.2.
Comment 2 Arjan van de Ven 2001-07-14 03:34:21 EDT
The patch you are using is against a "upstream", eg Linus released kernel.
THe kernel Red Hat uses has several patches applied to it, the majority
of those is already in 2.4.3 (either because we found a bug and sent the fix to 
Linus or because we took a bugfix from 2.4.3); and as as result you get 
conflicts if you apply that patch. If you want a 2.4.3 kernel, you can also 
download the official 2.4.3-12 upgrade (which is actually 2.4.3 + the ac14 patch 
+ all bugfixes upto 2.4.5-ac16).
Comment 3 Joe Acosta 2001-07-14 14:01:57 EDT
I know that the redhat kernel is heavily patched.  There should still be a way
to patch a redhat kernel to 2.4.3, 2.4.5 and 2.4.6, or Redhat should release
patches soon after Linus patches.

Comment 4 Joe Acosta 2001-07-14 14:03:03 EDT
Where is the officeial 2.4.3-12 and is there a 2.4.6-x?
Comment 5 Arjan van de Ven 2001-07-14 14:07:01 EDT
2.4.3-12 is available in the "updates" directory for 7.1 from our ftp site and 
it's mirrors, and also via the "up2date" update tool. This contains all bugfixes 
upto 2.4.5-ac16

In the "rawhide" directory on the same ftp site you can find snapshots of our 
work-in-progress, which has usually a rather uptodate kernel. However these are
experimental as it's a snapshot which hasn't passed through our QA process.
(right now there is a 2.4.6-ac1 based kernel iirc)

Note You need to log in before you can comment on or make changes to this bug.