Bug 491190 - SendFF does not work
SendFF does not work
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: cups (Show other bugs)
5.3
All Linux
low Severity medium
: rc
: 5.4
Assigned To: Tim Waugh
BaseOS QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-19 15:02 EDT by Robin R. Price II
Modified: 2010-10-23 04:25 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-02 07:26:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robin R. Price II 2009-03-19 15:02:39 EDT
Description of problem:

Can not get form feeding to work correctly in RHEL5u2.  
This is not fixed in the RHEL5u3 rebase of cups either.

Version-Release number of selected component (if applicable):


RHEL5u3+: cups-1.3.7*
RHEL5u2-: cups-1.2.4*

How reproducible:

Always

Steps to Reproduce:

	1) Add a text-only printer: lpadmin -p printer-text -E -v socket://<ipaddr>:9100 /usr/share/cups/model/textonly.ppd
	2) Edit /etc/cups/ppd/printer-text
	3a) replace *DefaultSendFF: False to *DefaultSendFF: True
		or
	3b) system-config-printer, select printer, and apply SendFF on the printer options tab
  
Actual results:

Printer prints \14

Expected results:

Send the form feed correctly to printer and not print \14

Additional info:

The problems acutally seems to be with bash and with the textonly filter located /usr/lib/cups/filter/textonly.
	At the end of this file, you see the command "echo -ne \\14".  This does not work correctly in RHEL5.  When you run this command, \14 is printed.  In RHEL3 and RHEL4, a blank line is given.  To fix the issue, I had the customer remove the 14 and replace it with "014".  Below is the patch for the fix.


--- /usr/lib/cups/filter/textonly.orig  2008-10-20 16:23:43.000000000 -0400
+++ /usr/lib/cups/filter/textonly       2008-10-20 16:24:03.000000000 -0400
@@ -43,7 +43,7 @@ while [ "$COPIES" -gt 0 ]; do
 
   if [ "$SENDFF" == "True" ]
     then
-    echo -ne \\14
+    echo -ne \\014
   fi
 
   COPIES=$(($COPIES - 1))


Also, echo -ne \\f works.
Comment 3 Chris Ward 2009-07-03 14:27:35 EDT
~~ Attention - RHEL 5.4 Beta Released! ~~

RHEL 5.4 Beta has been released! There should be a fix present in the Beta release that addresses this particular request. Please test and report back results here, at your earliest convenience. RHEL 5.4 General Availability release is just around the corner!

If you encounter any issues while testing Beta, please describe the issues you have encountered and set the bug into NEED_INFO. If you encounter new issues, please clone this bug to open a new issue and request it be reviewed for inclusion in RHEL 5.4 or a later update, if it is not of urgent severity.

Please do not flip the bug status to VERIFIED. Only post your verification results, and if available, update Verified field with the appropriate value.

Questions can be posted to this bug or your customer or partner representative.
Comment 6 errata-xmlrpc 2009-09-02 07:26:02 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1360.html

Note You need to log in before you can comment on or make changes to this bug.