Bug 491192 - SIGSEGV in loader with boot.iso
SIGSEGV in loader with boot.iso
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F11Beta/F11BetaBlocker
  Show dependency treegraph
 
Reported: 2009-03-19 15:15 EDT by Jesse Keating
Modified: 2013-01-09 22:27 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-20 15:43:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jesse Keating 2009-03-19 15:15:20 EDT
Rawhide from 20090319 booting boot.iso both i386 and x86_64 no other options results in a SIGSEGV:

loader received SIGSEGV! Backtrace:
/sbin/loader(loaderSegvHandler+0x7e)[0x409b0e]
/lib64/libc.so.6[0x7f607e66c2f0]
/sbin/loader(doPwMount+0xdf)[0x421ecf]
/sbin/loader[0x416f7d]
/sbin/loader(main+0x129c)[0x40b6dc]
/lib64/libc.so.6(__libc_start_main+0xfd)[0x7f607e6575ed]
/sbin/loader[0x407cb9]
Comment 1 David Cantrell 2009-03-19 15:39:14 EDT
This is because some doPwMount() calls are passing NULL for the last parameter rather than always passing a double pointer.  In doPwMount(), I'm trying to dereference the last parameter as a double pointer, so when it's NULL...bang.

Preparing a new boot.iso to test with.
Comment 2 David Cantrell 2009-03-19 17:12:19 EDT
Patch sent to list for review.  Built a local boot.iso to test and it's working.  New boot.iso image for today's tree can be found here:

http://dcantrel.fedoarpeople.org/boot.iso

(13 more minutes to upload as of the time I'm posting this comment.)
Comment 3 James Laska 2009-03-20 09:23:30 EDT
No longer seeing this with anaconda-11.5.0.34.  Tested both i386 and x86_64 boot.iso's

4c2a5b812315ea6eae213f1284e72ca128653f7c8aa5eace8199930897b0d011  /tmp/boot-i386.iso
f1d86b33f0660c7365991aaf9a1feb87364903726c25dc1e3c323922494071bb  /tmp/boot-x86_64.iso
Comment 4 James Laska 2009-03-20 09:25:41 EDT
I'm running into bug#491326 now, but that's after the original SIGSEGV
Comment 5 David Cantrell 2009-03-20 15:43:00 EDT
Closing per comment #3.

Note You need to log in before you can comment on or make changes to this bug.