Bug 491193 - RFE: buildinstall caches packages for install root
RFE: buildinstall caches packages for install root
Status: CLOSED DUPLICATE of bug 458283
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Martin Gracik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-19 15:18 EDT by John Reiser
Modified: 2013-07-04 08:46 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-15 07:11:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Reiser 2009-03-19 15:18:45 EDT
Description of problem: buildinstall always downloads all packages needed for the install root.  When pungi creates install DVD for Fedora 11, then that is about 350MB, which takes non-ignorable time.  Instead, buildinstall should use a caching mechanism for packages that are required by the install root.  Perhaps the caching could coordinate with the pungi caching (/var/cache/pungi/rawhide/packages, etc.)


Version-Release number of selected component (if applicable):
anaconda-11.5.0.33-1.i586


How reproducible: always


Steps to Reproduce:
1.Compose an install DVD using recipe on manual page for pungi: pungi -c /usr/share/pungi/rawhide-fedora.ks --destdir=... --name myDVD --ver 11
2.Observe network traffic when pungi sub-invokes /usr/lib/anaconda-runtime/buildinstall
3.
  
Actual results: All packages necessary to construct the install root are downloaded by buildinstall, even though many of them are present already in /var/cache/pungi/rawhide/packages, and even though many of them are the same as in previous attempts.


Expected results: buildinstall uses an effective caching mechanism for packages that are required to build the install root.


Additional info:  This may be related to bug 481445 "revisor does not use yum proxy".
Comment 1 Chris Lumens 2009-04-14 15:11:02 EDT
Martin is starting to look at the script rewriting stuff, so it's best to reassign this one to him.  We can probably get most of the hard part of this done by using yum in buildinstall instead of our own stuff.
Comment 2 Martin Gracik 2010-11-15 07:11:12 EST

*** This bug has been marked as a duplicate of bug 458283 ***

Note You need to log in before you can comment on or make changes to this bug.