Bug 49123 - please add lixv.so and libXfdga86.so
please add lixv.so and libXfdga86.so
Status: CLOSED NOTABUG
Product: Red Hat Raw Hide
Classification: Retired
Component: XFree86 (Show other bugs)
1.0
All Linux
medium Severity low
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-14 03:50 EDT by Knut J BJuland
Modified: 2007-04-18 12:34 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-14 03:51:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Knut J BJuland 2001-07-14 03:50:56 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.7-pre3-xfs i686)

Description of problem:
please add ld --whole-archive -shared -o libXv.so libXv.a
ld --whole-archive -shared -o libXxf86dga.so libXxf86dga.a to spec file

How reproducible:
Always

Steps to Reproduce:
1.
2. try to run xine
3.
	

Additional info:
Comment 1 Mike A. Harris 2001-07-14 22:18:33 EDT
I dunno who resolved it NOTABUG, but it is NOTABUG. ;o)

Right now, and in the future also, there will not *ever* for any reason
at all be any XFree86 shared libraries added to our releases above and
beyond the base shared libs that build with XFree86 by default.

The reason for this is that the XFree86 team has decided which libs have
stable API's and which do not.  Those that are not shared yet are not
shared for a reason.  As such I have removed the shared libraries from
our build both for compliance with the XFree86 team's wishes, and also
to be compatible with Debian GNU/Linux and other distributions that ship
XFree86 as well.

Any software that requires these shared libs should be rebuilt to *not*
require them.  For backwards compatibility however we have included
the 4.0.3 shared libs so that apps built against them will function.

Future software that links against these shared libs will not be compatible
with Red Hat Linux, Debian Linux, default binary distributions of XFree86,
and other Linux vendors releases that follow common standards and aim for
cross platform compatibility.  Anyone who rebuilds X with extra shared
libs for themselves is breaking standards and is on their own.

Short version: don't do it.  ;o)

Note You need to log in before you can comment on or make changes to this bug.