Bug 491235 - rtl8187 driver won't resume
rtl8187 driver won't resume
Status: CLOSED DUPLICATE of bug 469461
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
10
i686 Linux
low Severity high
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-19 19:38 EDT by GeoffLeach
Modified: 2009-07-21 15:48 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-21 15:48:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description GeoffLeach 2009-03-19 19:38:00 EDT
Description of problem: The rtl8187 driver results in a failure to resume after hibernate. rmmod-ing the driver cures the problem


Version-Release number of selected component (if applicable):
kernel 2.6.27.12-170.2.5.fc10.i686

How reproducible: always


Steps to Reproduce:
1. pm-hibernate
2. punch power button
3. 
  
Actual results:

Nothing. Reboot required.

Expected results:

Restore config at time of hibernate.

Additional info:

Here's the stanza from lshw

*-usb
                   description: Generic USB device
                   product: RTL8187_Wireless_LAN_Adapter
                   vendor: Manufacturer_Realtek_RTL8187_
                   physical id: 1
                   bus info: usb@2:1
                   version: 1.00
                   serial: 001AEF0303E3
                   capabilities: usb-2.00
                   configuration: driver=rtl8187 maxpower=500mA speed=480.0MB/s
 
The problem was diagnosed using the procedure outlined in Documentation/power/basic-pm-debugging.txt. Section 1 hibernation tests all failed, requiring reboot. The freezer test succeeded. The devices test failed until the RTL8187
driver was rmmod-ed. After that, all tests succeeded.
Comment 1 John W. Linville 2009-03-20 11:22:52 EDT
This is the same as bugzilla.kernel.org 11887:

   http://bugzilla.kernel.org/show_bug.cgi?id=11887
Comment 2 John W. Linville 2009-07-21 15:48:40 EDT

*** This bug has been marked as a duplicate of bug 469461 ***

Note You need to log in before you can comment on or make changes to this bug.