Bug 491269 - i810 regression from fc9 to fc10 - half horizontal resolution display bug
i810 regression from fc9 to fc10 - half horizontal resolution display bug
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
10
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-20 03:03 EDT by Maciej Żenczykowski
Modified: 2009-06-18 12:55 EDT (History)
1 user (show)

See Also:
Fixed In Version: xorg-x11-drv-intel-2.7.0-7.fc11.x86_64
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-18 12:55:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Maciej Żenczykowski 2009-03-20 03:03:31 EDT
I have a Shuttle SG33G5M Deluxe box with an HDMI and VGA output.

# lspci -s 0:02.0 -nn -vvv
00:02.0 VGA compatible controller [0300]: Intel Corporation 82G33/G31 Express Integrated Graphics Controller [8086:29c2] (rev 02) (prog-if 00 [VGA controller])
        Subsystem: Holco Enterprise Co, Ltd/Shuttle Computer Device [1297:3106]
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
        Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 0
        Interrupt: pin A routed to IRQ 16
        Region 0: Memory at fdf00000 (32-bit, non-prefetchable) [size=512K]
        Region 1: I/O ports at ff00 [size=8]
        Region 2: Memory at d0000000 (32-bit, prefetchable) [size=256M]
        Region 3: Memory at fdc00000 (32-bit, non-prefetchable) [size=1M]
        Capabilities: [90] Message Signalled Interrupts: Mask- 64bit- Count=1/1 Enable-
                Address: 00000000  Data: 0000
        Capabilities: [d0] Power Management version 2
                Flags: PMEClk- DSI+ D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-

The HDMI output is connected to a HDMI-DVI converter [came with the box] which is plugged into a DVI-HDMI cable [which I already had] plugged into an Optoma HD70 Projector's (native 1280x720 @ 50 or 60 Hz) HDMI port.

This setup worked perfectly with Fedora 9 (automatically) at the native 1280x720 @ 60 Hz.

Relevant packages on Fedora 9 (everything including the kernel was fully yum updated, and the system was rebooted a day or two ago).

xorg-x11-drv-i810-2.3.2-3.fc9.x86_64
xorg-x11-server-common-1.5.2-3.fc9.x86_64
xorg-x11-server-utils-7.4-1.fc9.x86_64
xorg-x11-server-Xorg-1.5.2-3.fc9.x86_64

I performed a yum upgrade of the system to Fedora 10.  Everything went smoothly.

xorg-x11-drv-i810-2.5.0-4.fc10.x86_64
xorg-x11-server-common-1.5.3-15.fc10.x86_64
xorg-x11-server-utils-7.4-3.fc10.x86_64
xorg-x11-server-Xorg-1.5.3-15.fc10.x86_64

However after reboot the system comes up with garbled graphics (see lower for description of garbled).

I downgraded to:

xorg-x11-drv-i810-2.4.2-12.fc10.x86_64 from koji

(no other packages were changed) with no luck.

However a downgrade back to:

xorg-x11-drv-i810-2.3.2-3.fc9.x86_64 (from koji again, but this is the same package [by version number] that I originally had in Fedora 9)

fixes the problem (however killing the Xserver is not enough - a full reboot is needed).

Doubt this is relevant, but the kernel version of my box since the upgrade to f10 is (freshest from koji, only thing on this machine which isn't from the normal f10 repos)

# uname -a
Linux zeus.lan 2.6.27.20-170.2.54.fc10.x86_64 #1 SMP Thu Mar 19 01:28:20 EDT 2009 x86_64 x86_64 x86_64 GNU/Linux

I'm extremely willing to help troubleshoot, but the process is relatively painful, since a full reboot is needed each time - hence some pointers would be appreciated.

Now a description of the screen garbledness:

- the machine boots with a normal 640x480 @ 60 Hz white on black text console (no rhgb) - this worked and still works

- the machine switches into X and a diff between the previous /var/log/Xorg.0.log and the new one doesn't really show anything interesting (besides version numbers increasing)

- it properly detects the native 1280x720 @ 60 Hz resolution and (thinks) it switches into it - the System>Preferences>Hardware>Screen Resolution applet is convinced the screen is at 1280x720 @ 60 Hz.

- however, the projector claims to see only 640x720 @ 60 Hz.

- if you switch to (some) other video modes like 1152x864, the projector once again claims the computer is displaying only 576x864.

- however resolutions from 1280x960 upwards (1280x960, 1280x1024, 1400x1050, 1600x1200) are detected correctly and display correctly (well they get scaled, but that's expected since the projector is only natively 1280x720)

- the resolutions below 1280x720 seem flaky and above 1280x720 seem flaky - sometimes they work fine (besides the half resolution thing) sometimes they seem to have some sort of vertical synch issue, where single frames are randomly either at the correct location or about 100 pixels too high (or was it too low?)

- killing (and the resultant auto-restart) the X server doesn't change anything

- switching back to text mode results in 320x720 @ 60 Hz text mode (ie. half horizontal resolution once again) - with the white on black becoming bright pink on very dark pink (ie. additional pinkish tinge)

- downgrading the X video driver to the working f9 version and killing the X server doesn't fix the issue - it requires a full reboot - apparently whatever video card bits are getting twiddled aren't touched by the f9 i810 X driver init sequence

Based on the pinkish tinge of text mode I'm pretty sure this is not an issue with some sort of incompatibility with the projector (especially since it works fine with f9), but rather the video card is actually sending a bad signal.

In each case where the projector detects half the expected horizontal resolution, you literally see every second pixel of each row (but you see all the rows).  Makes reading a pain.  Ie. it's not showing the first half of the row, rather it's showing all odd pixels (or even - hard to tell).

How should I further troubleshoot/diagnose this - where should I look and at what?
Comment 1 Matěj Cepl 2009-04-24 17:11:57 EDT
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf, if available) and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf (if you have one) whatsoever and let X11 autodetect your display and video card? Attach to this bug /var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Maciej Żenczykowski 2009-06-13 15:07:27 EDT
I was out for a month and now that I'm back and Fedora 11 is out I've updated the system in question and the problem appears to be gone (with xorg-x11-drv-intel-2.7.0-7.fc11.x86_64 - I believe the package was renamed around Feb 24th 2009).  This probably means this bug can be closed.

However, I do have to pass kernel commandline option 'i915.modeset=0' since switching to graphical/fb text mode results in no video output.

We can probably close this?
Comment 3 Matěj Cepl 2009-06-18 12:55:49 EDT
I think so. Thanks for letting us know.

Note You need to log in before you can comment on or make changes to this bug.