This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 491279 - thunderbird does not log junk mail (zh_CN)
thunderbird does not log junk mail (zh_CN)
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: thunderbird (Show other bugs)
5.3
All Linux
low Severity medium
: rc
: ---
Assigned To: Jan Horak
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-20 03:49 EDT by Cao, Chen
Modified: 2009-04-15 04:02 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-15 04:02:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Cao, Chen 2009-03-20 03:49:30 EDT
Description of problem:
the locale is zh_CN.utf-8.
thunderbird does not log the junk mails, while "Enable junk filter logging" is checked, and thunderbird does mark the mail as junk automatically.


Version-Release number of selected component (if applicable):
thunderbird-2.0.0.21-1.el5.i386


How reproducible:
100% reproducible.


Steps to Reproduce:
1. set a mail account.
2. enable adaptive junk mail controls for the account, by
"Edit" -> "Account Settings" -> select the account to set -> "Junk settings", 
check "Enable adaptive junk mail controls for this account", and leave all the other options unchecked.
3. enable junk mail logging by:
"Edit" -> "Preferences" -> "Privacy", and check the box "Enable Junk filter logging"
4. use another account to send "junk mails". 
generally, mails with subject and content like "asdfadf" will be recognized as junk by thunderbird.
5. send mails to the testing account until thunderbird recognize the mail as junk.
6. check the junk filter log by:
"Edit" -> "Preferences" -> "Privacy" -> "Show log"
  

Actual results:
nothing logged even thunderbird marked lots of mails as junk.


Expected results:
there are logs about junk filter.


Additional info:
1.
account used to setting thunderbird:
name: fedorathunderb@gmail.com
password: redhatqa
2.
google server info:
imap.gmail.com (security: ssl)
smtp.gmail.com:587
3.
I tested thunderbird on stablesystem
4.
the content of the "i18n" file,
cat /etc/sysconfig/i18n
-------------
LANG="zh_CN.UTF-8"
SYSFONT="latarcyrheb-sun16"
-------------
Comment 1 Matěj Cepl 2009-04-07 09:32:51 EDT
Yes, unfortunately can fully reproduce.
Comment 2 Matěj Cepl 2009-04-10 08:16:54 EDT
(In reply to comment #1)
> Yes, unfortunately can fully reproduce.  

and no it doesn't matter what locale you are in.
Comment 3 Jan Horak 2009-04-15 04:02:45 EDT
It is fixed in TB 3.0b2. Since this is not critical issue we are not going to backport the fix to 2.0 version. The problem will be solved when RHEL starts to use TB 3.0.

Note You need to log in before you can comment on or make changes to this bug.