Bug 491283 - Kernel Panic for SATA drive disk with support for libsas.
Kernel Panic for SATA drive disk with support for libsas.
Status: CLOSED DUPLICATE of bug 483171
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.3
All Linux
low Severity urgent
: ---
: ---
Assigned To: David Milburn
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-20 04:30 EDT by Ying Chu
Modified: 2009-03-26 19:32 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-26 19:32:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
give a patch for fix the issue (1.03 KB, patch)
2009-03-20 04:30 EDT, Ying Chu
no flags Details | Diff

  None (edit)
Description Ying Chu 2009-03-20 04:30:41 EDT
Created attachment 335986 [details]
give a patch for fix the issue

Description of problem:
Kernel Panic for SATA drive disk with support for libsas.

Version-Release number of selected component (if applicable):


How reproducible:
Attached any SATA disk drive to SAS/SATA Host Controller.

Steps to Reproduce:
1.
2.
3.
  
Actual results:
last sysfs file: /devices/pci0000:00/0000:00:1e.0/0000:05:02.0/irq

Modules linked in: mvsas(U) libsas scsi_transport_sas autofs4 hidp nls_utf8 cifs rfcomm l2cap bluetooth sunrpc ip_conntrack_netbios_ns ipt_REJECT xt_state ip_conntrack nfnetlink iptable_filter ip_tables ip6t_REJECT xt_tcpudp ip6table_filter ip6_tables x_tables ipv6 xfrm_nalgo crypto_api cpufreq_ondemand acpi_cpufreq dm_mirror dm_multipath scsi_dh video hwmon backlight sbs i2c_ec button battery asus_acpi ac parport_pc lp parport snd_hda_intel snd_seq_dummy snd_seq_oss snd_seq_midi_event snd_seq snd_seq_device snd_pcm_oss snd_mixer_oss snd_pcm snd_timer i2c_i801 snd_page_alloc snd_hwdep i2c_core 3c59x floppy snd ide_cd sg pcspkr sky2 soundcore serio_raw cdrom mii dm_raid45 dm_message dm_region_hash dm_log dm_mod dm_mem_cache ahci ata_piix libata sd_mod scsi_mod ext3 jbd uhci_hcd ohci_hcd ehci_hcd

CPU:    1
EIP:    0060:[<00000000>]    Tainted: P      VLI
EFLAGS: 00010002   (2.6.18-128.el5 #1) 
EIP is at _stext+0x3fbfee10/0x3c
eax: f789807c   ebx: f789807c   ecx: f7898000   edx: f88ccf20
esi: 00000000   edi: f7898000   ebp: f789807c   esp: ec0b5cbc
ds: 007b   es: 007b   ss: 0068
Process scsi_wq_7 (pid: 3798, ti=ec0b5000 task=c1928550 task.ti=ec0b5000)
Stack: f88e4bb4 f88e6385 ec0b5d0c 00000000 f7898000 f789807c f88e6cd6 ec0b5dac 
       f78998ac f7899788 f7898000 ec000000 fafbfcfd 00000000 00000000 00000000 
       00000286 f789808c 00000000 00300020 00000000 00000001 ec0b5d14 ec0b5d14 
Call Trace:
 [<f88e4bb4>] fill_result_tf+0x11/0x12 [libata]
 [<f88e6385>] ata_qc_complete+0x117/0x12f [libata]
 [<f88e6cd6>] ata_exec_internal_sg+0x24a/0x3e0 [libata]
 [<f88e6f09>] ata_exec_internal+0x9d/0xa5 [libata]
 [<f88e726e>] ata_dev_read_id+0xd3/0x3ac [libata]
 [<c055516c>] get_devres_head+0x44/0x4c
 [<f88e8c54>] ata_bus_probe+0x1b0/0x421 [libata]
 [<f8874c8b>] scsi_alloc_sdev+0x12b/0x167 [scsi_mod]
 [<f8874de3>] scsi_probe_and_add_lun+0xd2/0x8c1 [scsi_mod]
 [<f88c8717>] sas_ata_init_host_and_port+0x54/0x81 [libsas]
 [<f88c7db8>] sas_target_alloc+0x2f/0x3e [libsas]
 [<f88758c5>] scsi_alloc_target+0x1f4/0x2d6 [scsi_mod]
 [<f8875ac3>] __scsi_scan_target+0xb1/0x58c [scsi_mod]
 [<c04a91c5>] sysfs_new_dirent+0x53/0x5d
 [<c04a9219>] sysfs_make_dirent+0x10/0x6c
 [<c04a8a31>] sysfs_add_file+0x51/0x6a
 [<c04a8a40>] sysfs_add_file+0x60/0x6a
 [<c04f8298>] acpi_pci_find_root_bridge+0x1e/0x45
 [<f88761eb>] scsi_scan_target+0x5f/0x73 [scsi_mod]
 [<f883c74f>] sas_rphy_add+0xd8/0xe3 [scsi_transport_sas]
 [<f88c45b6>] sas_discover_domain+0x374/0x3d2 [libsas]
 [<c041d7fe>] __wake_up+0x2a/0x3d
 [<c043189a>] run_workqueue+0x78/0xb5
 [<f88c4242>] sas_discover_domain+0x0/0x3d2 [libsas]
 [<c043214e>] worker_thread+0xd9/0x10b
 [<c041e3d7>] default_wake_function+0x0/0xc
 [<c0432075>] worker_thread+0x0/0x10b
 [<c043455d>] kthread+0xc0/0xeb
 [<c043449d>] kthread+0x0/0xeb
 [<c0405c53>] kernel_thread_helper+0x7/0x10


Expected results:


Additional info:
Comment 1 David Milburn 2009-03-26 13:40:48 EDT
Hi,

This looks like a duplicate of BZ 483171 which was fixed in -131.el5, would
you please try a later test kernel?

http://people.redhat.com/dzickus/el5/
Comment 2 Ying Chu 2009-03-26 19:25:55 EDT
it was, thanks.
Comment 3 David Milburn 2009-03-26 19:32:29 EDT

*** This bug has been marked as a duplicate of bug 483171 ***

Note You need to log in before you can comment on or make changes to this bug.