Bug 49129 - initscript thinks my gateway is DNS
initscript thinks my gateway is DNS
Status: CLOSED CURRENTRELEASE
Product: Red Hat Raw Hide
Classification: Retired
Component: dhcpcd (Show other bugs)
1.0
All Linux
high Severity high
: ---
: ---
Assigned To: Elliot Lee
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-14 14:11 EDT by Knut J BJuland
Modified: 2005-10-31 17:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-25 17:17:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Knut J BJuland 2001-07-14 14:11:10 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.6-2 i686)

Description of problem:
I have a adsl with Cisco 677 adsl modem. It works a route and gateway
without DNS

How reproducible:
Always

Steps to Reproduce:
1. start te pc
2.
3.
	

Actual Results:  iniscripte make a resolv.conf with gateway as name server
and copies my rigth resolv to resolv.conf.sv. Dns does not work but I gan
acess internet with ip adresse

Expected Results:  DNS should work

Additional info:

iniscripte 5.60 

my resolv.conf
search broadpark.com 
nameserver 193.75.75.193
nameserver 217.13.4.4
nameserver 193.71.1.2

gateway 10.0.0.1 
dhcp

I have gone back to initscripte from redhat 7.1
Comment 1 Pekka Savola 2001-07-22 15:47:38 EDT
Umm, initscripts 5.60 is older than what shipped with RHL71 (5.83)...
Comment 2 Knut J BJuland 2001-07-22 17:13:19 EDT
sorry initscript 6.02-1 had this error, I mistype it.
Comment 3 Pekka Savola 2001-07-22 17:57:12 EDT
Did you specify PEERDNS, MS_DNS1 or MS_DNS2 anywhere in the configuration?

What data is your DHCP server telling you?  Does it report proper nameservers?  If not, resolv.conf
nameserver data may get replaced with dynamic data obtained from dhcp.
Comment 4 Knut J BJuland 2001-07-23 01:23:41 EDT
My adsl-server does not have proper dns is connect to my ISP by using POP over
ethernet. It also is a DCHP server to my pc but is does not have dns. This is
provided by my ISP.
Comment 5 Pekka Savola 2001-07-23 02:22:44 EDT
The real question is whether your DHCP server gives the DNS addresses
(either automatically or manually), not whether they should be used or not.

You might want to check that out with 'pump -i eth0 -s'.
Comment 6 Knut J BJuland 2001-07-23 05:02:30 EDT
This is from pump -i eth0 -s, it has no dns.
Device eth0
	IP: 10.0.0.2
	Netmask: 255.255.255.0
	Broadcast: 10.0.0.255
	Network: 10.0.0.0
	Boot server 10.0.0.1
	Next server 0.0.0.0
	Gateway: 10.0.0.1
	Renewal time: Mon Jul 23 10:53:30 2001
	Expiration time: Mon Jul 23 10:55:45 2001
Comment 7 Knut J BJuland 2001-07-23 15:46:15 EDT
I upgraded to latest from rawhide, it hade the same problem. pump -i eth0 -d
could not display anything. I odd problemen why did resolve.conf.sv appear.
Comment 8 Pekka Savola 2001-07-23 15:54:19 EDT
As a workaround, you could set the nameservers in DHCP server as you would set them statically (193.75.75.193, ...); this
way, DHCP run on the client should set them properly.

This doesn't cure the actual problem though..

You could also try running using dhcpcd and not pump.

Comment 9 Knut J BJuland 2001-07-23 17:24:11 EDT
A workaround for me copy resolv.conf.sv over resolv.conf. Then I can use dns and
access the internet.  Though I can not configure my ISP nameserver, I don.t have
acces code. To solve this I have to edit my own machine. An workaround is to put
cp /etc/resolv.conf.sv /etc/resolv in startingscrip.
Comment 10 Pekka Savola 2001-07-23 17:35:03 EDT
.save is what is saved by the init script yes.  But this is not a real workaround, as resolv.conf will get changed at boot.

You do have access to your DHCP server, there is no need to access DNS itself; just add DNS servers to being
configured using DHCP.
Comment 11 Knut J BJuland 2001-07-23 18:06:25 EDT
I do have access to my adsl modem but I rather not start modify by using telnet.
How do I configurer eth0 to use dhcp instead of pump. As an workaround I have
gone back to redhat 7.1 initscript.
Comment 12 Knut J BJuland 2001-07-24 02:30:44 EDT
I read my /var/log/message and it was using pump. I removed pump but my problem
was there still. An solution is to make /etc/resolv.conf unwritablel even for
root.
Comment 13 Knut J BJuland 2001-07-24 02:49:31 EDT
I was able to duplicat this problem with initscript from redhat 7.1 by removing
pump. Somehow redhat 7.1 initscript use pump first while rawhide initscript use
dhcpcd. This problem lies in dchpcd  since it can not get proper DNS from my
ISP. Therfore I moving this bug to dhcpcd package.
Comment 14 Knut J BJuland 2001-07-25 16:04:22 EDT
An soultion to this problem would be to add an option to not let dchpcd
overwritte /etc/resolve.conf or use statical dns like my adsl-router.
Comment 15 Bill Nottingham 2001-07-25 16:15:19 EDT
Thos options already exist. See
/usr/share/docs/initscripts-<version>/sysconfig.txt, search for resolv.conf.

Assigning back to dhcpcd.
Comment 16 Knut J BJuland 2001-07-25 17:17:43 EDT
I put PEERDNS=no which solved my problem. I can now use pump -i eth0 -s , and I
get the same reulats as above. My adsl modem uses POP over ehernet while
servering as a DHCP/firewale witth statical DNS from my ISP provider.
Comment 17 Elliot Lee 2001-08-26 17:04:54 EDT
Although the cause of the problem wasn't discovered, a satisfactory workaround
was, and it's quite likely that the problem was caused outside of pump (e.g.
inside the gateway or ISP is my guess), so I am closing this.

Note You need to log in before you can comment on or make changes to this bug.