Bug 491292 - Cobbler buildiso produces an iso image that does not work on KVM and VMWare-ESX
Cobbler buildiso produces an iso image that does not work on KVM and VMWare-ESX
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: cobbler (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Michael DeHaan
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-20 05:23 EDT by Egon Kastelijn
Modified: 2009-03-20 08:02 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-20 08:02:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Egon Kastelijn 2009-03-20 05:23:28 EDT
Description of problem:
When a Cobbler iso image is generated on the Cobbler server and that iso image is used to boot a virtual guest on KVM or VMWare-ESX then the guest machine does boot, but hangs with the error:
FATAL: Could not load /lib/modules/2.6.27.5-117.fc10.i586/modules.dep: No such file or directory

Cobbler buildiso generates an initrd that does not contain the specified directory /lib/modules/2.6.27.5-117.fc10.i586/.
It does contain the directory: /lib/modules/2.6.27.5-117.fc10.i686.PAE/.

Info:
Cobbler server: Fedora10
Cobbler 'system to be installed': Fedora10 

Version-Release number of selected component (if applicable):
Name        : cobbler
Version     : 1.4.3
Release     : 4.fc10

How reproducible:
See below.

Steps to Reproduce:
1. Install Cobbler on Fedora10
2. Import Fedora10 into Cobbler as a distribution
   cobbler import --path=/var/www/html/linux/fedora/10/i386/ --name=Fedora-10-i386 --available-as=http://145.52.5.201/linux/fedora/10/i386/
2. Run the command 'cobbler buildiso --iso=/cobblertest.iso' on the Cobbler serer 
3. Boot the virtual guest from the generated iso image.
  
Actual results:
The guest machine is unable to start its network interface because it can not load the driver for the network interface.
On the 3rd console (ALT-F3) is the message:
FATAL: Could not load /lib/modules/2.6.27.5-116.fc10.i586/modules.dep: No such file or directory

Expected results:
A normal Cobbler-based install over the network.

Additional info:
Comment 1 Michael DeHaan 2009-03-20 08:02:18 EDT
The only supported VMware mechanism is koan "--virt".

There is no ESX support in koan at this time.  This is something many folks on the list/IRC have talked about adding, but has not been done yet for various implementation reasons.

Note You need to log in before you can comment on or make changes to this bug.