Bug 491301 - non-conffile-in-etc /etc/sysconfig/rhn-satellite-prep/etc/
non-conffile-in-etc /etc/sysconfig/rhn-satellite-prep/etc/
Status: CLOSED CURRENTRELEASE
Product: Spacewalk
Classification: Community
Component: Installation (Show other bugs)
0.6
All Linux
low Severity low
: ---
: ---
Assigned To: Miroslav Suchý
Red Hat Satellite QA List
:
Depends On:
Blocks: space13
  Show dependency treegraph
 
Reported: 2009-03-20 06:07 EDT by Miroslav Suchý
Modified: 2011-02-08 03:41 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-08 03:41:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Miroslav Suchý 2009-03-20 06:07:41 EDT
Description of problem:
rpmlint /tmp/spacewalk-build/rpmbuild-spacewalk-config-git-9c870c5a6070590c6e8ce7909bb336270d213c52/noarch/spacewalk-config-0.5.6-1.git.9c870c5a6070590c6e8ce7909bb336270d213c52.noarch.rpm
spacewalk-config.noarch: W: non-conffile-in-etc /etc/sysconfig/rhn-satellite-prep/etc/jabberd/s2s.xml
spacewalk-config.noarch: W: non-conffile-in-etc /etc/sysconfig/rhn-satellite-prep/etc/jabberd/sm.xml
spacewalk-config.noarch: W: non-conffile-in-etc /etc/sysconfig/rhn-satellite-prep/etc/jabberd/c2s.xml
spacewalk-config.noarch: W: non-conffile-in-etc /etc/sysconfig/rhn-satellite-prep/etc/rhn/cluster.ini
spacewalk-config.noarch: W: non-conffile-in-etc /etc/sysconfig/rhn-satellite-prep/etc/rhn/rhn.conf
spacewalk-config.noarch: W: non-conffile-in-etc /etc/sysconfig/rhn-satellite-prep/etc/tomcat5/tomcat5.conf

We do not want to mark this files as conffile since we *want* the to be replaced with package upgrade. So this files are not configuration files and should not be in /etc/ but rather somewhere in /usr as others templates.

Version-Release number of selected component (if applicable):
Spacewalk 0.5
Comment 1 Jan Pazdziora 2009-11-19 08:44:56 EST
Well, if we just use %config and not %config(noreplace), they will be replaced upon upgrade. Please complain if you disagree.
Comment 2 Miroslav Suchý 2009-11-19 09:03:25 EST
But if you put there pure %config, then you will get warning that you are using %config without (noreplace).

I suppose it comes down to if:
 - those files are config files (which means user can configure them) and then this warning can be waived
 - it is not configuration files, but rather template, and it should not be in etc, but rather in /usr/share
Comment 3 Jan Pazdziora 2010-05-04 05:14:44 EDT
Moving to space11.
Comment 4 Jan Pazdziora 2010-11-19 11:05:34 EST
Mass-moving to space13.
Comment 5 Miroslav Suchý 2010-11-20 08:53:03 EST
This has been solved as side effect of 491331.
/etc/sysconfig/rhn-satellite-prep is now /var/lib/rhn/rhn-satellite-prep
Comment 6 Tomas Lestach 2011-02-03 07:21:36 EST
Moving ON_QA ...
Comment 7 Tomas Lestach 2011-02-08 03:41:34 EST
This bug has been fixed in Spacewalk 1.3.

Note You need to log in before you can comment on or make changes to this bug.