Bug 491321 - RFE Wine Version 1.1.17
RFE Wine Version 1.1.17
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: wine (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Andreas Bierfert
Fedora Extras Quality Assurance
:
: RFE:wine (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-20 08:42 EDT by Thomas Kowaliczek
Modified: 2009-06-24 15:41 EDT (History)
6 users (show)

See Also:
Fixed In Version: 1.1.23-1.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-24 15:41:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
wine 1.1.23 spec (48.01 KB, text/plain)
2009-06-10 18:39 EDT, Michael Cronenworth
no flags Details
revised pulseaudio patch (11.69 KB, patch)
2009-06-10 18:41 EDT, Michael Cronenworth
no flags Details | Diff

  None (edit)
Description Thomas Kowaliczek 2009-03-20 08:42:43 EDT
RFE Wine version 1.1.17
Comment 1 Andreas Bierfert 2009-03-20 16:12:07 EDT
Should happen next week.
Comment 2 Thomas Kowaliczek 2009-03-29 14:54:51 EDT
Can you say me an release date of it please?
Comment 3 Remy Maucherat 2009-04-04 13:03:37 EDT
1.1.18 is out, I suppose 1.1.19 will be out next week. Wine is one of the few areas where Fedora is lagging a bit, we're more used to getting trunk builds than releases from one month ago ;)
WinePulse 0.24 should also be integrated I think (http://art.ified.ca/?page_id=40).

Andreas, do you need help with the Wine package maintenance ?
Comment 4 Fedora Update System 2009-04-07 16:27:44 EDT
wine-1.1.18-1.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/wine-1.1.18-1.fc9
Comment 5 Fedora Update System 2009-04-07 16:28:57 EDT
wine-1.1.18-1.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/wine-1.1.18-1.fc10
Comment 6 Fedora Update System 2009-04-09 12:17:55 EDT
wine-1.1.18-1.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update wine'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-3495
Comment 7 Michael Cronenworth 2009-06-09 23:34:08 EDT
1.1.23 has been released.

1.1.15 is still the "official" Fedora package.

1.1.21 is in koji, F11 only.

May we get a 1.1.23 package for F10 and F11?

Andreas, would you like a co-maintainer?
Comment 8 Michael Cronenworth 2009-06-09 23:36:31 EDT
*** Bug 481248 has been marked as a duplicate of this bug. ***
Comment 9 Michael Cronenworth 2009-06-10 18:39:36 EDT
Created attachment 347303 [details]
wine 1.1.23 spec

The only change was that the %{_libdir}/wine/msvideo.dll16 line changed to %{_libdir}/wine/msvideo.dll.so. Feel free to remove my name in the change log and add your own.

Also a revised pulseaudio patch was required. It's coming next.
Comment 10 Michael Cronenworth 2009-06-10 18:41:06 EDT
Created attachment 347304 [details]
revised pulseaudio patch

This is the revised pulseaudio patch. The Ro language resource file was slightly different.

This should get you a working 1.1.23 build for Fedora 10 (tested and built on my local system).
Comment 11 Andreas Bierfert 2009-06-11 11:26:45 EDT
Thanks for providing the pulsepatch... Would you mind sending me a copy via email and submitting it to the winepulse side (see spec file).

As to wine versions: As stated already, the problem is not me building and testing new versions usually on release day but more that people do not test the versions in bodhi and thus upgrades to not get pushed out. If you want to help it would be greatly appreciated to leave comments in bodhi so I can trust that things are not only working for me but also for other people.
Comment 12 Michael Cronenworth 2009-06-11 11:55:16 EDT
(In reply to comment #11)
> Thanks for providing the pulsepatch... Would you mind sending me a copy via
> email and submitting it to the winepulse side (see spec file).
> 

Why must I send you a copy via e-mail? I attached it to this bug. After comparing the pre and post patches I don't see any difference, but rpmbuild failed when applying the adding-pulseaudio-to-winecfg.patch file until I corrected it.

> As to wine versions: As stated already, the problem is not me building and
> testing new versions usually on release day but more that people do not test
> the versions in bodhi and thus upgrades to not get pushed out. If you want to
> help it would be greatly appreciated to leave comments in bodhi so I can trust
> that things are not only working for me but also for other people.  

There is no Wine package in updates-testing for 1.1.19, 1.1.20, 1.1.21, 1.1.22, or 1.1.23 for me to leave karma on. I would if I could.

Leaving them in Bodhi for months to sit and rot is not an ideal situation and Wine releases hardly break things these days anyway. You will find my sentiment is shared with most if not all QA folks. Will Woods will tell you directly that time doesn't fix bugs.
Comment 13 Remy Maucherat 2009-06-12 05:22:35 EDT
I don't see either the point of lagging wine releases by more than a month, and then letting builds rot in testing for weeks.

This is not the way most of Fedora operates.
Comment 14 Fedora Update System 2009-06-14 17:10:39 EDT
wine-1.1.23-1.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/wine-1.1.23-1.fc10
Comment 15 Fedora Update System 2009-06-18 07:55:08 EDT
wine-1.1.23-1.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update wine'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-6648
Comment 16 Thomas Kowaliczek 2009-06-18 18:23:02 EDT
when will come the f11 packages?
Comment 17 Fedora Update System 2009-06-24 15:41:03 EDT
wine-1.1.23-1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.