Bug 491322 - FTBFS: k3d-0.7.10.0-1.fc11 fails to build causes broken deps in rawhide
FTBFS: k3d-0.7.10.0-1.fc11 fails to build causes broken deps in rawhide
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: k3d (Show other bugs)
rawhide
All Linux
urgent Severity urgent
: ---
: ---
Assigned To: Denis Leroy
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-20 08:47 EDT by Alex Lancaster
Modified: 2009-03-23 09:48 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-23 09:46:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alex Lancaster 2009-03-20 08:47:22 EDT
Probably related to the GCC 4.4 change, k3d no longer builds, see a scratch build:

http://koji.fedoraproject.org/koji/taskinfo?taskID=1247517

get a bunch of errors like:

[  9%] Building CXX object k3dsdk/CMakeFiles/k3dsdk.dir/hints.o
cd /builddir/build/BUILD/k3d-source-0.7.10.0/b/k3dsdk && /usr/bin/c++   -DK3D_HAVE_SIGC_2_0 -DK3D_HAVE_EXPAT -Dk3dsdk_EXPORTS -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m64 -mtune=generic  -fPIC -I/builddir/build/BUILD/k3d-source-0.7.10.0 -I/builddir/build/BUILD/k3d-source-0.7.10.0/k3dsdk/gil -I/builddir/build/BUILD/k3d-source-0.7.10.0/b/k3dsdk -I/usr/include/glibmm-2.4 -I/usr/lib64/glibmm-2.4/include -I/usr/include/sigc++-2.0 -I/usr/lib64/sigc++-2.0/include -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/uuid   -o CMakeFiles/k3dsdk.dir/hints.o -c /builddir/build/BUILD/k3d-source-0.7.10.0/k3dsdk/hints.cpp
In file included from /builddir/build/BUILD/k3d-source-0.7.10.0/k3dsdk/attribute_arrays.h:23,
                 from /builddir/build/BUILD/k3d-source-0.7.10.0/k3dsdk/mesh.h:23,
                 from /builddir/build/BUILD/k3d-source-0.7.10.0/k3dsdk/gprim_factory.h:27,
                 from /builddir/build/BUILD/k3d-source-0.7.10.0/k3dsdk/gprim_factory.cpp:24:
/builddir/build/BUILD/k3d-source-0.7.10.0/k3dsdk/almost_equal.h: In member function 'const k3d::bool_t k3d::almost_equal<double>::operator()(k3d::double_t, k3d::double_t) const':
/builddir/build/BUILD/k3d-source-0.7.10.0/k3dsdk/almost_equal.h:149: warning: comparison between signed and unsigned integer expressions
/builddir/build/BUILD/k3d-source-0.7.10.0/k3dsdk/almost_equal.h:149: warning: comparison between signed and unsigned integer expressions
/builddir/build/BUILD/k3d-source-0.7.10.0/k3dsdk/almost_equal.h: In static member function 'static const k3d::int64_t k3d::almost_equal<double>::to_integer(k3d::double_t)':
/builddir/build/BUILD/k3d-source-0.7.10.0/k3dsdk/almost_equal.h:156: warning: dereferencing type-punned pointer will break strict-aliasing rules
/builddir/build/BUILD/k3d-source-0.7.10.0/k3dsdk/gzstream.cpp:71: error: 'EOF' was not declared in this scope
/builddir/build/BUILD/k3d-source-0.7.10.0/k3dsdk/gzstream.cpp: In member function 'virtual int k3d::filesystem::gzstreambuf::underflow()':

full build.log here:

https://koji.fedoraproject.org/koji/getfile?taskID=1247517&name=build.log

This should be fixed ASAP as it it causing broken deps in rawhide and soon-to-be F11-beta:

	k3d-0.6.7.0-9.fc11.i386 requires libMagickCore.so.1
	k3d-0.6.7.0-9.fc11.i386 requires libMagick++.so.1
Comment 1 Alex Lancaster 2009-03-20 09:03:34 EDT
Looks like there has been some communication to upstream from maintainer:

http://sourceforge.net/mailarchive/forum.php?thread_name=49B7887D.8020502%40poolshark.org&forum_name=k3d-development

I am testing the new 0.7.11.0 release to see if that helps at all.
Comment 2 Alex Lancaster 2009-03-20 09:14:38 EDT
No luck with 0.7.11.0:

http://koji.fedoraproject.org/koji/taskinfo?taskID=1251238

Bleh, does anybody upstream care about getting this package to work on Fedora?
Comment 3 Alex Lancaster 2009-03-20 09:15:56 EDT
One small change which is definitely required, regardless of other errors, is to add another BuildRequires:

BuildRequires:  uuid-c++-devel
Comment 4 Denis Leroy 2009-03-21 07:43:31 EDT
I spend a fair amount on time on this problem last week, it is a GCC 4.4 compilation issue with the boost library. As soon as I get back home tomorrow, I'll post a call for help on the mailing list, as I think we'll need help from the GCC maintainer to figure out this (very) complex C++ compilation error...
Comment 5 Kevin Kofler 2009-03-21 16:11:44 EDT
At line 81 of k3dsdk/gil/boost/gil/color_base_algorithm.hpp, there's a line like this:
static type       get(const ColorBase& cb) { return at_c<semantic_index>(cb); }

The problem is that at_c is ambiguous, as it matches not only the intended boost::gil::at_c template function, but also the boost::mpl::at_c template class. Try fully qualifying at_c, as in:
static type       get(const ColorBase& cb) { return boost::gil::at_c<semantic_index>(cb); }
Comment 6 Denis Leroy 2009-03-23 09:46:40 EDT
Kevin, thanks a lot for your help. That indeed fixed the problem.
Comment 7 Kevin Kofler 2009-03-23 09:48:39 EDT
Have you already requested an f11-beta tag to get the dependency fixed ASAP? (I'm not sure if it'll still get tagged, but it's worth trying.)

Note You need to log in before you can comment on or make changes to this bug.