Bug 491349 - File conflict for libwrap.a on ia64 multi-lib
File conflict for libwrap.a on ia64 multi-lib
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: tcp_wrappers (Show other bugs)
4.8
ia64 Linux
high Severity high
: rc
: ---
Assigned To: Jan Safranek
BaseOS QE
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-20 11:09 EDT by Alexander Todorov
Modified: 2009-12-02 05:49 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-18 16:37:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2009:1032 normal SHIPPED_LIVE tcp_wrappers bug fix update 2009-05-18 11:38:36 EDT

  None (edit)
Description Alexander Todorov 2009-03-20 11:09:11 EDT
Description of problem:
Installing i386 packages on ia64 causes file conflict for tcp_wrappers
Preparing...                ##################################################
	file /usr/lib/libwrap.a from install of tcp_wrappers-7.6-37.6.el4 conflicts with file from package tcp_wrappers-7.6-37.6.el4


Version-Release number of selected component (if applicable):
tcp_wrappers-7.6-37.6.el4/RHEL4.8 snap #1

How reproducible:
Always/ia64
Comment 3 Alexander Todorov 2009-03-23 11:45:28 EDT
Panu,
is this something to do with updated rpm version?
Comment 4 Alexander Todorov 2009-03-24 06:56:22 EDT
Scratch comment #2. tcp_wrappers did changed:
tcp_wrappers-7.6-37.4.i386.rpm -> tcp_wrappers-7.6-37.6.el4.i386.rpm
Comment 7 Jan Safranek 2009-03-30 09:25:13 EDT
This seems to be bug in RPM itself, I can't find anything wrong with the .spec file and generated package.
Comment 8 Alexander Todorov 2009-03-31 09:48:00 EDT
Panu,
is this an issue with rpm?
Comment 12 Jan Safranek 2009-04-03 04:34:15 EDT
Investigation so far: 

RPM thinks, that /usr/lib/ does *not* need to be relocated to /emul/ia32-linux/whatever. The directory contains libwrap.a and symlink libwrap.so -> ../../lib/libwrap.so.0.7.6.

The reason is, that neither libwrap.a nor libwrap.so has the right 'color', see lib/rpmfi.c:936 - color of the files is being copied to color of directories and the /var/lib/ directory ends with no color. Only 'colored' directories are relocated (i.e. directories containing colored files).

RPM read color of files from RPM header, i.e. rpmbuild created rpm file with wrong (?) colors.
Comment 15 Jan Safranek 2009-04-03 07:44:57 EDT
rpmbuild correctly guess .a file colors (RPMFC_STATIC|RPMFC_LIBRARY|RPMFC_ARCHIVE|RPMFC_INCLUDE), but on build/rpmfc.c:1578 all the colors are cleared and only few pass to outgoing RPM file header:

        /* XXX Make sure only primary (i.e. Elf32/Elf64) colors are added. */
        for (i = 0; i < c; i++)
            fcolors[i] &= 0x0f;

Maybe the RPMFC_LIBRARY color should survive... Libraries (either static or shared objects) should be always relocated to the right directory.
Comment 22 Jan Safranek 2009-04-09 07:13:00 EDT
Both static and dynamic libraries are in /lib now.
Comment 28 errata-xmlrpc 2009-05-18 16:37:24 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1032.html

Note You need to log in before you can comment on or make changes to this bug.