Bug 491369 - NFS over GFS issue (fatal: assertion "!bd->bd_pinned && !buffer_busy(bh)" failed)
NFS over GFS issue (fatal: assertion "!bd->bd_pinned && !buffer_busy(bh)" fai...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gfs-kmod (Show other bugs)
5.3
All Linux
low Severity high
: rc
: 5.5
Assigned To: Robert Peterson
Cluster QE
:
Depends On: 455696
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-20 12:45 EDT by Robert Peterson
Modified: 2011-01-13 18:21 EST (History)
18 users (show)

See Also:
Fixed In Version: gfs-kmod-0.1.34-15.el5
Doc Type: Bug Fix
Doc Text:
Under certain circumstances, using a Network File System (NFS) protocol with a Global File System (GFS) could fail with the following error: GFS: fsid=axqa01:gfstest.0: fatal: assertion "!bd->bd_pinned && !buffer_busy(bh)" failed With this update, a complex patch has been applied to resolve this issue, and the above error no longer occurs.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-13 18:21:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
RHEL5 crosswrite (18.93 KB, patch)
2009-04-01 16:16 EDT, Robert Peterson
no flags Details | Diff
Better, tested version of the patch (19.41 KB, patch)
2009-04-13 10:02 EDT, Robert Peterson
no flags Details | Diff
Patch that includes the 495514 addendum (19.93 KB, patch)
2009-04-17 09:54 EDT, Robert Peterson
no flags Details | Diff

  None (edit)
Comment 1 Robert Peterson 2009-04-01 16:16:49 EDT
Created attachment 337648 [details]
RHEL5 crosswrite

Here is a RHEL5 crosswrite patch.  I haven't tested it nor double-
checked it against the RHEL4 original.  I was merely curious as to
whether it solved bug #245024.  It did not.
Comment 2 Robert Peterson 2009-04-13 10:02:25 EDT
Created attachment 339321 [details]
Better, tested version of the patch

This is a better version of the patch.  Although I haven't tried the
failing scenario on it, it has at least gotten some run time with
general gfs operations, such as mounting, unmounting, simple file IO
and nfs exporting.  I've built an instrumented module, based on this
patch, for bug #471141.
Comment 3 Robert Peterson 2009-04-17 09:54:00 EDT
Created attachment 340012 [details]
Patch that includes the 495514 addendum

This patch is the same as the previous one, but it adds the
necessary fix for bug #495514.
Comment 5 Robert Peterson 2010-03-05 13:10:53 EST
Now that bug #455696 has had some time to mature in the field
perhaps we should target this for 5.6.
Comment 7 Robert Peterson 2010-09-21 18:12:22 EDT
This patch was tested on the roth-0{1,2,3} RHEL5 cluster on the
2.6.18-222 kernel.  It's a crosswrite from RHEL4.  I was
holding back on this one until it withstood the test of time,
because the changes are so pervasive, but since no problems have
been reported on RHEL4, it's time to ship its RHEL5 counterpart.

It was pushed to the RHEL56 branch of the cluster git repository
for inclusion into 5.6.  Since gfs-kmod is not shipped upstream
nor in RHEL6 at all, there are no upstream requirements.
Changing status to POST until we get this built into a gfs-kmod
package.
Comment 8 Robert Peterson 2010-09-22 10:24:27 EDT
Build 2775451 successful.  Changing status to Modified.
This fix is in gfs-kmod-0.1.34-15.el5.
Comment 10 Jaromir Hradilek 2010-12-01 09:51:35 EST
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Under certain circumstances, using a Network File System (NFS) protocol with a Global File System (GFS) could fail with the following error:

  GFS: fsid=axqa01:gfstest.0: fatal: assertion "!bd->bd_pinned
  && !buffer_busy(bh)" failed

With this update, a complex patch has been applied to resolve this issue, and the above error no longer occurs.
Comment 12 errata-xmlrpc 2011-01-13 18:21:59 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0089.html

Note You need to log in before you can comment on or make changes to this bug.