Bug 491373 - python-feedparser handles media:title tags wrong in two different ways
python-feedparser handles media:title tags wrong in two different ways
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: python-feedparser (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Konstantin Ryabitsev
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-20 13:10 EDT by Jonathan Kamens
Modified: 2009-09-18 20:21 EDT (History)
1 user (show)

See Also:
Fixed In Version: 4.1-5.el4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-16 16:31:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2009-03-20 13:10:33 EDT
python-feedparser handles media:title tags in RSS feeds wrong in two different ways.

First of all, it attempts to base64-decode their contents when the namespace schema says that they're entity-encoded.

Second, the contents of media:title overwrites the contents of title, so the entry title gets set wrong.

Both of these issues appear to be fixed in the current svn version of feedparser at http://code.google.com/p/feedparser/source/checkout.  I don't know if/when the author is going to be putting out a new official release, but is there any chance of pulling a new version from svn rather than waiting for him?

  jik
Comment 2 Jonathan Kamens 2009-03-20 13:17:12 EDT
And it's fixed in Debian (see the comment on http://code.google.com/p/feedparser/issues/detail?id=80).  There, that should motivate Fedora to fix it even if Mark Pilgrim doesn't put out a release.  Nothing like a little healty competition :-).
Comment 3 Jonathan Kamens 2009-03-20 14:18:20 EDT
The maintainer of rss2email also believes that the development version of feedparser is stable and recommends that people use it.  See http://rss2email.infogami.com/FAQ#1.
Comment 4 Bug Zapper 2009-06-09 08:27:36 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Jonathan Kamens 2009-08-07 08:24:22 EDT
*sigh* More than four months after I reported this, and there has been no visible action on the ticket, and it's still broken, and RSS feed parsing in python just broke on my system again because I upgraded from rawhide and the upgrade overwrote my local copy of feedparser.py.

PLEASE fix this.
Comment 6 Fedora Update System 2009-08-07 09:01:47 EDT
python-feedparser-4.1-10.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/python-feedparser-4.1-10.fc10
Comment 7 Fedora Update System 2009-08-07 09:02:15 EDT
python-feedparser-4.1-10.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/python-feedparser-4.1-10.fc11
Comment 8 Fedora Update System 2009-08-07 09:02:47 EDT
python-feedparser-4.1-5.el4 has been submitted as an update for Fedora EPEL 4.
http://admin.fedoraproject.org/updates/python-feedparser-4.1-5.el4
Comment 9 Fedora Update System 2009-08-07 09:03:11 EDT
python-feedparser-4.1-10.el5 has been submitted as an update for Fedora EPEL 5.
http://admin.fedoraproject.org/updates/python-feedparser-4.1-10.el5
Comment 10 Fedora Update System 2009-08-08 15:24:29 EDT
python-feedparser-4.1-10.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update python-feedparser'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-8378
Comment 11 Fedora Update System 2009-08-08 15:30:48 EDT
python-feedparser-4.1-10.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update python-feedparser'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-8397
Comment 12 Jonathan Kamens 2009-08-10 09:10:02 EDT
Please put it into rawhide.
Comment 13 Fedora Update System 2009-08-10 16:32:12 EDT
python-feedparser-4.1-10.el5 has been pushed to the Fedora EPEL 5 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update python-feedparser'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/EL-5/FEDORA-EPEL-2009-0256
Comment 14 Fedora Update System 2009-08-10 16:32:20 EDT
python-feedparser-4.1-5.el4 has been pushed to the Fedora EPEL 4 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update python-feedparser'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/EL-4/FEDORA-EPEL-2009-0250
Comment 15 Fedora Update System 2009-09-16 16:31:40 EDT
python-feedparser-4.1-10.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 16 Fedora Update System 2009-09-16 16:31:56 EDT
python-feedparser-4.1-10.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 17 Fedora Update System 2009-09-17 14:02:05 EDT
python-feedparser-4.1-10.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 18 Fedora Update System 2009-09-18 20:21:14 EDT
python-feedparser-4.1-5.el4 has been pushed to the Fedora EPEL 4 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.