Bug 491381 - Can't use AES encryption in qcow2
Can't use AES encryption in qcow2
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: qemu (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Woodhouse
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-20 13:39 EDT by Miloslav Trmač
Modified: 2009-03-25 07:53 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-25 07:53:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Miloslav Trmač 2009-03-20 13:39:06 EDT
Version-Release number of selected component (if applicable):
qemu-img-0.9.1-10.fc10.x86_64
kvm-74-10.fc10.x86_64

Steps to Reproduce:
1. qemu-img create -f qcow2 foo.img 100M
2. qemu-kvm -m 128 -hda foo.img 
=> qemu window opens, system starts booting (and fails because there is no OS installed)
3. qemu-img create -e -f qcow2 foo.img 100M
   (note: no password prompt - I'd sort of expect one)
4. qemu-kvm -m 128 -hda foo.img
=> qemu-kvm just sits there, no window opens, no prompt appears.  strace shows
   a loop of
        select(0, [], [], [], {0, 10000})
Comment 1 Eduardo Habkost 2009-03-20 13:52:16 EDT
There was some monitor rework done by Jan Kiszka upstream, but I don't know if the new code entered the Fedora package. There were two patches I've sent to fix a similar issue, but before the monitor rework. They are on this thread:

http://article.gmane.org/gmane.comp.emulators.qemu/37762
Comment 2 Mark McLoughlin 2009-03-25 07:53:01 EDT
Thanks for the report. I've confirmed this is broken in F10.

With rawhide, it works for me using '-monitor stdio':

qemu-kvm -S -monitor stdio -vnc :1 -m 128 -hda foo.img
QEMU 0.10.0 monitor - type 'help' for more information
(qemu) cont
ide0-hd0 (foo.img) is encrypted.
Password: ****
(qemu) quit

Without '-monitor stdio', you need to hit Ctrl-Alt-2 to get to the qemu monitor and you'll see that you've been prompted for the password.

Closing as fixed in rawhide because we're unlikely to fix it in F10.

Note You need to log in before you can comment on or make changes to this bug.